IRC channel logs

2017-06-19.log

back to list of logs

<artyom-poptsov>Hello Guilers!
<artyom-poptsov>I got tired of exporting 'SSH_AUTH_SOCK' variable manually in REPL so I just add some Guile-SSH procedures to address the problem with OpenSSH agent interaction: https://github.com/artyom-poptsov/guile-ssh/commit/c4ec82cfa808024743871aa2013909a70fee5a8a
<void_pointer>artyom-poptsov: that is a major usability improvement (seems like a pain to have to type manually more than once and such a thing shouldn't require doing it manually anyways)
<artyom-poptsov>void_pointer: Agreed.
<paroneayea>oops
<paroneayea>just had the activitypub test suite freeze up while doing a request to something that needs to make a request back to it
<paroneayea>turns out?
<paroneayea>(web client) blocks, so 8sync/suspendable ports prevents the thing on the other end from requesting back
<paroneayea>wingo: would there be any harm in having open-socket-for-uri in (web client) be nonblocking?
<paroneayea>though! I guess I could set it nonblocking myself, if I pass in #:port...
<paroneayea>I'll try that tomorrow morning...
<catonano>sneek later tell paroneayea some time ago you pointed to a talk by Gerrald Sussmann about his adaptive computation concept. Could you point me again to it ? I'd lie to suggest it to someone but I can't find it again
<sneek>Okay.
<MaliRemorker>It's again me and the build systems. It seems that the one safe-ish way to detect where the heck Guile modules reside is to use ${pkgdatadir}/$GUILE_EFFECTIVE_VERSION (after a call to GUILE_PROGS macro in configure.ac).
<MaliRemorker>Btw, i just cloned the GNU Shepherd repo, it sets guilemoduledir to ... "${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION" which doesn't exist, at least not in my installs of Guile
<ArneBab_>could be interesting: A quick primer on human-factors evidence in programming language design: https://quorumlanguage.com/evidence.html ← state of the art!
<MaliRemorker>of course, this may not matter if Shepherds creates those subdirs :)
<nalaginrut>ArneBab_: good to read (although I dislike a language use integer rather than int)
<ArneBab_>nalaginrut: note also the really weak data on this: 22 robust papers in 35 years…
<ArneBab_>nalaginrut: I asked for the full results to be able to do sort of an evaluation of Scheme with that.
<CustosLimen>What would set this _LIBC - I checked config script and don't see it setting it? https://git.savannah.gnu.org/cgit/guile.git/tree/lib/regex_internal.h?h=v2.0.11#n113
<civodul>CustosLimen: this is Gnulib code imported from the GNU libc
<civodul>when building libc, the _LIBC macro is defined
<civodul>otherwise it's not
<CustosLimen>when building with libc I guess
<civodul>"when building libc", not "when building with libc"
<CustosLimen>hmm
<CustosLimen>so that will never be set when compiling guile ?
<civodul>essentially it's code that's meant to compiled within glibc, or outside glibc
<civodul>right
<CustosLimen>see I'm trying to figure out if the memory leak I found is particular to solaris (that does not use gnu libc) - but if _LIBC is never set it should happen on linux also
<CustosLimen> https://public.etherpad-mozilla.org/p/ofACqZqOUp
<CustosLimen>or well -it should happen always if RE_ENABLE_I18N is defined
<CustosLimen>added patch to the bottom
<CustosLimen>still present in latest git version also - just used 2.0.11 because that is where we observed the problem
<CustosLimen>anyway will submit a bug report
<CustosLimen>man the only good thing about solaris is umem+mdb
<CustosLimen>really dissapointed by the trash alternatives to this on linux
<dsmith-w`>Greetn's
***dsmith-w` is now known as dsmith-work
<nalaginrut>ArneBab: unless they're doing very carefully and slow research, anyway, computer science is a rapid changing area, a 10 years book/paper maybe outdated soon
<nalaginrut>of course, exclude the classic one
<paroneayea>sneek: later tell catonano well I'm not sure which one I linked you, if you mean propagators, probably https://www.youtube.com/watch?v=mwxknB4SgvM but there are also: https://www.youtube.com/watch?v=arMH5GjBwUQ https://www.youtube.com/watch?v=O3tVctB_VSU https://vimeo.com/151465912
<sneek>paroneayea, you have 1 message.
<sneek>paroneayea, catonano says: some time ago you pointed to a talk by Gerrald Sussmann about his adaptive computation concept. Could you point me again to it ? I'd lie to suggest it to someone but I can't find it again
<sneek>Got it.
<dsmith-work>paroneayea: That message you left for catonano looks failry long. Might be truncated.
<dsmith-work>paroneayea: Note that the bot does replay messages in order, so you can split a long message into several messages and they will be delieverd properly.
<paroneayea>sneek: (if previous truncated) there are also: https://www.youtube.com/watch?v=arMH5GjBwUQ https://www.youtube.com/watch?v=O3tVctB_VSU https://vimeo.com/151465912
<sneek>So noted.
<paroneayea>oops
<paroneayea>augh
<paroneayea>sneek: later tell catonano: (if previous truncated) there are also: https://www.youtube.com/watch?v=arMH5GjBwUQ https://www.youtube.com/watch?v=O3tVctB_VSU https://vimeo.com/151465912
<sneek>Okay.
<ArneBab>nalaginrut: the question which follows is: how to become a classic? ☺
<lottin>hello everyone
<lottin>how do can i execute a procedure step by step?
<lottin>i set a breakpoint with ,bt
<lottin>when i call the procedure, it triggers the debugger
<lottin>but the commands ,s and ,n don't enter the procedure
<lottin>all i can do is ,finish
<lottin>what am i doing wrong?
<ijp>,bt doesn't set a breakpoint, it gives a backtrace
<ijp>assuming that was a typo, I'm going to need an example
<lottin>sorry, i meant ,break
<ijp>so what's the procedure like?
<lottin>it takes 2 arguments and the body is a named let, but i can't post it here
<lottin>it's too long
<lottin>,n and ,s say
<lottin>Step into #<frame 7ffdd82f5b40 #<procedure process-file-names (lst num-ext)>>
<ijp>so it's working
<stis>hey guilers!
<lottin>no because it doesn't step in
<lottin>it just shows that line
<lottin>again and again
<ijp>how do you know it isn't stepping in?
<lottin>because it doesn't move forward
<ijp>what doesn't move forward
<lottin>i want to execute the instructions in the procedure
<ijp>e.g. are you not seeing the frame # change? that could just indicate the frame is being reused due to tail recursion
<ijp>are the ,locals not changing? that could be a mistake in your procedure
<lottin>no ,locals says no local variables
<lottin>and the frame doesn't change
<lottin>ok now the frame has changed
<ijp>like I say, the frame might not change if you have a loop
<lottin>i had to step 6 times
<lottin>yes it's a loop
***michaniskin_ is now known as michaniskin
<Muto>Hello, hello! I'm having some trouble generating a site with Haunt. Actually, I'm having trouble using Haunt in general, I get a "nq code for module (haunt ui)" error. Can anyone help?
<Muto>("no code for module", not "nq code")
<davexunit>Muto: sounds like your guile load path is not configured properly
<Muto>davexunit: I installed Guile 2.0 with the APT command. I'm not really used to using the load-path prefix, how can I configure it, if you don't mind me asking?
<davexunit>GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH need to be set
<davexunit>where did you install the haunt modules?
<OrangeShark>Muto: how did you install haunt? With `./configure && make && sudo make install`?
<Muto>davexunit: I installed Haunt from source with make, yes.
<Muto>Oop
<Muto>OrangeShark: Yes that's how I built Haunt.
<Muto>davexunit: I installed Haunt in /usr/local/bin/haunt
<OrangeShark>by default, that doesn't install it in the normal guile load paths.
<Muto>OrangeShark: Ah, I see, so should I just use the "cp" command to copy the haunt file to my module path?
<davexunit>Muto: that's the executable, but where are the modules?
<davexunit>Muto: no
<davexunit>sounds like you didn't specify an installation prefix
<davexunit>so `/usr/local` was used as the default
<Muto>davexunit: Ah, hold on, I have them here, let me just find the module folder. Also ah I see
<Muto>davexunit: Okay I think my module path is: /usr/local/lib/guile/2.0/ccache/haunt
<davexunit>that's the compiled module files
<davexunit>there are source files, too
<davexunit>export GUILE_LOAD_COMPILED_PATH=/usr/local/lib/guile/2.0/ccache
<davexunit>there's your first env var that you need to set
<Muto>davexunit: Alright
<Muto>davexunit: Aha! Thanks!
<davexunit>you need to set GUILE_LOAD_PATH though
<davexunit>so locate the source files
<davexunit>otherwise it won't work
<Muto>Ah, alright
<Muto>davexunit: Okay, /usr/local/share/guile/site/2.0/haunt. These look like some source files.
<davexunit>export GUILE_LOAD_PATH=/usr/local/share/guile/site/2.0
<Muto>export GUILE_LOAD_PATH=/usr/local/share/guile/site/2.0
<Muto>Oops
<Muto>This is... Not a terminal.
<Muto>Alright. Is that all?
<davexunit>yup
<Muto>Alright, I'll try it out, thanks a bunch!
<davexunit>np
<ijp>paroneayea: I *think* my rewrite has been successful
<paroneayea>ijp: yay
<paroneayea>ijp: details for the curious? :)
<ijp>I was able to reuse some functions for computing dominance in (language cps utils), and that made getting the nesting straightforward
<ijp>A side effect of this is that the inliner is no longer necessary for compilation to work
<paroneayea>ijp: nice :)
<ijp>The code is still pretty fugly, but I can clean it up
<paroneayea>great news ijp
<paroneayea>ijp: \\o/
<ijp> http://shift-reset.com/pastes/map-fixed.js.html is the code that was previously broken
<ijp>hopefully I can change tack in the next day or so
<paroneayea>ijp: happy to see the progress. Look forward to hearing more throughout the week :)
***evhan` is now known as evhan
<ArneBab>ijp: nice! What is the scheme-variable?