IRC channel logs

2017-06-16.log

back to list of logs

<slyfox>'GUILE_AUTO_COMPILE=0 ./meta/guile' did work though
<slyfox>looks like the problem is around bytecode generation
<spk121>slyfox: OK. Maybe try GUILE_AUTO_COMPILE=0 ./check-guile?
<mekeor>i get an error "lambda*: invalid argument list in subform" while defining a function, using define*, map, lambda and a keyword argument. any help? – code: http://sprunge.us/ZiGH ; error: http://sprunge.us/fOOH
<ijp>#: not :#
<mekeor>damn, a typo
<mekeor>thank you :)
***whiteline_ is now known as whiteline
***whiteline_ is now known as whiteline
<wingo>ijp: i think many of those primitives map to things that asm.js uses; dunno
<kolama>Hi, I've got some issues compiling guile. Actually, I got it compiling but now it segfaults.
<kolama>It is because of a macro scm_is_eq
<kolama>it seems this macro performs a load from something that is not a pointer (but a value).
<kolama>Any documentations about the defines of GUILE (there are a lot of them...) ?
<civodul>heya wingo!
<dsmith-work>Happy Friday, Guilers!!
<spk121>dsmith-work: hi
<MaliRemorker>Possibly a dumb question: is .guix-profile/share/guile/2.2 my guile's installation SITEDIR ?
<MaliRemorker>according to the info docs , it should be PREFIX/share/guile/site
<MaliRemorker>but there is no such subdir in .guix-profile/share/guile
<MaliRemorker>furthermore, all the sources are under .guix-profile/share/guile
<civodul>MaliRemorker: yes and no :-)
<MaliRemorker>civodul: i thought that's the answer
<civodul>"sitedir" is kind of deprecated
<MaliRemorker>ah
<civodul>heh
<MaliRemorker>so how do i search for GUILE module dirs?
<civodul>especially with Guix where you'll never install to Guile's PREFIX/share/guile/site
<MaliRemorker>from autoconf
<civodul>Guile provides a couple of Autoconf macros for that
<MaliRemorker>yes, they do not work
<civodul>like GUILE_MODULE_AVAILABLE
<MaliRemorker>since they refer to pkgconfig
<MaliRemorker>oh
<MaliRemorker>well, let me bring to your attention that GUILE_SITE_DIR macro
<civodul>well GUILE_PKG does indeed rely on the pkg-config Autoconf macros
<civodul>yeah, don't use it :-)
<MaliRemorker>hahahaha
<MaliRemorker>ok :)
<civodul>i mean don't use GUILE_SITE_DIR
<MaliRemorker>basically, your pkgconfig file is screwed up
<MaliRemorker>:)
<civodul>we should update the manual i guess
<civodul>my pkgconfig file?
<MaliRemorker>not yours
<MaliRemorker>"yours"
<MaliRemorker>i mean whoever wrote the build system for guile 2.0 and later
<civodul>so what's wrong with guile-2.0.pc?
<civodul>or guile-2.2.pc
<MaliRemorker>sitedir points to a non-existant directory
<civodul>oh?
<MaliRemorker>yeah
<civodul>hmm it does exist here
<MaliRemorker>sitedir=/gnu/store/5zx29y44nrqj0s8h3jlvlj82k8hj4dxs-guile-2.2.2/share/guile/site/2.2
<MaliRemorker>from .guix-profile/lib/pkgconfig/guile-2.2.pc
<civodul>this very directory exists on my laptop :-)
<civodul>oh no?
<MaliRemorker>are we using the same guix?:)
<civodul>hmm
<MaliRemorker>btw, it also does not exist on a custom gule 2.0 install
<civodul>no you're right, sorry
<civodul>anyway, "sitedir" is not the right thing
<MaliRemorker>yeah, now i got it
<civodul>so just ignore it and be done with it :-)
<MaliRemorker>thanks
<civodul>if you're working on a new project, i would suggest borrowing the Autoconf stuff from recent projects
<MaliRemorker>i was looking into artanis
<MaliRemorker>the newest version
<MaliRemorker>:)
<civodul>guile-git, guile-gcrypt, shepherd, guix, etc.
<civodul>ok
<MaliRemorker>sure, thanks
<civodul>yw!
<OrangeShark>I really need to finish that blog post on setting up a guile project with autotools and also contribute a template to ArneBab's project setup tool
<civodul>that would be nice
<OrangeShark>davexunit: the cert on your website expired
<davexunit>OrangeShark: yeah, I know. thanks, though.
<davexunit>people keep emailing me and stuff. haven't had time to fix it.
<OrangeShark>ah okay
<dsmith-work>Speaking of Templates, Martin Grabmueler (sp?) make one of these once.
<dsmith-work>I thought it was in Guile, but I don't see it.
<kolama>hello, I finally manage to cross-compile guile for Android (still some bugs but I can display a string).
<kolama>Just I wanted to tell the devs setlocale always return NULL with Android.
<kolama>And I think it would be a good idea to put init_throw before init_random (Actually, if the locale is unknown, the global variable needed for the throw have to be set before we can use any throw function, otherwise on ARM, it sets to zero (or not), and leads to a SEGFAULT.)
<kolama>and the configure script generated by automake has some bugs, especially to find the right path to the dependencies libraries, this is because the {prefix} is use instead of a user defined path.
<catonano>kolama: not everybody is always here. I would suggest you to write this report of yours on the dev mailing list
<catonano>I didn't know that someone was working on porting Guile on Android
<catonano>It's important that this info get stored in a easily retrievable format somewhere
<kolama>catonano: Fine, I will reports those problems on the dev mailing list. But I've got to suscribe to it first.
<catonano> kolama: yes, you have to subscribe first
<ijp>I realise today that my "inlining" module is misnamed. Since the move to cps-soup it is no longer strictly an optimisation / js-prettifier, but necessary to rebuild the scoping for variables
<ijp>funny how that worked out
<ijp>case-lambda compiles properly again
<ijp>Anyone have a decently complex, *purely numeric* function, lying around I can check? (not ackerman :) i.e. only loops, comparisons, arithmetic, lists
***Amynka_ is now known as Amynka
<catonano>davexunit: would you mind making a temporary repo of your blog to some reachable place like github or gitlab ? I'd like to clone it and then tweak it until it becomes my blog. Rigt now your git is unusable because of that certificate issue
<davexunit>catonano: try `git clone git://dthompson.us/blog.git`
<davexunit>ACTION goes afk
<ijp>wingo: is there some helper for working out which expressions rely on which variables in cps?
<ijp>I need it to get nesting right for conts
<ijp>I think compute-defs-and-uses might be what I want
<ijp>hmm, it has the information I want, but I'd need a reverse lookup for defs, and then use that to create the tree, or I guess a forest
<ijp>not a forest, a dag family
<ijp>surely this is just another dominance calculation, so the information must be in there somewhere
<ijp>I think this is as easy as doing a depth first search. When deciding if a child is a "proper" child (i.e. doesn't also have an intervening ancestor), you just check all the backlinks to see if they have been processed already. If so, it is. Otherwise, pass
<ijp>this assumes there are no "weird diamonds", but I think that is safe
<ijp>or if it isn't, you should still get something that makes topological sense
<ijp>no, you wouldn't, you'd need to make a choice
<ijp>basically a topological sort
<ijp>ACTION despairs at writing his daily log
<ijp>not topsort, transitive reduction