IRC channel logs

2017-05-25.log

back to list of logs

<Apteryx>Hello Guile!
<Apteryx>I'm trying to debug a function, and the REPL hangs after I do: ,next
<Apteryx>Maybe I should try in the terminal. Geiser seems a bit flaky, at least on Guix.
<Apteryx>If I blindy type ,q I saw there was an error, but Geiser failed to refresh the buffer.
***ertesx is now known as ertes
<Apteryx>Any way to list the sources in Guile REPL? Like the usual 'l' or 'll' of other debuggers.
<amz3>héllo #guile!
<amz3>catonano_: hi!
<catonano_>amz3: hi :-)
<amz3>catonano_: did you have glimpse at my screencast, wdyt?
<amz3>s/glimpse/a look/
<amz3>no worries if you did not look at it
<catonano_>shortly. It' s too fast and it glimpses on configuration. I' m less advanced than that
<catonano_>for example
<amz3>ok
<nalaginrut>I've fixed problems of artanis-docker, now it's ready to use https://github.com/bopjiang/artanis-docker
<catonano_>I discovered recently that no one uses guix pull in guixsd, they all use a link to a git checked out master branch guix
<amz3>catonano_: except me then, because I still use guix pull :-)
<catonano_>I could grasp more o fthe languages if system administration and configuration wasn' t so harsh
<amz3>catonano_: that's what I've read too
<catonano_>eh ;-)
<catonano_>now, for example
<catonano_>I' ve been asked to do some web scraping, for an "emergency"
<amz3>catonano_: sorry, to re about the screencast. So you think it should be slower?
<catonano_>yes it should be slower
<catonano_>in my opinion
<amz3>catonano_: yes
<catonano_>of course
<catonano_>you should ask someone else too ;-)
<amz3>catonano_: right now it more shows my skills that anything else
<catonano_>so, for this scraping I' ve been asked to do
<amz3>catonano_: yes, what about scraping?
<catonano_>"scrapy" is not packaged in Guix, so I' m using a Fedora box. I have to install Emavs bits and pieces to work with Python
<catonano_>Emacs
<catonano_>it' s always a ton of this system related crap before it comes to coding
<catonano_>it's frustrating !
<catonano_>yes it shows your skills ;-)
<catonano_>Also, you should make the font dimension in your terminal bigger
<catonano_>I had to squint
<amz3>catonano_: what's the purpose of the scraping task exactly?
<amz3>catonano_: can you use guile?
<catonano_>the scraping is for a conference. This one http://e-privacy.winstonsmith.org/
<catonano_>I could use Guile, yes, but I' m not versed in guile scheme
<amz3>catonano_: the screencast is not educational
<catonano_>In python I know scarpy exists, in guile... I wouldn' t know where to start
<amz3>I am not into scraping, that said I had a look at scrapy and don't understand where it helps. It seems to me you only need an html parser and xpath to extract interesting parts
<amz3>imo obviously
<amz3>catonano_: re system related crap, i sympathize
<catonano_>amz3: you' re making me curious
<catonano_>amz3: what is xpath ?
<amz3>I think you will hit the same wall, I've hit regarding the use of sxpath tho
<catonano_>is it this one ? https://www.gnu.org/software/guile/manual/html_node/SXPath.html
<amz3>it's a DSL to query XML documents
<amz3>yeah, sxpath is the scheme DSL
<catonano_>amz3: so which wall did you hit ?
<amz3>I know xpath as used in scrapy, but I can not map xpath to sxpath easily (I think sxpath is broken somehow)
<amz3>oh scrapy does use css selectors now
<catonano_>amz3: I can' t afford explorations. I have to deliver "RIGHT NOW" ;-)
<amz3>catonano_: oh, ok then go ahead use scrapy
<amz3>I must dive into this sxpath issue and at least report a bug
<amz3>if there is one
<catonano_>amz3: not bad, I' d say https://imgur.com/a/lQh8N
<nikita1>nalaginrut: hello!
<nikita1>I'm still fighting with the problem of exceeding number of simultaneous database connections in Artanis...
<nalaginrut>nikita1: please try the latest commits, you can set db.pool=fixed
<nalaginrut>or db.pool=increase
<nalaginrut>it's not documented yet, but you may read config.scm
<nalaginrut>and you may decrease db.poolsize
<nalaginrut>the original design is changed, we may not need work-queue length anymore, but it's not decided, anyway, DB pool size was decided by work queue length, but now it's decoupled to db.poolsize
<nalaginrut>thanks SO_PORTREUSE, we don't have to dispatch 64 continuations as a set to different CPU to take advantage of multi-cores
<amz3>Here is a video where I try to explain how my fullstack scheme framework works https://youtu.be/aC0_Br9KWP4
<amz3>paroneayea: I had a look at the feature you requested (which IIRC that the backend renders the content of the page before the frontend takes control) and it's not easy aka. I don't have a solution right now)
<schemer77>hello. can I somehow use the procedures from 'Arrays as arrays of arrays' with guile 2.0?
<amz3>why do you not use guile 2.2 ?
<schemer77>amz3: becauce my project makes use of guile-gnome
<amz3>I think guile gnome was updated to work guile 2.2 but I might be wrong, daviid will know better, but he is not connected yet
<schemer77>amz3: it may have to be updated in guix then
<rekado>amz3: what problems do you have with sxpath?
<rekado>amz3: I have some experience with it. Works very well for me.
<amz3>I don't recall correctly I will ping when I get back to it
<amz3>chatbot is difficult!
<amz3>let's go shopping!
<nalaginrut>amz3: are you writing a siri?
<amz3>already look up the web for chatbot stuff, there not much, this is field where guile can shine
<amz3>nalaginrut: not exactly
<amz3>nalaginrut: I want to provide a REPL-like interface for my blog
<amz3>but usinga more natural language that scheme (aka. I am setting up predefined set of key phrases that triggers some commands)
<amz3>I am looking for the path of least resistance regarding how to input posts
<daviid>amz3: paroneayea wrote a mini bot to test 8sync iirc
<paroneayea>daviid: amz3: 8sync's manual includes a tutorial on how to write an irc bot :)
<paroneayea> https://www.gnu.org/software/8sync/manual/html_node/Tutorial.html#Tutorial
<amz3>daviid: yeah, but it use websocket, which I can get working using my framework
<paroneayea>mudsync uses websocket :)
<paroneayea>and even has chatbots! :)
<amz3>to be honest I am not buying the mudsync message passing style thing
<paroneayea>that's fine
<amz3>paroneayea: that's the future :)
<paroneayea>8sync style message passing you mean probalby :)
<amz3>yes
<paroneayea>mudsync uses it too of course
<paroneayea>CSP and Actors are the two big concurrency theories/approaches
<paroneayea>and so, take your pick :)
<amz3>daviid: btw, someone was asking about guix support for guile-gnome
<paroneayea>I like the advantage that actors have that you can spread computation across many processes/machines easily though
<amz3>paroneayea: that's the actore approach I still don't fully grasp
<amz3>but I can't give much more feedback, as I did not read the code yet
<amz3>even I read the manual IIRC
<daviid>amz3: what guix support for guile-gnome? afaict guile-gnome is in guix already
<amz3>daviid: yes, but it use guile 2.0
<amz3>daviid: and schemer77 needs to use some array procedure only found in guile 2.2
<daviid>amz3: guile-gnome compiles and works fine with 2.2, so the guile-gnome package manager for guix could 'just' build another package or update the existing one...
<janneke>paroneayea: silly question, mediagoblin is not an alternative to mythtv/xbmc/kodi but for the interwebs, right?
<paroneayea>janneke: right, it's not really a home theater solution
<paroneayea>more of an alternative media *publishing* platform.
<davexunit>a home theater program could fetch stuff from mediagoblin, that would be cool
<janneke>paroneayea: a friend asked me about open source thingies for their home theater/music streaming wants
<daviid>ACTION liked that idea
<paroneayea>davexunit: right, it could be a nice backend or server, but you'd want another client
<janneke>and /me suddenly felt veeeeerrrry silly that i had never considered mediagoblin
<paroneayea>you could probably build an activitypub client