IRC channel logs

2017-05-23.log

back to list of logs

<paroneayea>yay
<paroneayea>rekado: got a multipart message writer working now, too :)
<reepca>Is it possible to have syntax-rules transform a form into nothing, not even '()? So for example (begin (display "hi") (nothing-inator foo bar baz)) => (begin (display "hi"))?
<reepca>I've got a recursive macro whose base case I would like to make be having zero parameters rather than one.
<reepca>(would make it a lot easier on macros that in turn use that macro)
***ertesx is now known as ertes
<amz3>io #guile
<amz3>re guile-git, the buggy checkout commit was all about typos
<OrangeShark>hello
<amz3>OrangeShark: o/
<amz3>m-o: ping
<OrangeShark>hello amz3, what have you been working on?
<amz3>OrangeShark: today I am working on guile-git
<amz3>I mean I fixed the 'checkout' bindings
<amz3>now you can 'checkout' a branch based on its name
<amz3>i just pushed the code
<amz3>in a branch
<OrangeShark>oh, it not in master yet?
<amz3>I'd like to synchronize with m-o who is working on guix integration
<OrangeShark>oh okay
<m-o>amz3: great !
<amz3>OrangeShark: it was is master, but for some reason a few typos slipped into master
<amz3>m-o: so what do you need from guile-git to get your work on guix going?
<amz3>right now the 'checkout' code is in a branch
<amz3>OrangeShark: I think I did not told you that m-o has commit access to the repository
<m-o>ok, for now the (guix git) binding is operational (is used 'reset hard' instead of 'checkout')
<m-o>the only thing missing is the right integration with guix pull
<amz3>m-o: are you working on 'guix pull'?
<amz3>ah ok
<amz3>m-o: can i help?
<m-o>that's why (guix git) was reverted on guix master
<m-o>yes totally: this problem needs to be solved https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26987
<m-o>to summarize (guix build pull) builds all .scm files, Ludo has added a snippet to remove files depending of guile-ssh if guile-ssh is not present
<m-o>but this does not work
<m-o>so we need first to fix this and then exclude all the files depending of guile-git if guile-git is missing (for now only (guix git))
<m-o>that solved, my patch can be un-reverted
<m-o>as I'
<m-o>as I'll be afk for 1 week, feel free to solve this problem :)
<amz3>oh
<amz3>to be honest, I am not very confortable contributing to guix itself
<m-o>no problem :) anyway, this problem is quite tricky I'll need Ludo assistance
<amz3>m-o: let me know if you need something specific in guile-git that you can't or don't want to do
<m-o>amz3: ok thanks, for now it's all good but it may happend later, when improving (guix git) !
<amz3>so maybe we should do release merge feature/checkout branch and do a release
<amz3>I am not confortable doing the release.
<amz3>it's quite a ceremony that I am not used to
<amz3>yet
<amz3>at least not GNU-style
<OrangeShark>amz3: typing `make dist` would create the release
<civodul>yeah, "make distcheck" even
<civodul>should be minimum hassle
<civodul>amz3: out of curiosity, you're not comfortable contributing to Guix because of the conventions, reviews, etc.?
<civodul>it's useful feedback for us
<civodul>we're aware that it's not as simple as it could be, but it's always good to know how other hackers feel about it!
<OrangeShark>civodul: oh neat, distcheck even runs the tests and makes sure everything works.
<civodul>yes, very handy :-)
<amz3>civodul: I am not confortable because it's a big project
<amz3>civodul: and the gnu commit message style that I don't know
<amz3>civodul: actually reviews is plus
<amz3>civodul: actually reviews is a plus
<civodul>ok
<civodul>thanks for the feedback
<OrangeShark>amz3: I feel similar when trying to contribute to large projects. Need to try to overcome it, it isn't so bad :)
<amz3>also, i have the feeling that I make everybody loose time, as I am not sure I want to commit to the project
<amz3>basically I am not sure I want to be guix contributor, so I don't want to waste the time of the knowledgeable to teach me...
<paroneayea>o/
<OrangeShark>hello paroneayea
<davexunit>yo yo
<civodul>amz3: i think it's ok to ask for guidance when joining a project; this is not "waste of time" for the established contributors
<paroneayea>hm that's interesting :)
<paroneayea>one interesting side effect of this rewriting optimization
<paroneayea>(let ((foo (bar)))
<paroneayea> foo)
<paroneayea>being rewritten to just
<paroneayea>(bar)
<paroneayea>is that if you were doing a multi-value return in (bar), technically you would think only one value would be returned from the let
<paroneayea>but now it's possibly multiple
<nalaginrut>paroneayea: hmm, I think this should be a problem, but Guile never check the multi return and only bind the first value
<stis>tja guilers!
<paroneayea>nalaginrut: I guess would only be a problem if you did something like a call-with-values outside of the let expecting a single value
<nalaginrut>paroneayea: but let-values won't do that inline optimizing
<paroneayea>nalaginrut: yup that's true
<paroneayea>I don't think this is a big problem
<paroneayea>it's something I just realized this morning while at the REPL :)
<nalaginrut>Guile is not strict to rnrs, sometimes I wonder how it's lucky enough to work successfully ;-P
<paroneayea>don't confuse optimal standards conformance with optimally correct behavior :)
<spk121>Cool. I'm writing to the systemd journal from Guile. :-)
<amz3>\\o/
<stis>heya amz3:
<stis>spk121: nice!