IRC channel logs

2017-05-14.log

back to list of logs

<paroneayea>trying to decide how I feel about $ in match
<paroneayea>I think not wild about it
<paroneayea>the main reason being that it makes the abstraction provided by the interface of the record more frail
<paroneayea>the ordering of slots becomes important, which seems like it should be hidden by the record's abstraction
***Guest24478 is now known as micro`
***ertesx is now known as ertes
<daviid>folks, is the following expected: http://paste.lisp.org/+7FFJ
<daviid>how a tipo can make you appear funny (or not...): '... did I kissunderstand the manaual' instead of '... did I missunderstand the manual' :):)
<reepca>see section 6.9.4.1 line 70 of the manual: "When ‘#:key’ is used together with a rest argument, the keyword parameters in a call all remain in the rest list."
<daviid>reepca: ah ok, I did missread that part: this is a bit weird imo, I wonder why maintainers implemented this this way
<brendyyn>How could I go about hooking guile in to weston so I could write a zmp_input_method client in Guile?
<amz3`>io all!
<amz3`>what is weston as the wayland software?
<brendyyn>amz3`: the official implementation of it i guess
<brendyyn>since wayland's like a protocol or something
<brendyyn>I don't even know how to make bindings so I gotta figure that out
<brendyyn>Or maybe it's about making weston a program with guile in it?
<brendyyn>I mean, does this involve modifying the program (weston) to have guile as an extension language, or does it involve writing a guile program that somehow loads up the program?
<amz3`>I will look up that, IIRC weston communicates over a pipe with the other programs
<brendyyn>amz3`: Like with Chickadee, I need help getting started so I can start playing around, otherwise I have no idea what to di.
<amz3`>brendyyn: I was no very helpful with chickadee!
<amz3`>actually I was misleading
<amz3`>anyway, I will try to find something regarding this wayland issue
<brendyyn>amz3`: Well I'm a lonesome autodidact, I need to chat to people on IRC to talk myself through problems
<amz3`>:)
<amz3`>no problem
<amz3`>brendyyn: what is zmp_input_method?
<brendyyn>amz3`: zwp, sorry. I read on a blog that is the way to write input methods in weston https://blogs.s-osg.org/basics-input-methods-weston/
<amz3`>this article is rather short..
<brendyyn>Well there isn't much on the internet about wayland/weston yet
<amz3`>indeed
<amz3`>I remember reading about the subject some time ago, just I can't remember what stopped me from porting guilewm to wayland
<amz3`>reading the man page of weston doens't provide any interesting https://github.com/wayland-project/weston/blob/master/man/weston.man
<amz3`>except that module seems to be loaded using 'dlopen'
<amz3`>they have this kind of files documentation a 'protocol' but I don't find explanation about what this protocol is https://github.com/wayland-project/weston/blob/master/protocol/weston-screenshooter.xml
<amz3`>wayland is a *protocol* and its implemenetation
<amz3`>but I don't know how it relates to dbus
<amz3`>The faq mention d-bus https://wayland.freedesktop.org/faq.html#heading_toc_j_3
<amz3`>there is a manual https://wayland.freedesktop.org/docs/html/
<amz3`>brendyyn: please come to #wayland and explain what you want to do there
<amz3`>brendyyn: please come to #wayland and explain what you want to do there
<amz3`>brendyyn: ?
<brendyyn>amz3`: Sorry my internet had a cry
<amz3`>brendyyn: ping
<amz3`>ah ok
<amz3`>It happens here too
<amz3`>brendyyn: like i said, come to #wayland to ask your question
<amz3`>I made a list of features of NLP framework http://paste.lisp.org/display/346605
<amz3`>some appears several times :/
<brendyyn>amz3`: http://www.jlekstrand.net/jason/projects/wayland/language-bindings-guide/
<amz3`>brendyyn: I am busy doing something else, but we can chat
<amz3`>brendyyn: based on that article, what do you need to do?
<amz3`>maybe I can guide in the new steps regarding your new findings
<amz3`>it seems you need to bind using foreign function interface lib wayland
<brendyyn>amz3`: Write guile bindings to libwayland, convert xml stuff?
<amz3`>I am not sure whether it's possible to autogenerate the bindings using the xml stuff
<amz3`>brendyyn: it seems like that
<amz3`>brendyyn: but to get started look up a simple call like 'wayland_version()' function to bind manually
<brendyyn>If I do (find-files "." "."), does the first . mean current directory, and is the second one a regex?
<brendyyn>hmm, actually it maybe just be a guix procedure, so i should ask there
***mjl_ is now known as mjl
***x1n4u- is now known as x1n4u
***random-nickname is now known as random-nick
<qq>d'you mind me writing a line from guile into the cah room ?
<qq>xchat plugin ... ;-)
<qq>pretty neat that guile plugin to xchat
<qq>I can't think of any .scm that would be interesting to see running in here as a plugin.
<manumanumanu>qq: I have written quite a lot of plugins for weechat in guile
<qq>I see.
<qq>what could be an interesting function ? banning people I don't find interesting at all.
<manumanumanu>the most useful thing is one that changes to the server window whenever I idle for too long. Otherwise It won't show me a last-read line nor show me whether I have been mentioned by name
<manumanumanu>I also have a thing logging who is online and active when for a channel I admin on another network
<manumanumanu>which also shows me wheneve someone is supposeldly connected using another nick (to help counter trolls)
<qq>well OK
<manumanumanu>do you have any functionality you miss or anything you would like=
<manumanumanu>?
<manumanumanu>that is the first thing you should ask yourself
<qq>I wish I could think of sth. interesting... well maybe some coupling IRC with bitmessage
<qq>weechat as well as xchat have guile plugins
<manumanumanu>I used to write IRC bots in ever new language :) For that my favourite was actually ruby though, and iirc there is actually a pretty neat ruby framework for writing irc bots.
<qq>or bring KDE's "KNewStuff" together with IRC, like for guile snippets swapping among schemers
<qq>I consider ruby #1 too. but guixSD is packages with guile, so ...
<qq>guix packager written in guile
<manumanumanu>The most fun thing I have ever written was a markov chain bot that constantly trained itself on whatever I was saying. I used to let it reply to a message every now and then
<qq>OK but that sounds like sth. wasting ppls time IMHO
<amz3`>manumanumanu: is it written in guile?
<manumanumanu>meh. it's IRC, and it is not like it was a serious channel. It was a really fun project, especially since it was the first time I used markow chains
<qq>think so. the packages are in .scm anyway
<amz3`>Yes, it indeed it sound interesting
<amz3`>manumanumanu: if it's written in guile, I'd like to package it with other NLP tools I write
<amz3`>if that's possible
<qq>amz3 what do you mean ?
<manumanumanu>amz3`: nope, that was mostly ocaml with some python to connect it with weechat
<qq>guix is similar to the "nix" packager, avail for debian even
<amz3`>qq: I am writing a NLP framework in guile and I am interested by markov chain code
<qq>NLP ? sry ?
<manumanumanu>I could see if I could write something. I am bored atm
<qq>neuro lingo ?
<amz3`>qq: Natural Language Processing
<amz3`>qq: sorry
<qq>oic
<manumanumanu>amz3`: do you have a project page?
<qq>sure just publish your NLP schemes as a guix and nix package ( a .scm file)
<manumanumanu>amz3`: why would you use markow chains with NLP?
<amz3`>manumanumanu: sort of https://github.com/amirouche/Culturia and also there is pieces in https://github.com/amirouche/guile-link-grammar
<amz3`>manumanumanu: for generating text noise
<qq>I hope no one finds your noise generator and spams bitmessage with it
<amz3`>manumanumanu: it's not very useful I know, but markov chains are also the basis of a theorical of graphical logic or something called Probabilistic Logic Network
<qq>ok
<amz3`>qq: yes, that's a dangerous tool
<amz3`>qq: basically, it's the field of text generation
<manumanumanu>amz3`: I'll see if I can write something. I have the source code lying around. If I find the time I can clean it up and make it more general. maybe you will find it useful
<qq>I got the artanis webserver framework, written in guile, to work.
<amz3`>I made a list of things that I'd like to have http://paste.lisp.org/display/346605
<amz3`>qq: !
<amz3`>right now I can only *put together* csv parsing and named entity recognition, also I have a handy database
<amz3`>the ease of use of sqlite with the power of mysql
<Apteryx>Hello Guile! In the Guile Reference manual, under the node "7.2.5 Time" (POSIX section), how am I supposed to from the `tm' object (broken down time, IIUC) ?
<Apteryx>s/to from/to form/
<amz3`>Apteryx: what's the question?
<amz3`>Apteryx: do you want to know the number of seconds since epoch?
<Apteryx>I want to format a time-difference as "seconds.miliseconds"
<amz3`>I use that to get the seconds since epoch: (define (now)
<amz3`> (time-second (current-time)))
<amz3`>idk sorry
<Apteryx>OK, no worries
<Apteryx>From the example apparently a "broken down time" can be gotten with: (localtime (current-time))
<manumanumanu>hae you checked srfi-19?
<manumanumanu> https://www.gnu.org/software/guile/manual/html_node/SRFI_002d19-Time.html
<Apteryx>manumanumanu: Yes, but it seems I'm better served by POSIX for ease of formatting it into a specific string.
<manumanumanu>welll... date->string is pretty good as well, no?
<manumanumanu>if you want milliseconds at least
<manumanumanu>posix is only seconds iirc
<Apteryx>manumanumanu: I'll take a second look, thanks :)
<manumanumanu>Apteryx: https://www.gnu.org/software/guile/manual/html_node/SRFI_002d19.html has all the sub-sections listed
<manumanumanu>just (import (srfi srfi-19)). Don't be fooled that guile already has some of the methods imported in the default environment
<manumanumanu>or (use-modules (srfi srfi-19))
<manumanumanu>Good night!
<amz3`>I should rename my project guile-nlproc
<amz3`>maybe it will make me more focused
<qq>I a scheme noob
<qq>only goofed around with guile for 1 day
<amz3`>welcome
<amz3`>I am reading that https://wingolog.org/archives/2016/02/04/guile-compiler-tasks
<qq>cool
<qq>spot the problem:
<qq>(use-module (artanis artanis))
<qq>took me 30 min to figure out
<amz3`>what do you mean?
<amz3`>you paste artanis two times instead of one?
<qq>nope
<manumanumanu>you are missing an s
<qq>rite
<amz3`>yep
<qq>the missing s took me 30 min to find LOL
<amz3`>that a typing mistake you get use to it sooner or later
<qq>as a scheme noob
<amz3`>i have the issue in every language i pratice
<amz3`>typoc check is in my coding habit
<qq>still tough for a noob
<amz3`>but I still get bitten
<qq>ruby sometimes gives friendlier err msgs
<amz3`>that's not the case i think
<qq>at least what they claim
<amz3`>what's really hurty cognitive understanding is that the stack trace behave differently
<amz3`>I mean it formatted differently
<qq>ya
<qq>also ruby goes back & forth in the src sometimes
<qq>execution flow
<amz3`>I have to leave
<qq>oki
<amz3`>sorry, see you later
<qq>cu
<Apteryx>manumanumanu: Good night!
<qq>gn
***ertesx is now known as ertes