IRC channel logs

2017-05-07.log

back to list of logs

<davexunit>brendyn: calling 'sleep' like that is a bad idea. will totally screw up the game loop.
<davexunit>what you really want is to make a coroutine instead
<davexunit>which the manual touches upon in the "Scripting" section
<brendyn>davexunit: Thanks
<paroneayea>hm
<paroneayea>daviid: obviously I must be doing something wrong! But it seems like ./configure isn't finding guile in guile-squee
<paroneayea>maybe I'm being stupid.
<paroneayea>daviid: pushed up a guix.scm
<paroneayea>maybe try with guix environment -l guix.scm --pure
<paroneayea>and then try ./autogen.sh && ./configure
<paroneayea>it doesn't seem like it finds guile... I wonder why?
<daviid>paroneayea: this is the very well known problem of AC_LOCAL
<daviid>paroneayea: let me check
<daviid>you are on devel then right?
<daviid>because here make distcheck pass
<paroneayea>daviid: yep, on devel
<daviid>ah, I know!!! paroneayea we have to copy the latest (there was a bug I fixed in, in guile.m4
<daviid>could you do that and try, i'm in a library that closes in a few min
<daviid>any time i'll have to leave
<paroneayea>daviid: sure, I'll copy the one from pubstrate, thanks
<daviid>I would take the latest gule.m4 from master
<paroneayea>hm
<paroneayea>using guile.m4 from guile-sjson still doesn't work, even though guile-sjson does ./configure fine
<daviid>i have the bug here as well
<daviid>let me coy the latest guile.m4 then
<paroneayea>using the configure.ac from guile-sjson instead seems to work
<paroneayea>daviid: this fixes it:
<daviid>paroneayea: ok, i can reproduce here, i'll look at it tomotrow if that's ok with you, then will let you know
<paroneayea> http://dpaste.com/0Z5BZZ6
<daviid>oh, i see therror
<daviid>I'm sorry fault is mine, they must be no ',' between the PROGS values
<paroneayea>daviid: np! that seems to be it indeed
<paroneayea>daviid: I will push up a fix.
<daviid>GUILE_PKG([2.2 2.0]), not GUILE_PKG([2.2, 2.0])
<paroneayea>daviid: do you think the GUILE_PREFIX_DIR and etc do something useful that I commented out?
<daviid>rerun autogen
<paroneayea>and what about the version number on GUILE_PROGS ?
<paroneayea>ACTION autotools noob
<daviid>paroneayea: we would need to change the pre-inst-env then
<daviid>actually we should rename env.in -> pre-inst-env.in
<daviid>paroneayea: you can check the vars used are in here: am/guile.am
<daviid>so, we need GUILE_GLOBAL_SITE and GUILE_SITE_CCACHE, which are addons to the guile.m4 'delivered' by guile; so, i'll need to work a bit on this, I'm sorry, will do so tomorrow
<paroneayea>daviid: no need to apologize :)
<paroneayea>daviid: I'll push up the simple result of just removing the comma tonight, and we can catch up more tomorrow. Feel free to push changes.
<daviid>if you don't comment any thing and use 'my' guile.m4', then it compiles here
<daviid>if you wish, I can immediately commit the latest guile.m4
<daviid>that I updated here just now
<daviid>taking the one fro gule will ask for some more work, which I can do but not exactly now
<paroneayea>daviid: no need to push the guile.m4 tonight
<paroneayea>just removing the comma "fixed" it
<paroneayea>so take your time to look at what other changes should be done
<daviid>are you sure?, because it did fails to find 2.1.x previsouly...
<daviid>and the one I can push is definitely better
<daviid>let me paste, then you can see
<paroneayea>daviid: ok, I pushed a couple of commits that weren't related to the guile.m4, so feel free to make that change, but you might want to git pull first
<paroneayea>daviid: I trust you
<paroneayea>I'm too tired to look at m4 code :)
<daviid>ah ok, let me pull and push
<daviid>pushed
<daviid>paroneayea: you can pull... have to leave now, bb tomorrow
<daviid>paroneayea: hey, I'm glad you finally looked at devel :):)
<daviid>ciao!
<paroneayea>daviid: :)
<paroneayea>later!
<MaliRemorker>is there anything like uint/sint-list->bytevector, but for the floating point numbers?
<MaliRemorker>i'm trying to avoid dealing with specific bit size of a numeric type when dealing with numeric arrays, instead using the default single and double precision numbers on the platform
<manumanumanu>good question.
<manumanumanu>i want to know that as well
<manumanumanu>MaliRemorker: is this helpful? https://www.gnu.org/software/guile/manual/html_node/Bytevectors-as-Floats.html
<MaliRemorker>manumanumanu: not really, as those functions interpret an already created bytevector as single, or double
<MaliRemorker>i didn't find a function to create a single/double precision bytevector without specifying its bit size
<MaliRemorker>i'd like to have something like (make-single-bytevector ...) and (make-double-bytevector ...)
<amz3>brendyn: did you look at my code?
<brendyn>amz3: Yeah it was complicated so I haven't understood it yet.
<brendyn>not sure what ref and ref* do
<brendyn>And why you got rid of my arrays
<amz3>ref allows to retrieve a key inside an assoc e.g. (ref `((name . "amz3) (age . 32)) 'name) returns "amz3
<amz3>ref* does the same thing for nested assoc
<amz3>ref* is not used in you implementation
<amz3>the current implementation
<amz3>using assoc list I create a sparse matrix index by the position in the board
<amz3>it could be done using a list instead of an assoc and not require ref/set procedures, it'a limited trade in terms of complexity because you still need paginate the whole list to find a cell inside the universe, since it's not ordered it's not fast
<amz3>I removed arrays because arrays are mutable by default and what the algorithm needs is an immutable datastructure
<amz3>it rendered universe per universe the new state, it's unlike 'graph walking' where the next results immediatly takes into account the new state
<amz3>in the game of life, the universe evolves by step, a step must be complete to be a valide universe for computing the next state
<amz3>well, it's better explained on wikipeida
<amz3>if you are familiar a little with javascript, ref* does the same as immutable getIn and set* does the same as setIn https://facebook.github.io/immutable-js/docs/#/Map/getIn
<amz3>I had the idea first, this time I did not copy facebook, but it's a good description of the behavior or ref* and set*
<amz3>something should be noted, if instead of a list you assign a vector to 'new' variable you can bring back the array-set calls
<manumanumanu>MaliRemorker: Can't that be trivially implemented using those methods? You'd have to write it yourself, but you have the tools
<amz3>héllo all ;)
<manumanumanu>MaliRemorker: something like this: https://pastebin.com/L3an7Cvb
<manumanumanu>I haven't tested those, though.
<amz3>there is a json imap it's called jmap http://jmap.io/
<manumanumanu>amz3: yup. Developed by fastmail.com I think
<manumanumanu>MaliRemorker: you should probably use the procedure (native-endianness) instead of my hard-coded symbols though.
<amz3>manumanumanu: exact
<dadinn>hi all
<dadinn>a question: Is there an EDN data format reader for Guile?
<dadinn> https://github.com/edn-format/edn
<amz3>dadinn: I don't know such thing
<amz3>how crazy difficult it must be to create a standard like imap \\cc paroneayea
<amz3>btw paroneayea what are the probable extensions of the federation standard you are working on?
<amz3>can it support for instance, say, some apps like soundcloud or hackernews?
<kkebreau>i am hacking roblox
<CharlieBrown>I was reading the manual on GObject and evaluated the example code. I got this error: http://paste.debian.net/931222/
<kkebreau>ACTION returns to computer and regrets leaving it unattended in the presence of children
<amz3>ahah
<amz3>looks like good stuff
<amz3>this roblox thing
<amz3>CharlieBrown: it says: Unbound variable: <gtk-window>
<amz3>OrangeShark: m-o is developper of the guie-git project
<amz3>OrangeShark: do we change the name into guie-libgit2?
<amz3>what is needed to do the change?
<CharlieBrown>amz3: What's <gtk-window> supposed to be in the docs?
<amz3>maybe the doc is not complete
<amz3>seems like a base object that you must have in code from a previous snippet
***ertesx is now known as ertes