IRC channel logs

2017-05-01.log

back to list of logs

<amz3`>programming is hard!
<mejja>Let's Go Shopping!
<amz3`>:)
<amz3`>that's what basically I do, looking for a library that does *exactly* what I want
<amz3`>I know, I will retry what did not work yesterday hoping, planets aligns and it works today :)
<amz3`>sometimes it works
<amz3`>not this time!
<manumanumanu>amz3`: I'm feeling stupid over here as well. I am trying to get all divisors of a number from it's prime factors
<manumanumanu>and I'm failing miserably
<manumanumanu>all because I don't think my project euler solution is fast enough
<amz3`>oh
<amz3`>I've never done project euler
<manumanumanu>It's fun. I am but a lowly programming enthusiast, and lousy at math at that, but I think it is fun
<brendyn>I did 4 or 5 of the easy ones I think
<manumanumanu>I'm at 50 now, but the last 20 or so has been slow.
<manumanumanu>doing something like one every month :)
<brendyn>nice
<manumanumanu>But, I can't for the world turn (2 2 3 5) into a list of all divisors. it's making me frustrated
<brendyn>I feel more motivated to work on real projects atm
<amz3`>the problem with project euler is you end up with programs that are not very useful..
<amz3`>me too
<brendyn>Those are the prime factors of a number?
<brendyn>2^2 * 3 * 5 ?
<manumanumanu>brendyn: yes
<brendyn>I'm trying out an idea for it atm
<manumanumanu>amz3`: meh. for me it is like crosswords. It is fun to try to make things fast. I ended up writing a couple of things I have used in other projects
<amz3`>I don't do crosswords.
<brendyn>Is it just all the ways those numbers can be multiplied together?
<manumanumanu>brendyn: yup
<brendyn>But you need to make it faster some how?
<manumanumanu>but I end up not getting it to work anyway
<brendyn>why?
<amz3`>it's a challenge
<manumanumanu>haha. I have to take care of my son. mention me if you come up with something?
<brendyn>I'm going to bed
<amz3`>night!
<amz3`>let's dive into GNU MailUtils
<amz3`>ACTION ready! set! go!
<brendyn>lmao, I tried to do it, but I ended up writing a procedure that outputs my list backwards
<brendyn>bahahaha, I'm goint to bed for real this time.
***sajith is now known as Guest39853
<nalaginrut>nikita1: it depends, if we discuss too long details with code, it's better on gitlab
<daviid>then we can't follow, nr help ... this too bad
<nalaginrut>anyway, I think it's very near to release Artanis-0.1.3, very very near, if I'm not so sleepy, I'll release it now ...
<nalaginrut>hmm...maybe 0.2, since new server core is done and works smoothly
<nalaginrut>but 0.2 is reserved for the fist stable version, I haven't checked if there's something broken by new server core
<nalaginrut>alas~I stop bothering and go to sleep now, night guilers
<nalaginrut>ACTION zzzZZZZ
<nikita1>a bug with crash on non-existent file appeared again with new fixes
<manumanumanu>amz3`: solved it in a way that is slower than trial division :(
<amz3`>manumanumanu: you can not be faster than trivial division, can you?
<amz3`>ACTION sent a mail to gnutls people. Hopefully someone will reply
<amz3`>in the meantime I continue to try to understand IMAP and MailUtils
<spk121_>amz3`: FWIW, curl also has some IMAP functions. But I've never tried to use them.
***ertesx is now known as ertes
<amz3`>I will fallback to curl if I don't succeed in my current attempt
<amz3`>I had a look at the API in libcurl and it was not immediatly clear how to use the API
<amz3`>I was under the impression that I will need some imap knowledge
<daviid>amz3: for info, one of the advantage I see of using clutter for your text editor project is that clutter has a (sophisticated) textview widget, which would give you quite a lot of functionality you'd otherwise have to develop. that texview widget also handles pangomarkup... and for info, gnome-shell, gnomeboxes, gnomevideo ... are examples of apps purely written using clutter (no gtk code)