IRC channel logs

2017-04-23.log

back to list of logs

<chatter29>hey guys
<chatter29>allah is doing
<chatter29>sun is not doing allah is doing
<chatter29>to accept Islam say that i bear witness that there is no deity worthy of worship except Allah and Muhammad peace be upon him is his slave and messenger
<amz3`>those people are following me or what? crazy people.
<amz3`>so my editor is 250 sloc (according to sloccount) it's missing search and keyword higlighting
<amz3`>compared to kilo
<amz3`>I think termbox has issues with some keyword input and the maintainer doesn't want to invest in fixing them for some reason :(
<amz3`>another thing is that termbox doesn't support true colors but only 256 colors
<amz3`>true color aka. rgb colors
***random-nickname is now known as random-nick
<MaliRemorker>I just recompiled one application i am developing with 220 and, without changing anything in the source code i'm getting errors of this form
<MaliRemorker>ERROR: In procedure assoc-set!:
<MaliRemorker>ERROR: In procedure set-cdr!: Wrong type argument in position 1 (expecting mutable pair): (main-include)
<MaliRemorker>Expecting mutable pair?
<MaliRemorker>The alists are not mutable anymore? :)
<amz3`>what's the exact guile --version you have
<MaliRemorker>the version is 2.2.2
<MaliRemorker>last time the code worked was with 2.0.11
<amz3`>yeah, then literals are now immutable
<MaliRemorker>ah
<amz3`>see the second paragraph in http://lists.gnu.org/archive/html/guile-user/2017-04/msg00025.html
<amz3`>this is breaking change, but it was buggy anyway
<amz3`>I mean you can not mutate literals
<MaliRemorker>amz3 i wasn't aware of that part of Scheme standard
<MaliRemorker>the literal in my case was an initial value of a list
<MaliRemorker>hard wired in the code :)
<MaliRemorker>oh, well, i'll replace all of that with list constructors
<MaliRemorker>i guess, that'll make it mutable
<MaliRemorker>This is the kind of code that breaks http://paste.lisp.org/+7E61
<MaliRemorker>Looks innocent enough to me :)
<MaliRemorker>just did () --> (list) and the code works; seems this was the only such place (luckily)
<amz3`>I am stuck regarding how to do highlighting in my editor
<amz3`>seems like I need another datastructure or something
<amz3`>basically turn char with position into spans of text with position and highlighting information
<amz3`>hmm...
<paroneayea>hello guilers
<paroneayea>so, who here uses unfold?
<paroneayea>when might I want to use it?
<paroneayea>the documentation in the manual doesn't give an example really
<amz3`>seems like unfold is like fold but with a stop condition
<amz3`>also it does produce a list
<amz3`>one could implement 'iota' with unfold
<paroneayea>amz3`: indeed, iota was easy to implement with unfold
<paroneayea>interesting, I guess you don't necessarily start with a list, but end up with one with unfold, which makes sense.
<amz3`>paroneayea: are you randomly exploring the manual or what?
<paroneayea>amz3`: not exactly; I was reading through fash.scm and ran into fash-unfold
<paroneayea>wingo: btw I wonder if fash-fold has the arguments backwards if it's trying to mimic srfi-1 fold
<paroneayea>shouldn't the last two arguments be reversed?
<paroneayea>Oh, apparently unfold is good for writing breadth first traversal in a functional style.
<paroneayea>that seems like a good reason to explore it.
<paroneayea> http://citeseerx.ist.psu.edu/viewdoc/download;jsessionid=BD0B88BC1C7B2DA074C84D85B981C34C?doi=10.1.1.42.1735&rep=rep1&type=pdf
<amz3`>oO
<MaliRemorker>i've seen there is the (ice-9 documentation) module and noticed ice-9 modules follow, more or less, certain comment/docstring structure which i'm trying to emulate in my own applicatoins; but, how do you generate say info documentation of such annotated source files?
<rlb>A Debian buildd has seen a powerpc build failure that appears to be a recurrence of https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20017 i.e. https://buildd.debian.org/status/fetch.php?pkg=guile-2.0&arch=powerpc&ver=2.0.11%2B1-9%2Bdeb8u1&stamp=1485708200&raw=0
<rlb> FAIL: fractions.test: fractions: (eqv? (expt 2 1/2) (sqrt 2))
<rlb> FAIL: fractions.test: fractions: (eqv? (expt 2.0 1/2) (sqrt 2))
<rlb>I'll follow up to the bug, but wondered if that rang any bells.
<rlb>(Also perhaps worth noting that this is 2.0.11, which we're attempting to build to fix two CVEs in jessie.)
<daviid>rlb: why is jessie using 2.0.11 and not 2.0.14? also, stretch uses 2.0.13, why not 2.2, I mean it's been years (6 years) that work on 2.2 started... and now it is the latest stable, as you know of course, but I relly don't get why debian is so late wrt guile packages, just curious, what forces you to use these versions?
<rlb>I assumed that the jessie release managers wouldn't allow changes that large into jessie, but you raise a good point, I should double-check, make sure that assumption is correct.
<daviid>rlb: especially because there has been a security update for guile itself, which is in 2.0.14
<rlb>in addition to the server and umask fixes?
<rlb>(I backported those.)
<daviid>rlb: I don'r remember the details, i'd have to find the email
<rlb>No worries, I can delve, but first I'll check about the version.
<random-nick>daviid: even arch and parabola are late with guile 2.2
<daviid>rlb: something to do with spawn-server iirc
<rlb>yeah, I think that's one of the ones I backported.
<rlb>unless there's been further change.
<rlb>I expect I'll have 2.2 in sid in a week or two...
<daviid>random-nick: fine, but debian stable using 2.0.11 is a bit 'too much' imo :)
<daviid>rlb: ok perfect, but hey, jessie managers *should* use (accept to upgrade) to 2.0.14
<rlb>I'll ask.
<daviid>and stretch should use 2.2
<daviid>my 2c
<rlb>I'm fairly certain 2.2 can't go in, wasn't even released until after the freeze? It's potentially a little different since it'll be a new package, but we're far into the freeze now.
<daviid>rlb: ok, in sid then, oh man...
<daviid>sid is using 2.0.13 as well
<rlb>It has both.
<rlb>wait
<daviid>ah ok
<rlb>oh, right
<rlb>hang on.
<rlb>You're right.
<daviid>i can't find guile-2.2 on debian any distro
<rlb>daviid: I haven't finished it yet ;>
<rlb>Though I did a dry-run, seemed pretty straightforward.
<rlb>But iirc I may have had a few questions I'll want to ask.
<rlb>Right now I'm tied up with emacs freeze issues, and this jessie fix...
<daviid>rlb: ok, good luck! I hope jessie maintainers accept 2.0.14, that 2.2 gets in thr next testing
<daviid>so, at least strech should get 2.0.14 as well of course, then 2.2 in the next testing...
<rlb>Drafting the mail to one of the managers as we speak ;>
<daviid>great! thanks
<rlb>Yeah, I'll see about 14 for stretch, though not sure.
<rlb>I'll get the diff to them for review.
<daviid>rlb: what I'm saying is it does not make much sense to try to have 2.0.143 in jessie and not in stretch, so you mauy as well forward your email to the stretch maintainers
<daviid>then try to get 2.2 in unstable asap...
<daviid>* 2.0.14 (not 2.0.143 of course :))
<rlb>I've already asked one of the jessie managers about it, but I can easily refer to that when I talk to the stretch managers.
<random-nick>how far apart are debian releases? 2 years?
<paroneayea>wingo: hm, another fash thing! There's no fash-delete
<rlb>random-nick: there's no set schedule, but that's generally been the pace these days.
<rlb> https://wiki.debian.org/DebianReleases
<rlb>daviid: oh, and in case you're interested, here's where we are wrt stretch: https://release.debian.org/stretch/freeze_policy.html -- in particular "Changes which can be considered".
<daviid>rlb: tx
<amz3`>sad day in france :(
<amz3`>far right got a chance to be elected president...
***ertesx is now known as ertes