IRC channel logs

2017-04-21.log

back to list of logs

<daviid>I think add-to-load-path could accept more then 1 dir: "Scheme Syntax: add-to-load-path dir1 dir2 ..." I can write a patch if maintainers think it is a good idea, let me know...
<daviid>ACTION is abusing the channel, he is terribly lasy at writing emails :)
<Apteryx>When I do (readlink my-symlink), it returns the value as the basename. Can I get the fully qualified file path instead?
<Rains>Apteryx, and the link is absolute or is it relative?
<Apteryx>Rains: absolute
<Apteryx>I could use dirname on it and string-join with the target?
<Rains>Huh
<Rains>Thatseems like a bug given the documentation
<Apteryx>Actually I think there's no bug! it returns the value of the symbolic link. The link is referring to a file in the same directory, hence the value of its pointer is simply the basename of that file.
<Apteryx>Ugh. Not sure how I can safely reform the absolute path, without guarantees of what the symbolic-link value might be! In this case it's a link to a file in the same folder, but that's not general much.
<Rains>Apteryx,well then it'sa relative link
<Rains>Apteryx, well that's the thing about a relative symlink
<Rains>What it points to depends on where the symlink is located as it is relative to the location of that symlink
<Apteryx>Rains: Ah, sorry, I got confused by link/file. The file *has* a relative link. The string of the file path itself is absolute.
<Rains>Apteryx,but basically a symlink is a file and it turns out that you can have multiple hard links to the same symblink like to any other file that's not a directory
<Rains>So with a relative link which hard linkt o the link you traverse determins what it links to
<Apteryx>So, basically: "/home/maxim/gimp-man-dir/share/man/gimp-console-2.8.1" --> gimp-2.8.1
<Rains>Yeah
<Rains>THat is a relative link
<Apteryx>Now I want to know: is gimp-2.8.1 a symlink as well? So I did (readlink "gimp-2.8.1") but it doesn't find it of course. I need to reform the absolute path of that file.
<Apteryx>s/readlink/symbolic-link?/
<Rains>Apteryx,but like what you can do is "ln /home/maxim/gimp-man-dir/share/man/gimp-console-2.8.1 /home/maxim/another_hard_link"
<Rains>Apteryx, well you can't do that in the general case is the problem if the symlink is relevant
<Rains>Unix files do not actually have "a location"
<Rains>A unix file can have between 0 and however many locations on the filesystem
<Rains>And a relative symlink resolves relative to the location you use the access it.
<Apteryx>Rains: So there is only two possibilities: either the path starts by '/', in which case it's absolute, or it doesn't, in which case it's relative. For the relative case all I need to do is to append it to the dirname of the original symbolic-link file.
<Rains>Apteryx, well if the original symbolic link has only one dirname, yes.
<Rains>The problem is that a Unix file can be located in arbitariry many directories including 0 and under different names.
<Rains>Given a file, thee is no way to found out where it is located because it can be located in multiple places
<Apteryx>Right. I'm not so interested as to *where* it lives in the filesystem but rather as to "Is the file it points to a symbolic-link as well?"
<Rains>Ahh
<Rains>Well that'sambiguous, as "thefile it points to" depends on where the symlink itself is located if it's relative
<Rains>It can also point to nothing at all.
<Apteryx>Hmm.
<Apteryx>I guess for my scenario (manpages) I can assume it's always relative.
***nikita is now known as Guest76569
***Guest76569 is now known as nikita2
<manumanumanu>So... I am getting "no code for module", but the module is obviously loaded. I am loading a module from the same directory using (load "colour.scm") and then a (use-modules (colour)), and apart from that message, everything works
<civodul>manumanumanu: does colour.scm have (define-module (colour))?
<manumanumanu>yup
<civodul>hmm weird
<manumanumanu>ill try something different...
<manumanumanu>(add-to-load-path (dirname (current-filename))) works
<manumanumanu>it just loaded the file and the procedures became visible because of that.
<manumanumanu>so the module was empty, but the procedures were loaded anyway
***nikita is now known as Guest70467
***Guest70467 is now known as nikita2
<jophish>Hmm, eval.go has been compiling for about 20 hours
<wingo>jophish: from git? what architecture?
<wingo>guile does take a while to compile but that is not normal :)
<nikita2>wingo: I have almost 3 hours of .go compiling on Atom netbook.
<wingo>from git or from a tarball?
<nikita2>wingo: from tarball
<wingo>from a tarball i think that is unexpected fwiw
<wingo>for me a tarball builds in 5 minutes or so on a 5 year old machine
<wingo>nikita2 do you know if it is picking up files from prebuilt or no?
<wingo>and are you building -jN or just one core
<nikita2>wingo: yes, was trying to build with -j 2
<wingo>do you set CFLAGS at all?
<nikita2>with no any custom CFLAGS or so
<wingo>not setting them is ok of course, if you do set them though you have to include -O2 or similar
<jophish>wingo: guile-2.0.13.tar.za from gnu/guile. I'm happy to chalk this up to an issue in qemu
<jophish>I'm compiling an armv7l-linux version on x86_64 using qemu-user
<wingo>ah.
***_extremist is now known as wleslie
<wingo>yes i would say that is probably the issue. note that you can cross-compile with guix to arm pretty easily, though you end up with guix deps. a nice solution if it works for you tho
<manumanumanu>I just compiled for armv7 without issue.
<manumanumanu>but on armv7
<jophish>manumanumanu: I'm trying to get an arm machine set up for that at the moment
<jophish>good to know it works without problems
<jophish>wingo: yeah, I can cross compile with nix too :) Some part of my build will only work natively though, so I had to use qemu
<wingo>cool :)
<civodul>sneek: seen artyom-poptsov
<sneek>artyom-poptsov was here Mar 19 at 06:06 pm UTC, saying: wferi: Could you please provide the context, e.g. the procedure source and code that calls it? IMO, It's hard to guess what the problem you experiencing w/o seeing the code..
<wingo>that feeling when your fresh guile build finally crawls out of bootstrap/
<wingo>ACTION has been building texinfo all day
<wingo>er, texlive
<wingo>so i can release :P
<ArneBab_>wingo: :-)
<civodul>wingo: heh, terrible
<wingo>ACTION uploading 2.2.2
<wingo>adsl upload ffs
<wingo>at least with this syntax object fix the tarball is smaller ;)
<lloda>I moved from adsl to fiber this winter. Night and day
<wingo>they have to tear up my street before we might maybe some day get such a thing
<wingo>habemus 2.2.2
<dsmith>wingo: is it soup yet?
<wingo>just need a few more rocks
<wingo>maybe this time the cvs thing will be not painful
<wingo>ok all done
<wingo>civodul: want me to update the guix package?
<wingo>i will do that
<wingo>done
<wingo>now, off to do other things
<civodul>wingo: cool, thank you!
<civodul>\\o/
***nikita1_ is now known as nikita1
<dsmith>Hmm. Is it normal for make check to say things like:
<dsmith>allocate_stack failed: Cannot allocate memory
<dsmith>and
<dsmith>GC Warning: Out of Memory! Heap size: 7 MiB. Returning NULL!
<dsmith>
<Apteryx>Where can I get a list of all the possible errno? I'm catching an exception returned by symbolic-link? when the link is broken.
<dsmith>never noticed those before..
<Apteryx>Oh actually this wouldn't raise. It would just say #t (it *is* a symbolic link, no matter if it's broken or not!)
<Apteryx>So the exception I want to catch to format a useful message is this: "ERROR: In procedure lstat: No such file or directory: "/tmp/tata". Any idea of what the errno would be for that?
<Apteryx>Or if I just want to print the exception message, what function should I use?
<Apteryx>Oh, looks like my error would be of errno code ENOENT ('No such file or directory').
<Apteryx>Is it common that Geiser becomes sluggish/irresponsive?
<Apteryx>Especially when working with the REPL.
<Apteryx>Emacs is using 1 GiB of memory, which is not normal, but other than that the CPU is staying close to 0%. Strange.
<wingo>dsmith: possibly yes, there is a test that rlimits down the heap
<wingo>but we should make those warnings go away