IRC channel logs

2017-04-18.log

back to list of logs

<zacts>does anyone know the status of lilypond + guile-2?
<amz3>paroneayea: thx! I will have a look
<amz3>re: activitypub ^
<mouldysammich>paroneayea: Is activitypub somewhat like pubcookie?
<MaliRemorker>wow, guile 2.2 is there
<MaliRemorker>can't believe my eyes
<MaliRemorker>btw, are immutable records (srfi srfi-9 gnu) thread safe?
<civodul>MaliRemorker: immutable data structures are usually thread-safe, and that's the case for these
<amz3`>heya
<amz3`>guess what?! I started another project! But this time I don't come with only my mouth, and have something to deliver to the awesome guile community
<amz3`>I made bindings for termbox -> https://framagit.org/snippets/436
<amz3`>its only dependency outside guile itself, is scheme-bytestructures
<amz3`>termbox is kind of like ncurse, less powerful I guess, also it's quite simple
<amz3`>it support utf8
<amz3`>you can convert a char to "utf8 integer" using char->integer procedure, e.g. (char->integer #\\é)
<amz3`>termbox is for terminal user interface or TUI
<amz3`>(search engine friendly message ^)
<amz3`>scheme-bytestructure is available in guix, as guile-bytestructures
<amz3`>...
<amz3`>now I am wondering how I will actually structure my code
<amz3`>basically, the api of termbox can be summed up to:
<amz3`>a) (tb-change-cell x y char foreground background) which change a "cell" in the back buffer
<amz3`>b) (tb-present) which sync the terminal with the back buffer
<wingo>neat
<MaliRemorker>amz3`: can you use it to make a Roguelike game? :)
<amz3`>MaliRemorker: yes prolly
<amz3`>MaliRemorker: do you think I should make a rogue-like game?
<MaliRemorker>amz3` oh yeah, please do. I got tired of rerunning Zangaband over the years :)
<amz3`>MaliRemorker: I can't, I am not enough into rogue-like games, I may have never played such game
<MaliRemorker>ACTION goes back to Zangband
<amz3`>^^
<wingo>ACTION just pushed sandbox support
<wingo> http://git.savannah.gnu.org/cgit/guile.git/tree/NEWS#n9
<wingo> https://lists.gnu.org/archive/html/guile-devel/2017-04/msg00033.html
<daviid>wingo: nice! just seen you have a competitor :) 'fb annouces react fiber ...' on hn :)
<daviid>wingo: it would be cool to have 2.2.1 to use (optionally) truncated-print for its raised exception mecanism, how are things wrt this? also i thought about the repl and how about a simple patch: adding a %repl-use-truncated-print, intialized to #f, export it so users can import (system repl common), set! it to #t .. (of course the code would (if %repl-use-truncated-print (truncated-print val) (write val)) ... WDYT?