IRC channel logs

2017-03-25.log

back to list of logs

<OrangeShark>dsmith-work: a statically and strongly typed scheme?
<OrangeShark>oh, you probably meant at work instead of python
<akkad>is there a way to include guile into a GnuMakefile that is less ugly than the docs show?
<spk121>akkad: what does your makefile do? Does it compile and install a scheme-only library? Or something more complicated.
<akkad>just has to parse some data, and output files. was looking to not have to create .scm files and have the login in guile within the GNUMakefile
<akkad>$(shell) it is
<spk121>should just be this...
<spk121>outfile: infile
<spk121> guile -L path-to-lib script.scm $^ > $@
<spk121>right?
<davexunit>is there anything I can do to hint to the compiler that an integer variable is within the u64 range so it can be unboxed?
<akkad>I meant guile inside of makefile proper
<davexunit>okay I'm rather convinced that guile is just missing this particular optimization, but how to fix that...
<akkad>can you capture (system "ls") output?
<taylan>akkad: not (yet) I believe. see 'open-pipe' instead: (info "(guile) Pipes")
<davexunit>hello from libreplanet, guilers.
<janneke>davexunit: hi!
<amz3>!
<civodul>hey davexunit! say hi to the gnus at LP! :-)
<amz3>in the meantime parsing of wiktionary is making good progress http://dpaste.com/339TAVS
<amz3>I think there is an issue with (ice-9 session) procedure-arguments
<amz3>I mean what I am doing wrong
<amz3> http://paste.lisp.org/display/342378#1
<amz3>as you can see in the second paste, #:foo has '1' as value
<amz3>I understand now, 1 referes to the position of the keyword argument
<amz3>which is not what I need
<amz3>I need the default value instead
<daviid>hello *
<daviid>just uploaded Guile-CV to nongnu (it is in the queue to be (or not) part of gnu, but since they told me it would take at least another 5 weeks, I decided better make it nongnu for now...)
<daviid> https://savannah.nongnu.org/projects/guile-cv/
<daviid>will release, but wanted to share here for who might be interested and a cloner :)
<daviid>feedback, design and code review more then welcome!
<amz3>daviid: :)
<amz3>daviid: why do you use vigra instead of opencv?
<daviid>amz3: the opencv team has abandonned the support of the opencv_c library, long time ago, so opencv is not even an option :)
<daviid>amz3: but vigra has 2 major qualities, although at this point in time less functionalities of course: (1) they made the right choice for in mem representation of images, imo at least, and (2) the caller allocate mem, this is absolutely fantastic for us, because mem management (85% of errors for C programmers are mem management related) is done in(by?) guile, a real winner