IRC channel logs

2017-03-24.log

back to list of logs

<thomassgn>:)
<sirgazil>ACTION is using Guile 2.2 now. Thanks to all people who work on it :)
<akkad>^^
<MoronicAcid>How would I go about making a typed array containing real numbers?
<lloda-home>MoronicAcid: see https://www.gnu.org/software/guile/manual/html_node/Array-Procedures.html#index-make_002dtyped_002darray
<lloda-home>e.g. (make-typed-array 'f64 0. 10 10) makes a 10x10 2d array filled with 0.
<amz3>o/
<amz3>catonano: if culturia, works, don't do 'git pull' because master is broken
<amz3>the state of the project is not very nice
<amz3>I am not sure what do to next
<amz3>especially since the code I've done yesterday is broken today
<amz3>My plan was to parse wiktionary
<amz3>mbuf: what do you seek exactly?
<mbuf>amz3, something like ruby on rails guides
<amz3>I am not familiar with rails guides, what are they?
<mbuf>amz3, if I have a Rails application, how can I re-implement the same using artanis, for example
<amz3>ah ok
<amz3>nalaginrut: is the maintainer of artanis
<amz3>mbuf: fwiw I do web stuff, I don't use artanis, see http://culturia.one
<mbuf>amz3, the present document is like a reference manual
<amz3>which document?
<amz3>mbuf: ^
<mbuf>amz3, https://www.gnu.org/software/artanis/manual/artanis.html
<mbuf>I would like to see some performance metrics as well
<mbuf>if possible
<amz3>I've done 5 years of Django, I never seen any performance metrics about it
<amz3>wait... I saw some performance metrics actually
<amz3>anyway, it would not be fair to compare rails/django to artanis since they don't implement the same feature
<amz3>as of right now, you can't be as productive using guile web infrastructures as you would be in ruby or python
<amz3>there is still a lot of plumbing to do
<amz3>I mean, for instance, there is a no form validation library
<amz3>mbuf: if you have no answers here, please send a mail to guile-user mailling list or artanis mailling list
<mbuf>amz3, okay
<mbuf>amz3, thanks!
<OrangeShark>o/
<OrangeShark>mbuf, amz3: artanis is under heavy development, I know I had some issues the last time I was trying to use it.
<mbuf>OrangeShark, okay
<davexunit>wingo: for some reason I have an easier time unboxing f64s than u64s. I'm currently writing a merge sort to order sprites by their Y coordinate and there's allocation due to u64->scm and scm->u64 calls.
<davexunit>I have an f32vector of sprite coordinates and I'm filling up a u64vector with indices into that coordinate vector. to reference the y coordinate, I need to do (f32vector-ref coordinates (+ (* (u64vector-ref indices i) 2) 1))
<davexunit>guile is boxing the u64 to do arithmetic then unboxing it for the f32vector-ref call, it seems.
<davexunit>I guess either I'm doing something wrong that makes the compiler do this, or in order to eliminate allocation I need to split the f32vector of coordinate pairs into 2 f32vectors of x coords and y coords.
<davexunit>hmm, seems that splitting up the vectors makes things more convenient for me, but not more efficient. the scm->u64 and u64->scm ops remain
<nee```>Maybe the Snapshots section should be removed from https://www.gnu.org/software/guile/download/. All the downloads are 404ed anyway, and people who just scroll down fast, looking for the release can mistake it for that.
<davexunit>,x (lambda () (f32vector-ref (f32vector 1.0 2.0 3.0) (u64vector-ref (u64vector 0) 0)))
<davexunit>^ disappointing disassembly output
<davexunit>is this an optimization to be added or user error?
<janneke>mescc-compiled mes now loads modules and passes 30 scheme tests
<janneke>now stuck on: expected: (#\\a #\\b #\\c #\\n unbound variable: ewline
<janneke>;-)
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>janneke: heh
<davexunit>disassembly output: http://paste.lisp.org/display/342274
<davexunit>what's up with the ash op on line 37?
<janneke>happy Friday dsmith-work!
<lloda>davexunit: it also looks like the compiler pevals vector/vector-ref but not u64vector/u64vector-ref (if you look at ,x with u64vector -> vector)
<davexunit>yeah, I'm not concerned about that right now, but yeah.
<davexunit>if it did I would need a bigger example to demonstrate my problem
<davexunit>;)
<civodul>janneke: oh so you're about to close the loop!
<janneke>civodul: ...almost...almost self-hosting
<taylan>did anyone raise the issue of some syntax-rules macros desiring unhygienic (by-name) matching of literals yet, since 2.2 is now released and matches them all hygienically (as is conformant BTW)?
<taylan>e.g. guix has the 'modify-phases' macro which uses literals like 'add' and 'remove' which are really intended to be matched by name not variable-identity.
<taylan>I suspect it'll bite a few people in the back eventually if the issue is ignored :)
<civodul>lots of neat stuff in http://wedesoft.github.io/aiscm/
<davexunit>civodul: is this new?
<davexunit>never heard of it before
<random-nick>davexunit: there was a mail about it on guile-user
<random-nick>davexunit: https://lists.gnu.org/archive/html/guile-user/2016-06/msg00015.html
<civodul>i just rediscovered it and found it impressive
<davexunit>oh cool
<davexunit>thanks for re-sharing
<davexunit>I missed that
<davexunit>or saw it but forgot
<davexunit>one of the two :)
<kyamashita>civodul: This is nice!
<dsmith-work>wingo: Did I hear something about userland code being more performant than kernel code from you?
<dsmith-work>ACTION has this vague memory of something.....
<random-nick>dsmith-work: maybe this https://wingolog.org/archives/2017/02/24/encyclopedia-snabb-and-the-case-of-the-foreign-drivers
<dsmith-work>Yeah, I think so. Just checking the wingolog. Saw this: https://github.com/snabbco/snabb
<dsmith-work>Hmm. Lua and lua-jit
<dsmith-work>The last few devices we have done here at work use Python. A lot. I really hate it.
<dsmith-work>There are worse things than python.
<dsmith-work>But I hate that I can't just look at the code and see the data structures. Any random funtion can modify any random object at runtime.
<dsmith-work>Ugh!
<dsmith-work>How does lua compare? (probably the wrong chan for this question)
<dsmith-work>And wingo is probably enjoyign his weekend.
<dsmith-work>Sure wish we had something more staticaly and strongly typed.
<dsmith-work>ACTION ranting
<dsmith-work>Sorry