IRC channel logs

2017-03-06.log

back to list of logs

<daviid>amz3: I would first try to fix guildhall, as it is
<daviid>guildhall adds functionality to guild, the guile script, and its design (guildhall) has been supervised by at least wingo, it is a pretty good design, not sure why you would want a 'load-module...' guildhall has all this already
<daviid>my 2c
<lloda>nalaginrut: tried your branch of tjit and compilation failed with 'No such file or directory: ".../module/system/vm/native/jit-code-t.scm". Does this ring any bell? jit-code-t.scm is mentioned in module/Makefile.am, but for some reason it isn't generated (?)
<nalaginrut>lloda: I'm trying to solve it, the problem is that the tjit designed to generate some file and include them during compilation, and this cause problem when Guile still has to interpret itself to generate guile-procedures.texi
<nalaginrut>lloda: I don't think this generation is necessary, but it's better to use its current design for other debug. The solution is to generate these files twice during compilation. I'll submit when I done
<nalaginrut>lloda: and you may delete the jit-code-t.scm in the srcdir then try, the author put this generated file in the source code which prevent Makefile generate this target
<jmd>I'm having trouble using the aspell module.
<jmd>(use-module (aspell) (aspell-set-lang "en_US")
<jmd>gives: ERROR: Unbound variable: aspell-set-lang
<jmd>What have I forgotten?
<lloda>jmd: a paren?
<ArneBab_>amz3: wow … compan does not have dependency resolution, but it seems to simple
<jmd>lloda: ;) I did have that missing paren in my repl.
<roelj>Is there a way to suppress the compile-related warning messages?
<roelj>So.. export GUILE_AUTO_COMPILE=fresh works for me
<ArneBab_>amz3: it would be cool to just crawl modules and auto-generate a list of packages from compan
<ArneBab_>the federated package repository
<ArneBab_>that would just need seed packages and all libraries could be added automatically
<ArneBab_>… compan actually does not need to resolve dependencies, because the compan macros will get the required modules within dependencies while the program is running.
<ArneBab_>the crawler would mostly be useful to pre-fetch all the dependencies, for example to create a self-contained release-tarball.
<nalaginrut>lloda: I think it's fixed with a workaround, and it's even faster than Chez in the naive case mentioned in my mail after rebased with the latest master...
<nalaginrut>lloda: would mind pulling and try it again?
<lloda>hmm, it segfaulted in configure.texi. There's some cruft in there and I needed distclean to configure outside. Retrying.
<lloda>nah, segfault again :-/ I've forgotten how to debug this.
<catonano>amz3: are you here ? I wouuld ike to point you to this competition http://wiki.dbpedia.org/textext
<catonano>I am interested in natural language processing but I don't know so much about it
<catonano>I would like to observe your moves
<nalaginrut>lloda: are you trying guile-tjit again? I never encounter configure.texi
<nalaginrut>issues
<lloda>nalaginrut: sorry, it's guile-procedures.texi, just tried again from clone.
<lloda>I'm using gcc 6.3, libgc 7.6.0, lightning 2.1.0 if that means anything
<nalaginrut>lloda: I have to push with -f after rebase, so maybe you have to tweak something with Git, dunno
<lloda>those work on master (well except lightning)
<nalaginrut>but it's fine if you clone again
<nalaginrut>I haven't tried gcc-6.3, mine is 4.9
<nalaginrut>other are same IMO
<lloda>yeah I got the merge errors, but I just reset far back until it pulled w/o errors, I don't think it's that
<lloda>I still have gcc 5.4 installed, I'm retrying with that
<lloda>nah, the same
<nalaginrut>lloda: what's the error? file missing? or core dump?
<lloda>nalaginrut: http://paste.lisp.org/display/340723
<lloda>I've seen that error before, but the cause varies, it seems
<lloda>e.g. https://lists.gnu.org/archive/html/bug-guile/2016-07/msg00008.html
<lloda>GUILE_AUTO_COMPILE=0 meta/guile just hangs sucking CPU
<lloda>argh it's some readline crap
<mekeor>omg, i was just wondering how to find the docs of `system*' function... then i just tried out (help system*) – nice! :3
<amz3>mekeor: !
<amz3>mekeor: you must have some magic parens inside your ~/.guile otherwise help procedure doesn't exist
<amz3>the funny thing is that help can sometime find documentation about procedures that are not imported yet
<amz3>try: (help append-mad)
<amz3>in fresh REPL
<amz3>tx catonano I am looking at it
<amz3>the problem I have with dbpedia is they have a vast amount of dead links
<mekeor>(help help) says "`help' is an object in the (ice-9 session) module.", so i prolly got that module loaded by default
<amz3>mekeor: read the code it's funny story
<amz3>here is my ~/.guile https://hastebin.com/tetazicoso.scheme
<amz3>catonano: this is exactly the kind of thing I am looking for! I am very grateful!
<catonano>amz3: ;-)
<mekeor>ugh, a pastebin that requires javascript
<amz3>mekeor: sorry → http://dpaste.com/31QFR74
<mekeor><3
<mekeor>very handy, cool, thank you :)
<amz3>thas is very cool stuff here http://wiki.dbpedia.org/textext
<amz3>it's a multiple tasks about natural language processing competition
<amz3>it's all i've been *thinking* about without being able to put words on
<amz3>basically the answer to the question: what are the problems that are involved in NLP?
<amz3>the above link answer that question ^
<wingo>meep
<amz3>o/
<amz3>good luck to reproduce dbpedia results it's an horrible mess
<amz3>anyway, I am very interested in the competition, since they explicitly allow other ontologies not just their ontology
<catonano>amz3: coming up wiith new ontologies is one of the goals of the competiton, as far as I understand
<catonano>I might be wrong, thouugh
<amz3>catonano: yes, I talk about the bootstrap ontology, you can use whatever you want
<amz3>if I don't link my ontology to dbpedia ontology, it's like hiding part of the solution
<amz3>right now wikidata (the wikimedia project) and dbpedia are two universes of knowledge
<amz3>there is no link between them
<amz3>but there is a link between wikidata and freebase
<catonano>I didn't kknow they were isolated from each other
<amz3>you can pass, feed the entity name in wikidata to dbpedia spotlight tho
<amz3>which does entity linking for free text
<amz3>so it's not impossible to do
<amz3>catonano: I've written a entity linking naive algorithm in guile
<amz3> https://framagit.org/a-guile-mind/culturia.one/blob/master/src/conceptnetization-02.scm
<amz3>basically if one input a sentence, it will retrieve (if possible) for every group of words the related entry in database
<catonano>I see
<amz3>I also created guile bindings of link grammar (from linas)
<amz3>here is the documentation of the dictionary of link grammar which is the other interesting part (but time consuming)
<amz3> https://amirouche.github.io/link-grammar-website//documentation/dictionary/introduction.html
<amz3>here is the repository of link grammar bindings https://github.com/amirouche/guile-link-grammar
<catonano>give me a minute, I can't copy from withint the weecat window, I have to wait for this to be reported on the log page on the gnunet site
<amz3>no problemo
<amz3>I should put all this stuff in a single repo... it will be simpler to backup and stuff
<amz3>there is a even some documentation
<catonano>wow ;-)
<catonano>yes, you should definitely put these things together !
<catonano>it's encouraing to knwo that some effort for this stuff is being done in guile
<catonano>I could use some o this stuff for a project I could be involved in
<catonano>a huge collection of olitical textes ranging from the 40ies to today
<catonano>they could be published on a mediawiki instance
<catonano>so, you see ? Things come around ;-))
<catonano>so, you see ? Things come around ;-))
<catonano>sorry
<catonano>amz3: the link-grammar thing is cool !
<amz3>the next step is port RelEx written in java
<amz3>it is also based on dictionary thing
<wingo>i wonder what lilypond is doing that makes it slow down so much
<catonano>amz3: does the wiredtigerz in culturia.one work with the new wiredtiger ?
<amz3>catonano: I use /usr/local/lib/libwiredtiger-2.9.1.so
<catonano>amz3: wonderfuul
<catonano>good to know !
<paroneayea>I usually really like guile's define*/lambda*, though I occasionally have fleeting moments where I miss Python's *args / **kwargs
<paroneayea>ACTION hits one of those right now
<paroneayea>(yeah I know, it's all abstractions, I could write my own *args / **kwargs if I wanted)