IRC channel logs

2017-03-03.log

back to list of logs

<daviid>can I compare integers and their corresponding float expression, such as (= 1 1.0)? is the result guaranteed?
<daviid>also, can I use = to compare rounded floats?
<daviid>I mean float that have 1 decimal and it is always zero, 2.0, 4.0 ...
<wleslie> http://codepad.org/OgqxWTV3
<wleslie>by which I mean, if you check check checkity-check your assumptions
<daviid>wleslie: I see. but in my case, I can guarantee all values, the 1 used to compare and the list of ... are composed of values like x.0, with x beeing a positive integer
<daviid>so I guess I can use = then
<daviid>I'm trying to avoid inexact->exact actully
<daviid>because of the size of the f32vectors (millions of entries ...)
<ecraven>avoine: just some custom scheme code to produce the graphs
<ecraven>from the csv
<ecraven>I've just never posted it, because it is very hackish and ugly ;)
<roelj>I noticed that my Guile program uses up to 30% CPU (in gnome-system-monitor). I havent done any threading stuff in the code. Usually, programs use 1 core up to 100% smoothly (25% total). Why is Guile different? It seems to use all four cores, but not up to 100% each, but 30%-60%-ish..
<lloda`>Guile uses threads itself for things like GC, even if your program doesn't use threads
<mekeor>is there something like `define-datatype` in guile for defining new datatypes? here <http://wiki.call-cc.org/eggref/4/datatype> it's described for chicken-scheme?
<lloda`>mekeor: there is https://www.gnu.org/software/guile/manual/html_node/SRFI_002d9-Records.html. If that's not enough there's https://www.gnu.org/software/guile/manual/html_node/Records.html or even https://www.gnu.org/software/guile/manual/html_node/Structures.html
***lloda` is now known as lloda
<mekeor>thank you, lloda.
<mekeor>still, in my favorite prog-lang, haskell, you can easily define a new data-types. e.g. define lists like `data List a = Empty a | Cons a (List a)`. i guess that'd be pretty complicated in guile/scheme – but still possible using structures(?).
<lloda>hm... Guile just doesn't have static typing. Generally you can put anything in any struct field, so if you want constraints you have to write your own functions to check at runtime etc. :-/
<wleslie>and the fundamental unit is the pair; the addage is that it's better to have 100 functions operating on 1 data type than it is to have 10 functions operate on 10 data types. so the schemely thing to do is make good use of lists and trees.
<masoudd>Hey. I'm new to scheme. I was playing around with guile-www module in repl and I think I've found a bug. After I call a certain series of procedures it just drops out of guile repl without any errors. Is this normal?
<random-nick>is it possible to implement GNU/MIT Scheme's sc-transformer-macro in guile?
<spk121>hello
<spk121>the !HAVE_SYS_MMAN_H path in loader.c doesn't compile. The patch is quite straightforward. Can I just push the fix? Or do I need to throw it to guile-devel for review?
<spk121>wingo: ^
<spk121>mark_weaver: ^
<wingo>spk121: go ahead and push, tx
<spk121>wingo: ok
<roelj_>Is there a way to dynamically define symbols? I intend to do something like: http://paste.lisp.org/+7AOU
<wingo>string->symbol
<roelj_>Can I then define-public it?
<wingo>no :) but you can define! it
<wingo>and then you can export that binding using module-export!
<wingo>it's tricky though, if you can it's better to do that kind of thing in a macro
<spk121>... and now I have 3 VMs crunching on "BOOTSTRAP GUILEC ice-9/psyntax-pp.go"
<roelj_>wingo: Ah thanks. This is tricky indeed
<wingo>i finally realized why spammers were attacking my blog
<dsmith-work>Happy Friday, Guilers!!
<wingo>i forgot to add rel="external nofollow" to <a> tags in comments
<wingo>i did add it on the author url link but that is only part of a solution
<wingo>happy friday dsmith-work :)
<dsmith-work>wingo: crazy amount of fixes going on. Contrats. 2.2 is gonna be great
<wingo>:-)
<avoine>I'm trying to build something like the emacs pretty-mode but for Guile's repl, this is what I've got so far I think I'm close but it's not working. Also, is there a better way?
<avoine>(define prettify-lambda (e)
<avoine> (match e
<avoine> [(lambda (formals ...) body ...) `(#\\λ ,formals ,body)]))
<avoine>(display (prettify-lambda '(lambda (x) (* x x))))
***siel_ is now known as siel
<amz3>héllo #guile!
<OrangeShark>hello amz3
<amz3>OrangeShark: apparently the creator of NYACC is working on automatic binding wrappers lib
<OrangeShark>amz3: oh, for C libs?
<amz3>yes
<amz3>OrangeShark: the person's name is Matt Wette
<OrangeShark>oh I see, they mentioned it on the mailing list
<amz3>I think article about unix/linux with some History is neat https://kukuruku.co/post/the-collapse-of-the-unix-philosophy/
<amz3>So i've put on a server the code I was working on
<amz3>here is the rendering http://hypermove.net/discuss/mezangelle
<amz3>the search engine isn't in working state tho
<paroneayea>warning: 'waitpid' -1 failed unexpectedly: No child processes
<paroneayea>oops
<paroneayea>meant for #guix
<amz3>ACTION now works on guildhall
<daviid>ACTION thinks it is important to keep full separation between guildhall (the command line facility) and anything on top of it, and tbh, I don't beleive a web interface is necessary, but ... :)
<amz3>daviid: yes, I agree but a lot of user are expecting to have such a portal to get into guile
<amz3>It just another way to show that guile can be useful, I am not much interested (right now) in using it personally
<daviid>it would be nice to have a well maintained guildhall facility, the web is superficial
<daviid>potential users can 'guild --list-all' ... my 2c
<daviid>the web is always superficial, imo
<amz3>because your are a cli user
<amz3>nowdays, if there is no VR interface, kids won't have a look at it
<daviid>we have guile (web), so a robust guildhall, and we could list projects as a guile subpage or something
<daviid>anyway, back to hack, good luck!
<OrangeShark>where is the emacs interface for the package manager? ;D
<daviid>OrangeShark: yes, à la magit!
<amz3>don't try to make me go away from the project, because I know for once I *can* make something that can be useful
<amz3>I mean I think at least for that task I already have all the required the knowledge or most of it
<amz3>:)
<amz3>I created a small form validation pattern, it starts L14 with (validate form assoc) http://dpaste.com/37B1HNE
<amz3>I am wondering what's the point of to return multiple values in the light of ice-9 match
<spk121>amz3: Reject the CLI orthodoxy! www-guildhall for life!
<amz3> string)b
<amz3>:)
<amz3>ah ok guile will recompile same files with different location...
<amz3>ok so nginx is correctly configured
<spk121>to be in keeping with 70s Lisp culture, guildhall may also need a gopher interface
<amz3>it's live at http://guildhall.hypermove.net/
<amz3>becarful there is no password
<amz3>I mean no https
<amz3>you can already add packages, just register an account (remember no https) and use "add" link at the bottom to create an entry :)
<amz3>password are hashed using industria's sha-1
<amz3>I will just send an email will all the nfo