IRC channel logs

2017-02-26.log

back to list of logs

<pmikkelsen>Hi #guile! I am having a hard time with open-input-output-pipe from (ice-9 popen)
<pmikkelsen>I want to communicate with an interactive program, but after I read 1 line the program I interact with terminates
<pmikkelsen>is this desired behavior? the program is waiting for input when i try to read from it.
<amz3>I have a big issue
<amz3>I need to choose between the graph based database with traversal
<amz3>and the lower level eav database with minikanren querying
<amz3>that's an issue I don't how to solve
<amz3>the minikanren code is smaller
<amz3>I am not sure of the complexity of minikanren quering tho
<amz3>One thing I could do is rewrite what I have done using the traversal querying language using minikanren
<amz3>bummer
<amz3>dmiles: what do you think?
<amz3>dmiles: is minikanren or graph traversal better?
<amz3>so maybe I need to benchmark that stuff
<amz3>that's not only a performance issue tho
<amz3>I need the most easy and powerful API
<amz3>to get started I will benchmark both grf3 and tuplespace over conceptnet.io
<dmiles>amz3: i'd like to hear the results of your benchmarks
<dmiles>hard to say which is better :P
<amz3>dmiles: I did not do them
<amz3>dmiles: re-do them I mean. I am sure there is an overhead while using the graph structure for representing some information like lists
<dmiles>oh thats what you meants for GraphDB
<amz3>yes
<dmiles>well god *i* wonder now if that is what a lot of peopel meant by it over the years.. wow
<amz3>I mean for instance, when I build trigrams out of a word, it requires an edge per trigram whereas the eav model doesn't require the "edge"...
<dmiles>my opinion is that kind of graph database is one of the weorse case datastrores :p
<amz3>it a simple foreign key, but at the end of the day, I could also implement it directly on top of the key/value store
<amz3>things are complicated
<amz3>which layer/vocabulary is the good one to best express my ideas?
<amz3>while being performant
<dmiles>when people have said graph database i secrelelty immagined a database composed of all hashmaps
<amz3>dmiles: that's graphdb on top eav
<amz3>that's basically what I used to do
<dmiles>had a branch leading to another branch finally maybe leaves?
<amz3>dmiles: i have another question, are you familiar with “wikification” ?
<dmiles>hrm god i guess i just described a list
<dmiles>sort of yes
<amz3>eav is basically a list of hashmaps
<amz3>dmiles: how do you do it?
<dmiles>oh i am publishing a wikification of the prolog database state
<amz3>what do you mean?
<dmiles>in https://github.com/TeamSPoon/xlisting_web
<amz3>dmiles: in particular how do you wiki-fy things like "Bob Marley" or "Barack Obama" and stuff?
<dmiles>i needed a runtime debugger of memeory state so created https://github.com/TeamSPoon/xlisting_web/blob/master/prolog/xlisting_web.pl
<dmiles>i pull up all assertions concerning "Bob Marley" onto one page
<dmiles>and display them creating what spiders called doorway page
<dmiles>to make the ulitmate page about Bob Marley
<dmiles>also i make small queies into the db as well
<dmiles>like isa(iBobMarley,What).
<dmiles>and display isa(iBobMarley,mobArtist). as "He was an artist"
<amz3>that is not my question
<amz3>I asking about your NER algorithm
<dmiles>(That is how I and Cyc wikifies)
<amz3>wikification is a super problem of NER
<dmiles>oh i meants dewikify :P
<dmiles>oh you meant dewikify :P
<dmiles>but i guess i just see it backwards
<dmiles>i dewikify (convert the data i read off wikipedia to named entities) by stealing first its subjects
<amz3>basically the input string is "Bob Marley plays the guitar" I want to output '(PV (SUBJ "Bob Marley") (V "plays") (OBJ "the guitar))
<dmiles>oh I call that POS tagging.. well i do a virterbi "best guess based on fit"
<amz3>you link both "Bob" and "Marley" together into a single entity?
<dmiles>Marly is capitalized and adjacient to Bob so that is good indicator and huamn hame
<amz3>ah ok
<dmiles>(and "Bob" is part of human names)
<dmiles>plays is a closed class verb
<amz3>That's what I thought but it's not robust enough for non-human-name entities
<dmiles>it can be
<dmiles>but jsut most people only make toy version of HSPG
<dmiles>i've done non ty versions.. and never hit a bittle spot
<dmiles>brittle*
<amz3>dmiles: is there wikipedia page for HSPG?
<dmiles>i mena it can be made robost to the point of insanity (genious)
<amz3>dmiles: ahahh
<dmiles> https://en.wikipedia.org/wiki/Head-driven_phrase_structure_grammar
<amz3>hmm that's what I was thinking about a toy version of HPSG
<dmiles>i did a semi-probablistic version once.. i even went so far as to use n-grams to help vote
<dmiles>but it started as toy and just kept gettign more and more complex/robust
<amz3>dmiles: yes
<amz3>dmiles: cool
<dmiles>why they are so neat.. they work almost on day 1
<amz3>dmiles: is that feature structures in the HSPG wikipedia page ?
<amz3>dmiles: another question, how do you store all the wikipedia in prolog?
<dmiles>yes.. for example .. doing number agreement
<amz3>number agreement?
<dmiles>and tense/time agreement
<dmiles> are the fish numerous? is the fish only one?
<dmiles>"are" agrees with plural versions
<amz3>dmiles: this seems like feature structure https://en.wikipedia.org/wiki/File:Walks-avm.png ?
<dmiles>i'd say so
<amz3>definitly
<amz3>ah yes, you virtiby parser to match the sentence
<amz3>that's what LG or RelEx was using at some point
<dmiles>the "sing" was "number [aghreement]" there
<amz3>now they use minisat
<amz3>I think...
<dmiles>anything to "almost" use prolog :)
<dmiles>sometimes i will grab off the shelf POS tagger to get its opinion before i HPSG it myself
<dmiles>in case it does something brilliant that i might not notice
<dmiles>like http://nlp.stanford.edu/software/tagger.shtml
<dmiles>i then useit POS opinions to guess help guess (brute firce) my routines
<dmiles>you seen my E2C examples?
<dmiles> https://docs.google.com/document/d/1rdI_f-2YnX0e2RD6rGAY57YAqzLj2xHsk36m5HT6SoM/edit
<dmiles>where on that page "[[txt, 'George'], [tag, staart, nnp, np]]" in e2c("George fell last year").
<dmiles>staart is a feature that was added basted on being the first word
<amz3>MUD + IA = awesome
<dmiles>IA/AI?
<dmiles>IA = interaction agenda .. that is awesoem to
<dmiles>i wanted sometimes to see when the parser was being overly subjective in its ear
<dmiles>(like goerge the football player)
<dmiles> (CityNamedFn "George" RepublicOfSouthAfrica ) would have needed to be possibly known to be at war
<dmiles>or perhaps in some peacefull sports contest
<dmiles>(in which a trophy is passed)
<dmiles>i like to even use abstract things like that to be part of the parse phase
<amz3>hmm
<amz3>you are talking science to me :p
<dmiles>George fell last year riding his mountain bike on pensilvainia avenue
<amz3>I mean AI
<dmiles>would be "Geoge Bush" as the subject
<dmiles>RelEx would use turd polish caused by "pensilvainia avenue"
<amz3>turd polish?
<dmiles>vs my polish .. which uses the same semantic vote
<dmiles> turd polish = robustification by making everything seem less brittle by weaking the system using "floats"
<dmiles>floating point numbers
<dmiles>i call it "turd polish" ussualy when proability is used to cover for the fact that 2 or less smeantic routines are used
<dmiles>i call it "turd polish" ussualy when probability is used to cover up for the fact that 2 or less senantic routines are used to guess things.. i liek to use 10+ things to guess things
<dmiles>10+ feature structures
<dmiles>turd polish might be covering for for the fact that "close on some webpage" is all that is used to learn the connection between "George Bush" and "Pensilvainia avenue"
<dmiles>some NER systems are trained first on "close on some webpage"
<dmiles>to create word2vects
<amz3>yes
<amz3>I understand
<amz3>tx again dmiles I must go afk, I will let you know if i get wikification (or whatever the name) working
<amz3>I far away but anyway
<dmiles> https://www.pinterest.com/pin/392165080029408192/
<dmiles>kk !
<amz3>dmiles: you are too high up in the air for me to understand that joke :)
<amz3>dmiles: give me a few more month so that a climb at you :)
<amz3>dmiles: what do you do when the computer is processing data for a long time? do you do multi tasking?
<wingo>evening
<dmiles>yes and sometime compete to CPU to irc rant
<dmiles>yes and sometime compete for CPU resources to irc rant *
<amz3>dmiles: :)
<dmiles>but also mostly i try coding in lue of the process being successful
<amz3>dmiles: good ideq
<amz3>dmiles: good idea
<taylan>hmm, a with-current-directory procedure would be neat
<wingo>taylan: no support on the os level, sadly
<taylan>wingo: is there a problem with a naive dynamic-wind implementation?
<wingo>no, it's that "current working directory" is a kernel-level per-process concept afaiu
<wingo>setcwd affects all threads
<wingo>afaiu
<taylan>oh I see
<amz3>is there a procedure that allows to compute all partitions for a given list
<amz3>for instance '(1 2 3) return '(((1) (2) (3)) ((1 2) (3)) ((1 2 3)) ((1) (2 3)))
<amz3>my algorithm fuu is laking
<amz3>s/partitions/subsets/
<amz3>subsets without overlap and taking into account the order of elements
<stis>heya guilers!
<stis>working with a C type checker for clambda
<stis>C type inference is not too difficult
<stis>this is for compiling a scheme representation of C to C
<stis>The scheme representation is better than C though, it has sane macros and more scheamy with named lets and everythingis an expresison principle
<stis>I want to add some extra features for type deduction and support for SCM types
***random-nickname is now known as random-nick
<stis>I kind of like rusts type system which is a swet spot between C and haskell
<stis>I plan to incorporate more rust features as I develop it. I want to learn rust and this is my way of doing it
<paroneayea>stis: interesting
<wingo>holy crap this unicode thread, what is the deal
<wingo>ACTION just catching up
<amz3>seems like I found the algorithm... http://dpaste.com/3PC3PWJ
<amz3>mark_weaver: ^