IRC channel logs

2017-02-25.log

back to list of logs

<amz3>sorry I changed topic
<amz3>hmm
<amz3>I'd like to say: me too!
***darthlukan_ is now known as darthlukan
***profan_ is now known as profan
<amz3>o/
<felipebalbi>hi, I'm trying to use FFI to bind a library to guile. The library has an _init() function which takes a void **ctx and an _exit() function which takes a void *ctx. How can I describe this void ** and void * in guile's FFI?
<felipebalbi>basically from C you would: void *ctx; _init(&ctx); do_something(); _exit(ctx);
<felipebalbi>I'm thinking that once I can make a void *ctx in guile, I would use something like (init (pointer-address (library-pointer-ctx)))
<felipebalbi>but how to make a C pointer in guile?
<amz3>felipebalbi: I think I have the solution somewhere
<felipebalbi>amz3: thanks :-)
<felipebalbi>if it gets to the point of being too laborious, I'll just wrap the library with C itself, but I'd like to rely 100% on guile, if possible :-)
<amz3>felipebalbi: https://framagit.org/a-guile-mind/guile-wiredtiger/blob/master/src/wiredtiger.scm#L343
<felipebalbi>amz3: so, if I understand correctly. (double-pointer pointer) is what turns pointer into &pointer ?
***micro`_ is now known as micro`
<stis> http://c-lambda.se/native-compilation.html function oriented and a little prolog
***rokf is now known as rokf_
***rokf_ is now known as rokf
***random-nickname is now known as random-nick
***random-nickname is now known as random-nick
<amz3>felipebalbi: double-pointer is variable