IRC channel logs

2017-01-03.log

back to list of logs

<janneke>nyacc+mes compile puts, strlen...now for command-line args and strcmp
<janneke>ACTION [now=next] --> zZzzz
***karswell` is now known as karswell
<ArneBab>CharlieBrown: why can’t you use uzbl with tor?
<davexunit>good morning guilers
<OrangeShark>good morning
***peter___ is now known as pmikkelsen
<civodul>hey hey!
<civodul>amz3, OrangeShark: any ETA for a guile-git release? :-)
<OrangeShark>civodul: I just got back to working on it. I think we need to go over what is missing and add some basic documentation.
<civodul>OrangeShark: cool!
<civodul>even if some APIs are missing, you could make a 0.x release or something :-)
<OrangeShark>true, need to make sure all the essential APIs are available. Is there any specific ones you need?
<davexunit>that reminds me that I need to release guile-sdl2 0.2.0...
<civodul>hey davexunit
<civodul>OrangeShark: i think what i need is already there
<civodul>which is why i'm slightly insistent ;-)
<OrangeShark>okay :P
<civodul>i'll check more closely though
<davexunit>hey civodul
<amz3>it's missing at least clone, checkout and merge
<amz3>ACTION reboots
<amz3>so, I have basic code for checkout but I did not push it yet
***logicmoo is now known as dmiles
<amz3>IIUC we must make sure all works under guile 2.2
<amz3>maybe we can deliver what we have at the end of the week
<civodul>amz3: right, clone + checkout would also be useful to me as a 2nd step
<amz3>ok
<davexunit>I got my step-daughter involved in some fun guile hacking last night. :)
<davexunit>she didn't write any code because she can't really type yet, but she did ask for some features and watched me implement them
<holomorph>:D
<davexunit>I had a silly test program running to test out guile-sdl2 and some opengl rendering things. you could move a rotating snowflake around the screen with a usb game controller.
<davexunit>she asked if it could stop spinning and be a dog instead of a snowflake.
<davexunit>then if there could be a forest backgroud instead of black, so we did that.
<davexunit>then she wanted the dog to be able to dig up jewels from the ground, so I made it so when you presed a button on the controller a random gem sprite was added on top of the background under the dog.
<civodul>davexunit: fun!
<davexunit>she seemed really interested in being able to make a game.
<civodul>heh :-)
<civodul>i should try and demo this kind of things to my kids
<davexunit>she said it will be a game that only we have, to which I asked if we could share it with everyone if we made something fun, and she said yes.
<davexunit>so there was a little software freedom lesson in there, too. :)
<davexunit>civodul: having the visuals helps a lot to keep a kid's interest I think.
<civodul>yes
<civodul>i think Ao can be a good vehicle for that
<davexunit>it was a nice dynamic.
<davexunit>yes, Ao looks fun.
<davexunit>I will see if I can continue to keep her interested. I had to veto some of her ideas because they would take too long to implement.
<davexunit>the design team always underestimates the engineering challenges!
<davexunit>she wanted a whole world to walk through, we had to settle for a static background.
<davexunit>oh and she wanted a bear to chase the dog, so I attempted to explain that AI is a tricky thing. ;)
<amz3>ahah
<civodul>"the design team" :-)
<davexunit>so there is my anecdotal evidence that guile + interactivity + cute visuals = hacker training
<davexunit>now if I can just work in the REPL...
<rekado>davexunit: "a bear to chase the dog" <-- that's something we often do in "Snap!" by telling the bear to always point in the current direction of the dog while moving one small step ahead.
<joolean>Hi Guilers! Happy new year.
<civodul>hello joolean, best wishes!
<joolean>Thanks! Same to you.
<joolean>apropos of nothing, could I tempt you or wingo to take a peek at the Ecmascript patch in https://lists.gnu.org/archive/html/guile-devel/2016-11/msg00014.html and merge if you like it?
<davexunit>rekado: yeah, that's a nice easy way to do it!
<davexunit>I probably should have done that, but I was trying to only implement things that I could do extremely quickly. this whole event lasted less than a half hour, I think.
<davexunit>but now I know what I can do next time she asks about this.
***random-nickname is now known as random-nick
***random-nickname is now known as random-nick
<paroneayea>wingo: https://en.wikipedia.org/wiki/Process_calculus is this the theory that fibers is based on?
<paroneayea>what's exciting, if so, is the overlap I've observed between 8sync and fibers in how they do message passing has a well understood link
<paroneayea> https://en.wikipedia.org/wiki/Actor_model_and_process_calculi
<paroneayea>I just discovered that 8sync's concept of a "Hive" (what all the actors attach to)
<paroneayea>is not unique!
<paroneayea>the E capability language has the very same idea
<paroneayea>and calls them "vats"
<davexunit>paroneayea: fibers implements "communicating sequential processes" from http://usingcsp.com/
<paroneayea>davexunit: oh nice, I have this book on my e-reader already :)
<paroneayea>now I can read it offline :)
<davexunit>not specifically guile related but I just found a really nice paper about rasterizing lines in opengl that I'm going to implement with guile http://jcgt.org/published/0002/02/08/paper.pdf
<paroneayea>davexunit: Leading examples of process calculi include CSP ... https://en.wikipedia.org/wiki/Process_calculus
<paroneayea>so yes!
<paroneayea>\\o/
<davexunit>haha
<davexunit>well I'll be
<paroneayea>this is great, I now have a more solid "theory" based relationship to talk about in the fosdem 8sync talk
<paroneayea>yess
<davexunit>:)
<davexunit>not thinking about concurrency has helped me focus on other things, gamedev-wise.
<davexunit>paroneayea: I'm just working under the assumption that you will produce what I need. ;)
<paroneayea>davexunit: :)
<davexunit>I need to tackle font rendering soon... sort of dreading it. I've found a really good technique (and another good paper) for fast, high quality rendering, but I've never done text layout before (looking up glyph metics, kerning tables, etc.)
<paroneayea>wowee I'm so excited.
<paroneayea>(that there's a clear link between 8sync and fibers, and grounded in theory I can point to!)
<paroneayea>this is also great because process calculi is an area of research my brother is interested in and has been reading on
<paroneayea>and likewise (obviously) actors are one I've been researching for some time
<paroneayea>so now we have a great basis to compare notes.
<davexunit>lots of process trees bearing fruit
<paroneayea>:)
<paroneayea> http://git.savannah.gnu.org/cgit/8sync.git/commit/?id=61fed4138184d12cfcdca93035492119999dfa48
<paroneayea>documented!
<CharlieBrown>ArneBab: Because it's not approved by the security mavens...
<CharlieBrown>Unlike TBB.
<djcb>good evening guilers!
<djcb>is it possible to catch errors at the top level in the repl?
<djcb>ie. some hook that gets called if any error occurs?