IRC channel logs

2016-12-28.log

back to list of logs

***micro` is now known as Guest17384
<nalaginrut>morning guilers~
<nalaginrut>I think it's better to implement M4 on Guile, then we can replace it and keep compatibility
<nalaginrut>I'm going to try Nyacc
<nalaginrut>I forced my team to use autoconf this time, but I think most people doesn't like M4 based configure
<janneke>nalaginrut: nice
<jmd>In an exception handler, how can I get the frame in which the exception occurred ?
<amz3`>héllo #guile
<amz3`>I'd like to work again on tinkero app...
<amz3`>or thinkhero... whatever the name...
<amz3`>so many possibilities, so little time
<amz3`>not having time is part of what prevent me from working on this project
<wleslie>tell me about it
<wleslie>(not enough time)
<wleslie>ACTION nearly has his yaks in a row
<jmd>The exception from copy-file is highly misleading.
<jmd>(copy-file "/no/such/file" "/tmp/cc") throws an exception with the args:
<jmd> ("No such file or directory" "/tmp/cc")
<jmd>It ought to say: ("No such file or directory" "/no/such/file") IMO
<OrangeShark>Hello everyone
<OrangeShark>jmd: the docs says the return value for copy-file is unspecified. I wonder if there is a reason for that.
<jmd>OrangeShark: I wondered about that too. But the return value is a different issue.
<jmd>It seems that if copy-file ever returns then the operation was successfull. Otherwise it makes a non-local jump.
<paroneayea>wingo: btw do you think the wip-elisp branch will be merged before guile 2.2 still?
<paroneayea>I think that would be a good thing to not lose track of
<paroneayea>YES
<paroneayea>annoying. bug. squashed.
<paroneayea>and 8sync's agenda is considerably cleaner! :)
<paroneayea>it still has a kind of crappy scheduler (still using the linked list time segments approach from SICP rather than a better datastructure, so adding a lot of delayed events isn't ideal), but that can be fixed, and it's clearer how to replace it now.
<paroneayea>so 8sync's actor model is able to handle 25k message per second.
<paroneayea>I'm sure it could be better but I think that's pretty decent.
<paroneayea>and that's on my old-ass thinkpad x200
<paroneayea>and if an actor uses a ~tight loop where it's yielding execution rather than using message passing, it's about 100k / second.
<davexunit>paroneayea: nice!
<paroneayea>davexunit: :)
<amz3>ohoh!
<amz3>I think I will pull sly 0.1 to do some 2D stuff...
<amz3>something is holding me...
<amz3>what do you think davexunit
<amz3>should I wait for the next release or use one the previous one?
<davexunit>amz3: sly 0.1 is old
<amz3>I have no need for speed, slow is ok
<davexunit>in general I don't recommend using it.
<davexunit>sly is basically abandoned.
<davexunit>as I've mentioned other times.
<amz3>I need 2d shape drawings
<davexunit>it doesn't do 2d shapes
<amz3>0
<amz3>0.1 does
<amz3>it's 0.2 that doesn't IIRC
<davexunit>it doesn't
<amz3>I clearly remember it does, I will pull my project and try to demo it
<davexunit>it doesn't
<davexunit>you can draw rectangles and cubes, that's it.
<davexunit>unless you wrote your own stuff.
<davexunit>I use sprites almost exclusively so I didn't get around to adding other geometric primitives
<amz3>I'd like to use this to make a creative graph illustratr
<amz3>maybe I added something
<davexunit>my focus now is a more low-level library
<davexunit>re-using much of the same code
<amz3>Do you plan to implement tree diffing algorithm?
<davexunit>no
<davexunit>as I said, sly is pretty much abandoned.
<davexunit>I have other plans.
<amz3>my idea is to create illustrations using graph just like the kid game when you link several nodes to form a picture where you could link each node to some media/url/whatever
<amz3>it's a mind mapping application!...
<amz3>too bad darktable is already thing I would have used that name
<amz3>*a* thing
<roelj>Could anyone help with finding the problem of the following code: http://paste.lisp.org/+76K1
<roelj>I am making a web page, where you could go to /hello/world and that would load page-hello-world from a module: (gdms pages hello world).
<roelj>One-level works (/hello and /world).
<roelj>But two-level does not.
<amz3>roelj: you dynamically resolve the url components to a scheme module?
<roelj>amz3: Yes
<amz3>roelj: bad idea, Django was doing that they have been bitten
<amz3>roelj: but this doesn't explain why your code doesn't work :)
<amz3>roelj: see the Application refactor
<amz3>let me see this code
<roelj>I think it breaks on the resolve-module, because 'module-symbol' is a list..?
<roelj>The printer displays the `(gdms pages ,module-symbol) as: (gdms pages #{developers schematic}#)
<amz3>your are implementing PHP router system in scheme, go there, seen what happen
<amz3>s/go/gone/
<amz3>roelj: did you try without space in the something like /gdms/pages/developers/schematic
<roelj>Hm, no. I have the module in gdms/pages/developers/schematic.scm, without the space, I would have to move it to gdms/pages/developers-schematic.scm I suppose.
<amz3>no
<amz3>I saying that in what you pasted there is space in the lasst component
<amz3>I am saying that...
<roelj>What do you mean with 'last component'?
<amz3>the last item in (gdms pages #{developers schematic}#)
<roelj>Ah yes, the space comes from the way module-symbol is made.
<roelj>Hm, is there a way to 'flatten' the whole thing (gdms pages #{developers schematic}#)?
<amz3>roelj: why don't you use string-split ?
<roelj>amz3: How can I then put translate that to (gdms pages first second), where first and second are (string-split request-path #\\/)?
<roelj>Hmm, I gotta run.
<amz3>ok
<roelj>Thanks for looking at my mess :)
<amz3>:)
<roelj>I think I found the problem, so that's good :)
<roelj>I really appreciate your effort.
<davexunit> paroneayea: hoping to have a little game library put together in the next few weeks that we mix with 8sync
<davexunit>that we can*
<amz3>I lost the code that create custom shapes but it use build-mesh
<amz3>anyway
<davexunit>amz3: that makes sense, you can build whatever you want with that.
<davexunit>I'm hoping to have shape rendering in my WIP library
<paroneayea>davexunit: :)
<janneke>yay, Mes now has call/cc