IRC channel logs

2016-12-24.log

back to list of logs

<amz3>rust docs is good, almost as good as racket docs
<amz3>s/is/are/
<fantazo>Hi, could someone explain me why garbage collectors generally are kinda greedy in their memory allocation schemes? As I noticed in running guile locally with a small test where I just generated garbage in a loop that the memory the process uses doesn't shrink, only when I quit guile. I noticed that GC behaviour also when working with other programming languages (java, ruby)
<fantazo>I'm a hacker and the GC is just a black box which does things it shouldn't do. That bewilders me. Makes a lecture of http://gchandbook.org/ it any better regarding understanding?
<sapientech>exit
<sapientech>oops :) just from repl not guile
<fantazo>sapientech, was that an answer to my question?
<[df]>fantazo: I read an interesting article lately:
<[df]> https://medium.com/@octskyward/modern-garbage-collection-911ef4f8bd8e
<[df]>I suspect in the guile case that heap fragementation is occuring (afaik guile doesn't have a compacting gc, though someone more knowledgedable may correct me on that)
<[df]>I think the jvm just grabs a big chunk of heap from the OS and doesn't ever bother to release it
<fantazo>[df], I read that article too. An interesting piece indeed.
<random-nick>fantazo: did you test from a file or from the repl?
<fantazo>random-nick, from the repl.
<random-nick>I remember reading something about the repl changing something in gc settings, but not sure
<amz3>fantazo: sorry I not knowledgeable in this area