IRC channel logs

2016-11-05.log

back to list of logs

<paroneayea>gah!
<paroneayea>a lot of fixes happened to the code I snarfed from Guix to add https support to guile since I originally snarfed it :)
<paroneayea>time to walk through the commit log...
<amz3>o/
<amz3>I discovered something today regarding wiredtiger
<amz3>the issue I had, is that the data was not persisted across restart of the database
<amz3>what I missed in the documentation is that 1) persistence is guaranteed at commit-level aka. commit level durability 2) there is no autocommit
<amz3>the point 2) is the most important, I was just assuming that if no transaction was started the engine would autocommit every operations but it's not the case
<amz3>"most important"
<amz3>anyway, all is well!
<paroneayea>hm.
<paroneayea>I have a problem, it seems!
<paroneayea> http://paste.lisp.org/display/330413
<paroneayea>the short of it is: the gnutls built for guile 2.0 *does* resolve in guile 2.1 if you do (resolve-interface '(gnutls)) or even (use-modules (gnutls))
<paroneayea>it just gives you broken bindings
<paroneayea>at least in my guix setup
<paroneayea>I'm not sure why this is importable for me
<paroneayea>I could do a kludgy workaround and do (procedure? gnutls-version)
<jmarciano>searching for solution as tr// in perl, to use in Guile,
<amz3>jmarciano: what is the question?
<jmarciano>when I have multiple characters like đšžćč to transliterate to dszcc
<jmarciano>in Perl it is done by using tr
<amz3>sorry I can't help
<jmarciano>thank
<jmarciano>s
<jmarciano>maybe you have example for string-replace ?
<jmarciano>ok that one is not usable, I got it
<jmarciano>how can I use srfi 115? It has some good char replacements
<ArneBab>jmarciano: does not look like it’s in Guile - you’ll need to see whether you can get the code working
<jmarcian`>how do I say null char or nothing in regexp-substitute/global?
<jmarcian`>to substitute with "?" with ""?
<jmarcian`>OK I had to escape with \\\\?
<jmarcian`>How can I make this one sane, short and clear? http://paste.lisp.org/display/330422
<jmarcian`>is there a way in Guile to edit functions directly? Like with vim, editor, from REPL?
<amz3>no
<amz3>you can use geiser or the equivalent for vim to edit function and update them on the fly
<jmarcian`>any way to get function definition then? I can make editing.
<jmarcian`>yes, but in REPL
<amz3>I am not aware of such a feature
<jmarcian`>to show a function definition?
<paroneayea>. o O (hm, is it just me or is M-x M-x debbugs-gnu being really slow)
<paroneayea>https patch -> bug tracker :)
<amz3>cool
<jmarcian`>how do I see all open ports?
<amz3>jmarcian`: why do you want to do that?
<jmarcian`>to examine which ports are left open
<amz3>I don't think you can do that in pure guile, i've never seen such facility in a language
<paroneayea> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24075#14 <- https patch
<amz3>jmarcian`: you might need to rely on a strace to do what you want
<jmarcian`>Don't know how to use it, I wish to get it in REPL
<jmarcian`>I would like to write to file, and read from file.
<rlb>civodul: uploaded 2.0.13+1-2 with your fix - thanks again.
<civodul>thank you rlb!
<amz3>jmarcian`: try this
<amz3>atw (~user@c-73-147-38-191.hsd1.va.comcast.net) a rejoint #guile e@(guile-user)> (use-modules (ice-9 rdelim))
<amz3>scheme@(guile-user)> (with-input-from-file "/proc/cpuinfo" read-string)
<jmarcian`>ohhhh, thanks, relief...
<amz3>jmarcian`: to write use with-output-to-file
<jmarcian`>there is no write-string?
<amz3>jmarcian`: using the with procedure you will avoid leaving some ports open behind
***random-nick is now known as beakiloo
***beakiloo is now known as random-nick
<jmarcian`>I guess they get closed
<jmarcian`>how to write? Or opposite of read-string?
<amz3>jmarcian`: (call-with-output-file "/tmp/foo" (lambda (port) (format port "echo")))
<jmarcian`>Thank you. And how to avoid: ;;; <stdin>:40:0: warning: non-literal format string
<amz3>idk
<jmarcian`>Thank you amz3: http://paste.lisp.org/display/330432 now I can edit some text
<jmarcian`>I guess it could be way simpler.
<jmarcian`>to write to file, edit that file, and give back the value
<jmarcian`>I see it is not working well
<amz3>=)
<jmarcian`>OK now, proc to port...
<jmarcian`>scheme and lisp are so much saner in comparison to Perl
***jmarcian` is now known as jmarciano
<jmarciano>how to catch wrong types?
<daviid>lloda: your 'can ony one try this ...' fails here too
<daviid>(format #f "~2f" 9.95)
<daviid>ice-9/format.scm:1525:37: In procedure format:fn-round:
<daviid>ice-9/format.scm:1525:37: In procedure string-ref: Value out of range: 18446744073709551615
<daviid>2.1.4
<daviid>happy saterday guilers!
<daviid>civodul, mark_weaver, wingo: I'm preparing a (prelimary version of a) webpage for g-golf... I'd like to share guile-user and guile-devel mailing lists instead of creating go-golf-user[devel], because I really wish to benefit from the knowledge of both of these list members to help me with the design, development ..., then users may help users as well ... is that ok with you? (not that I've created a separate bug mailing list
<daviid>(bug-g-golf))
<daviid>well, uploaded! if any problem wrt the above, let me know and I'll create separate mailing lists