IRC channel logs

2016-10-29.log

back to list of logs

<ArneBab_>status-info: This is the result of the argument-parsing to run tasks (though the task is a dummy-task). It now also includes per-task help output: http://paste.lisp.org/display/329818
<ArneBab_>davexunit, paroneayea, amz3: thank you! (see ^)
<ArneBab_>(and debugging output via -d | --debug
<ArneBab_>)
<ArneBab_>the most important part for me: each task is just a regular procedure, per-task help is simply the docstring.
<ArneBab_>utility procedures are filtered out (by being added to the list utility-procedures)
<ArneBab_>I can now call: ./createplots.w task1 task2 task3, and it will simply do these tasks.
<ArneBab_>and ./createplots.w --help shows all tasks
<ArneBab_>help works via -h, --help or help and via -h TASK, --help=TASK or help TASK
<ArneBab_>I miss --help TASK, but I can live with that :)
<ArneBab_>⇒ I’m happy ☺
<ArneBab_>thank you!
<sapientech>hi all, interested in putting data structures in the functional position. is there a way to modify how guile applys all procedures to check for a datastructure?
<sapientech>i have modified apply to do this, but i dont know how to change this for any funapp
<sapientech>if possible i want to stay compatible with guile, rather than make a new dialect
<sapientech>fyi datastructure in functional position means (some-hash-table 'some-key) ==> (hash-ref some-hash-table 'some-key)
<sapientech>and would dispatch appropriately to other datatypes
<sapientech>thanks all!
<civodul>sapientech: record types can have an 'apply' slot
<civodul>for instance SRFI-39 parameters are records, but they can be "applied"
<civodul>though applicable struct are not really public it seems
<sapientech>civodul: oh interesting, are these srfi-9 records youre talking about
<civodul>sapientech: "structs", the thing below SRFI-9 records
***karswell` is now known as karswell
***djose is now known as Guest2827
<paroneayea>ArneBab: great to hear :)
<sapientech>civodul mentioned that we can have applicable structs in guile. it looks like this is used in goops where there is an applicable struct class. is there a way to use applicable structs without goops?
<paroneayea>sapientech: can you define "applicable structs"?
<paroneayea>oh
<paroneayea>you mean like, callable like a procedure...?
<paroneayea>sapientech: I don't know for sure, but it looks like libguile/struct.c contains some useful info
<paroneayea>read teh comment in scm_i_struct_inherit_vtable_magic
<paroneayea>SCM_VTABLE_FLAG_APPLICABLE seems to be the right thing, but is it exposed to scheme? I dunno!
<sapientech>paroneayea: yeah i was looking at that section and appears in goops we have (class-add-flags! <applicable-struct-class> vtable-flag-applicable-vtable)
<sapientech>so im making a class that inherits from it to play around
***Guest2827 is now known as djose
<jmd>How do I run a compiled .go file?
<jmd>(yes I have read the manual)
<amz3>héllo #guile :)
<jmd>I have a guile program where (feature? 'i18n) evaluates to #t. However (gettext"string") does absolutely nothing except return "string". Yes, I have called setlocale, textdomain and bindtextdomain. What have I forgotten?
<jmd>What does this error mean: ERROR: Unbound variable: GOOF----LE-8-2.0
<tantalum>is it normal that the following gives an "unbound variable: b" error? (define-syntax define-b (syntax-rules () ((_) (define b 2)))) (define-b) (write b)
***djose is now known as Guest64980
***Guest64980 is now known as djose
<taylan>tantalum: yes, because of the concept of "hygiene". you have to think a bit like a machine. imagine that define-b were defined in some other module. the name 'define-b' may make it evident to you that it will define a variable called 'b', but technically you don't know that. so it's not allowed. every variable binding must happen in such a way that the variable being bound is clearly visible.
<taylan>tantalum: if you really want an "unhygienic" macro, you can write one via the lower-level macro system, i.e. syntax-case.
<tantalum>thanks for the response. ic, somehow i forgot about this in regards to introducing bindings. i had started out with a syntax-case definition and got the error. i think i just have to introduce the binding differently, probably with-syntax or unsyntax.
<paroneayea>sapientech: interesting!
<paroneayea>sapientech: lmk if you get it to do something ;)
<MorrisSzyslak>Hi I want to parse xml with guile, so I tried this simple example: (xml->sxml "<foo/>") from https://www.gnu.org/software/guile/manual/html_node/Reading-and-Writing-XML.html#Reading-and-Writing-XML but I get an error "Wrong type ... expecting open input port"
<MorrisSzyslak>However the documentation says I can give string or input port
<MorrisSzyslak>I have guile 2.0.5
<MorrisSzyslak>but I don't think it is related
<MorrisSzyslak>ok I must use open-input-string
<MorrisSzyslak>thx
<paroneayea>whee
<paroneayea>sent a patch to the bug tracker so that `guile --listen=/tmp/guile-socket' will be nice and clean up that socket file afterwards
<paroneayea>which has been really annoying me :)
<amz3>taylan: you have a PR https://github.com/TaylanUB/scheme-bytestructures/pull/12
<amz3>OrangeShark: I've pushed a few things, like tests and moved commit related procs to commit.scm
<amz3>OrangeShark: also I've added guile-bytestructures to guix.scm but I'm too lazy to add lookup how to add it do configure
<OrangeShark>amz3: okay, I will add it to configure when I have the chance to
<amz3>ok :)
<amz3>otherwise I'm adding the Makefile the files I created
<amz3>so they are now 3 tests files...
<amz3>it's now possible to create a very basic 'git log'
<rlb>Regarding the repl test failure, looks like it's not just powerpc and i386. I guessed there might be some kind of race, and found that this will (eventually) reproduce the failure here:
<rlb> while GUILE_LOAD_PATH=. ./guile-test tests/00-initial-env.test tests/00-repl-server.test; do :; done
<rlb>It looks like the initial repl prompt is being lost when it fails:
<rlb> FAIL: tests/00-repl-server.test: repl-server: simple expression - arguments: (expected-value "scheme@(repl-server)> $1 = 42\\n" actual-value "$1 = 42\\n")
<rlb>
<rlb>The initial part of the repl prompt I mean.
<paroneayea>hup
<paroneayea>ACTION starts looking at adding tls/https support to guile proper again
<amz3>ACTION would be very happy!
<rlb>Wonder if there could be some kind of buffering problem between read-line and read-string...
<taylan>amz3: thank you! merged :)
<amz3>:)
<daviid>taylan: tests failed here using 2.1.4
<daviid>taylan: here http://paste.lisp.org/+72IS
<daviid>taylan: i think you did not commit this file, I don't have it here
<daviid>and just cloned
<taylan>daviid: fix pushed. seems it was an oversight during directory structure restructuring
<daviid>taylan: thanks, trying
<taylan>thanks for notifying me
<daviid>taylan: wc! all tests passed
<daviid>%%%% Starting test bytestructures (Writing full log to "bytestructures.log")
<daviid># of expected passes 214
<daviid>
***random-nick is now known as spooky-spook
<sirgazil>jmd: for what is worth, I have some i18n exercises in my guile lab repo. See i18n-hello, i18n-multidomain, and polyglot files in the src directory.
<sirgazil>jmd: https://bitbucket.org/sirgazil/myglab/src/
<jmd>sirgazil: I will take a look. Thanks.
***spooky-spook is now known as random-nick
***random-nickname is now known as random-nick
<paroneayea>civodul: got a sec?
<paroneayea>civodul: wondering if I can just make sure I'm doing the right thing with the "https support in guile proper" thing
<paroneayea>civodul: if you're too busy, no worries :)