IRC channel logs

2016-10-06.log

back to list of logs

<davexunit>ACTION reads a bit of the csp book
<davexunit>it's convenient that it has snippet of lisp, because I understand that much better than all this math notation
***codemac`` is now known as codemac
<lloda>the spacing at the top of https://www.gnu.org/software/guile/manual/html_node/ looks broken
<civodul>paroneayea: great blog post, i hope the W3C spec will hit the next stage!
<paroneayea>thanks civodul :)
<paroneayea>me too!
<civodul>that got me wanting to try out soci-el :-)
<paroneayea>civodul: annnnd I just wrote up a crazy plan for a more "functional" / better distributed social network http://dustycloud.org/blog/an-even-more-distributed-activitypub/ :)
<civodul>paroneayea: i see the post features the word "blockchain", so it must be the right thing ;-)
<civodul>but yeah, a git-log/blockchain/persistent kind of data structure makes sense to me
<civodul>(not that i'm an expert ;-))
<paroneayea>civodul: "blockchain" just means signed ledger these days :)
<wleslie>pleasant UGT morning, #guile
<paroneayea>moin moin wleslie
<wingo>i thought blockchain meant "series A"
<wingo>:)
<paroneayea>wingo: ha
<paroneayea>wingo: well, "series A" has lead to a proliferation of things called "blockchain", and thus probably a dilution of the term, but in this case I'm not complaining... there are some incredible things coming out because of it
<paroneayea>the Stellar consensus protocol being the most interesting to me.
<paroneayea> http://stellar.org/papers/stellar-consensus-protocol.pdf
<paroneayea> https://www.stellar.org/how-it-works/stellar-basics/explainers/ if you want a less academic explaination
<paroneayea> https://www.stellar.org/stories/adventures-in-galactic-consensus-chapter-1/ or in comic form ;)
<wingo>imagine rebuilding guix if all your tarballs were on another planet
<paroneayea>Always Be Compiling
<paroneayea>the guix slogan! ;)
<paroneayea>(Always Be Rebuilding I guess is better because there could be substitutes, but that's not an ABC)
<wingo>:)
<wingo>i suppose Always Be Building CXX object Source/WebCore/CMakeFiles/WebCoreDerivedSources.dir/__/__/DerivedSources/WebCore/JSEventTarget.cpp.o is not so catchy
<OrangeShark>morning
<amz3>o/
<OrangeShark>hi amz3
<lluis>how do I control what gets evaluated when a macro is expanded?
<OrangeShark>amz3: I sent you some merge requests to guile-git. It uses autotools and should be able to find libgit2 automatically :)
<amz3>OrangeShark: neat!
<OrangeShark>tell me if it works for you
<amz3>I can't test right now, but later today I'll do
<OrangeShark>It works with guix and on my laptop that doesn't use guix
<OrangeShark>there is also a guix.scm file :)
<codemac>Should I file a bug report about system* / open-pipe* not handling stderr correctly? Or do I have a misunderstanding? Here is my test case: http://paste.debian.net/857673/
<davexunit>codemac: judging from yesterday's log, you have a misunderstanding about how some things work.
<davexunit>the current output and error port in guile have *nothing* to do with stdout and stderr
<davexunit>and things like (call-with-output-string (lambda () (system* "ls"))) won't produce a string with the current directory's contents
<codemac>Oh, I don't doubt I have a deep misunderstandy. Ok, so in my paste I did a parameterize on current-output-port and current-error-port, and then call system*, expecting it's stdout and stderr to go to what I have set the current-* to be. Is that not what should happen?
<davexunit>correct.
<davexunit>there's a couple problems there
<davexunit>the current output and error ports are purely a guile construct, they don't affect the file descriptors that correspond to stdout and stderr
<davexunit>if you want to capture the output of a program, you need to use a pipe.
<codemac>ok, but open-pipe only has open_read and open_write, there's no concept of stderr as far as I can tell?
<jmd>Is there a way to have a procedure run whenever a module is loaded?
<jmd>(yes I have read the manual)
<davexunit>I don't know of a hook for that
<OrangeShark>jmd, wouldn't just calling the function in the module do that?
<jmd>OrangeShark: So it does. Thanks.
<davexunit>oh, I thought this was about calling a hook whenever *any* module is loaded
<amz3`>OrangeShark: on your guixsd machine, do you use guile 2.0 or guile 2.1?
<OrangeShark>I am just using guix on Fedora
<OrangeShark>and with guile 2.0
<amz3`>Okay!
<amz3`>I got it working with guile 2.0 there seems to be some issues on guix with guile 2.0 vs guile-next
<amz3`>anyway
<amz3`>thx OrangeShark you did the right thing! I fullly forgot to mention the config.scm but you knew about it :)
<OrangeShark>okay, I haven't tried guile-next
<wingo>ACTION gently pokes ecraven about a new benchmark run :)
<jmd>What's the best way to enter a long string of text into a guile program?
<civodul>(call-with-input-file "long-string.txt" get-string-all) :-)
<jmd>s/long/medium length/
<ecraven>wingo: building now :)
<wingo>excellent :)
<ecraven>it'll run over the weekend, the results should be around start of next week :)
<ecraven>sorry to keep you waiting so long!
<wingo>np, thanks for the benchmarking, it's fun to see :)
<davexunit>I think the benchmarks are a nice way to encourage some friendly competition
***codemac` is now known as codemac