IRC channel logs

2016-09-15.log

back to list of logs

<amz3`>sotoki is still running :)
<amz3`>sorry wrong chan
***heroux_ is now known as heroux
***wleslie is now known as shooper
***shooper is now known as wleslie
<OrangeShark>morning
<wleslie>gninrom
<b4283>just realized there's a (string-reverse)
<paroneayea>o/
<wleslie>\\o
<paroneayea>hi wleslie
<wleslie>what's new?
<dsmith-work>Thursday Greetings, Guilers
<wleslie>Greetings from The Future, dsmith-work (:
<dsmith-work>It's always Thursday somewhen
<paroneayea>somewhen :)
<amz3>:))
<random-nick>amz3: is that an alien with 2 mouths?
<amz3>random-nick: no it's not an alien ;)
<paroneayea>ACTION compiles guile 2.1.4
<janneke>paroneayea not uses guix?
<paroneayea>janneke: I am
<paroneayea>but there isn't a substitute yet
<paroneayea>wingo: once I get guile-next built here, I'll try to see about packaging guile-fibers for guix
<paroneayea>wingo: I *might* try to use it for Pubstrate, if I have time to experiment with it.
<paroneayea>I have a good reason to want to do something async'ish, even with pubstrate being a demo:
<paroneayea>submitting an entry to your inbox is all well and good, but you should be able to give a response before the thing potentially federates
<janneke>ACTION wishes for distributed network of trust of guix-publish'ers
<amz3`>what is guix?
<dsmith-work>!!
<dsmith-work>sneek: guix?
<sneek>I've heard guix is a functional package management tool for the GNU system
<dsmith-work>sneek: guix?
<sneek>Someone once said guix is a functional package management tool for the GNU system
<amz3`>Some One has the link of the benchmarks of Guile against other Scheme?
<amz3`>wingo: ?
<amz3`>I've been wondering about functionnal distributed filesystem lately, I don't how it works, yet
<amz3`>sneek: culturia?
<amz3`>that's fun!
<amz3`>guile help filter
<amz3`>sneek: guile help filter
<amz3`>it doesn't output here :/
<amz3`>sneek: learn something
<amz3`>sneek: culturia is search engine for GNU system
<sneek>Understood.
<amz3`>sneek: culturia is search a engine for GNU system
<sneek>So noted.
<amz3`>sneek: culturia?
<sneek>I've heard culturia is search a engine for GNU system
<amz3`>sneek: culturia?
<sneek>Last time I checked culturia is search a engine for GNU system
<amz3`>sneek: culturia is a search engine for GNU system
<sneek>So noted.
<amz3`>sneek: culturia?
<sneek>Someone once said culturia is search a engine for GNU system
<amz3`>sneek: culturia?
<sneek>From what I understand, culturia is search a engine for GNU system
<amz3`>meh
<amz3`>antispam?
<amz3`>sneek: culturia?
<sneek>Last time I checked culturia is search a engine for GNU system
<amz3`>sneek: culturia is a search engine for GNU system
<sneek>I'll keep that in mind.
<amz3`>sneek: culturia?
<sneek>I could be wrong, but culturia is a search engine for GNU system
<amz3`>:)
<amz3`>The biggest bug I face is that for building the search engine interface, I need to have a second thread for dealing with database calls
<amz3`>I find it painful to have to deal with several processu at the terminal
<amz3`>so I'm thinking on ways to embedded the database processus inside the web processus...
<amz3`>but now that I think about it, my server will never do more that 500 request per second... so I can probably simply do blocking calls
<amz3`>1500 RPS I mean... so it can do blocing calls...
<amz3`>nice comment about gambit-c on HN https://news.ycombinator.com/item?id=12502617
<avoine>what is the guile's version of (void) function he's talking about?
<DeeEff[m]>avoine: (void) isn't even useful when you have it
<avoine>ACTION didn't know you could write a makefile with guile, pretty cool!
<DeeEff[m]>it's mostly a placeholder for an "undefined" state or value
<avoine>ok
<amz3`>isn't that the role of '()
<amz3`>?
<DeeEff[m]>like, if you use `(for-each proc lst)`, the return value is undefined as per the standard
<DeeEff[m]>there is no standard return value
<amz3`>hmm...
<DeeEff[m]>so an implementation can do anything
<OrangeShark>amz3`: it the unspecified value returned by certain things
<DeeEff[m]>in Gambit and CHICKEN, they use the result of (void), which is an "undefined" atom
<amz3`>it's like similar to a (current-undefined)
<amz3`>?
<DeeEff[m]>basically, you should strive to never need that value in your code (and to be honest, you probably never will)
<amz3`>it seems strange, but probably if the vm did return always '() it would incure a performance impact or something
<amz3`>that's how I understand it
<OrangeShark>it like the result from doing (if #f 'foo)
<OrangeShark>so it doesn't print anything
<amz3`>hmmm
<OrangeShark>but you can do (define x (if #f 'foo))
<OrangeShark>and now you have the unspecified value
<amz3`>so in the REPL they actually check for the existance of undefined at least to avoid to print anything?
<OrangeShark>yeah
<amz3`>but it's the only time in should happen in the life of an application?
<davexunit>there is an *unspecified* object
<davexunit>you can return 0 values with (values)
<davexunit>(or *unspecified*, but I think it's best to not refer to that object directly)
<OrangeShark>I think it something scheme implementations picked up because the spec says certain special forms have an unspecified value
<amz3`>on an unrelated topic, there is python library that seem to achieve a lot of performance using asyncio and postgresql binary protocol https://magic.io/blog/asyncpg-1m-rows-from-postgres-to-python/
<amz3`>thx OrangeShark davexunit DeeEff[m] avoine
<OrangeShark>amz3`: oh right, async and await is out already for python?
<DeeEff[m]>ACTION never got on the async / await train from C#
<davexunit>get on the call-with-prompt train instead
<DeeEff[m]>Well, if I used Guile more often than CHICKEN maybe :)
<DeeEff[m]>I'm on the call/cc blunderbuster unicycle express
<davexunit>:)
<DeeEff[m]>we don't need feet where we're going, so footguns are welcome
<amz3`>OrangeShark: it's python 3.5, dev version is 3.6 which support at last lazy async generators without going through OOP forms
<OrangeShark>ah and 3.5 also introduced the type hints, I remember that being talked about for awhile
<amz3`>yes type hints
<amz3`>I'm not very happy with this change, it can make my life quite less happy as I enjoy dynamic programming a lot, but python seems to have a lot of success with things like cython so they are investigation typing
<amz3`>DeeEff[m]: :)
<OrangeShark>amz3`: well it is optional
<amz3`>OrangeShark: it won't be optional when at $WORK we will rewrite on core business engine from C to that Python
<random-nick>amz3`: is this the benchmark you were talking about? http://ecraven.github.io/r7rs-benchmarks/benchmark.html
<amz3`>random-nick: yes thanksa lot
<OrangeShark>amz3`: well types help with some of the checking needed by developers when designed software
<amz3`>I will create the web interface of my search engine... let's dot it!
<paroneayea>hm
<paroneayea>fibers has GUILE_PKG([2.2]) in configure.ac, which makes sense
<paroneayea>but it means that guile-next which is 2.1.4 doesn't work, though
<paroneayea>switching it to 2.1 doesn't work either!
<OrangeShark>paroneayea: guile-next should be considered 2.2
<dsmith-work>Yes
<paroneayea>OrangeShark: strange, I wonder why it didn't find that guile...
<paroneayea>maybe it's because I didn't do --pure on the environment
<paroneayea>that's probably it...