IRC channel logs

2016-08-22.log

back to list of logs

<roelj>Is there a way to tell the garbage collector something has already been collected?
<spauldo>anyone have any good advice for keeping the cache clear when debugging libraries? I'm using emacs/geiser/quack and for some reason it's getting an old version of the stuff I'm working on.
<mark_weaver>the cache lives in $HOME/.cache/guile/ccache/
<spauldo>I deleted everything under ~/.cache/guile (it's not a system library, it's guile-sdl2 in a subdirectory of my home directory)
<spauldo>hrm. Wonder what it could be, then. Is there a way to tell if a symbol is in a .go file?
<mark_weaver>sorry, I have to go to sleep now. good luck!
<spauldo>that's cool, sleep well
***spauldo is now known as spauldo-afk
<sapientech>hi all, using a (define-macro macro-name ....) in (display (macro-name ...)) says: definition in expression context, where definitions are not allowed
<sapientech>doing some research, and it seems like the issue is that since these macros are defined in their own modules, they are not available to the macroexpander in the module that i import them from
<sapientech>guile manual 6.17.11 local inclusion is where im looking
<sapientech>eval-when seems appropriate here?
<sapientech>but in general, with guile, do you guys think its better to have mutliple files for these macros, and use (include ...) or to have these macros in modules, and use eval-when, or the like
<sapientech>i think what i said about macros not being available until runtime is not true, eval-when section says they are available at expansion time, but the issue is when it tries to call a normal procedure
<sapientech>a little help would be great :)
<amz3>héllo :)
<amz3>I recieve SICP and reasoned schemer at work today \\o/
<amz3>SICP is a big book actually
<artyom-poptsov>amz3: Congrats!
<artyom-poptsov>For me, I very much enjoyed the old MIT video course based on SICP, recorded back in 1986.
<rekado_>I always forget how to use match with an alist (the manual could have a few more examples)
<OrangeShark>morning
<rekado_>I'm trying to use Guile's web server as a backend for a JS uploader library. In the process I find that I need to deal with multi-part form data, which appears in Guile as a request body that is encoded as a bytevector.
<rekado_>Do you know of any code I could snarf to process the request body?
<rekado_>now I'm extracting the boundary string from the headers, convert the body to a UTF-8 encoded string (not sure if that's always correct), split the big string at the boundary string, and manually process the chunks.
<paroneayea>rekado_: heh, I have to do this too
<paroneayea>I wrote some old code for it, but it was when I first used guile, and I think it's probably no good
<paroneayea>rekado_: I'd be interested in seeing what yours looks like
<paroneayea>rekado_: we should probably try to get a procedure for this into guile proper
<joolean>Good morning #guile.
<rekado_>paroneayea: I'm sure my procedures are probably not good enough because I'm unaware of all the pitfalls of dealing with multipart data.
<rekado_>but I'll give it a try anyway and maybe produce a patch in the end.
<paroneayea>rekado_: :)
<paroneayea>rekado_: well, if not all pitfalls are handled, future patches! ;)
***berndj-blackout is now known as berndj
<paroneayea>wowee
<paroneayea>I love the combinator aspects of guile's character sets
<paroneayea>it was so easy to get a version of the character set that only contained the values acceptable for cookie keys and cookie values
<davexunit>yeah character sets are pretty nice
<davexunit>used them a lot for guile-syntax-highlight and other parsing chores
<sapientech>ive done a bit more testing, and the macro works when i simply call it on the repl, but it fails when its called inside a lambda expression
***dsmith is now known as dsmith-work
<dsmith-work>Morning Greetings, Guilers
<zv>morning
<amz3`>héllo again :)
<stis>heya
<stis>:)
<sapientech>this is the definition in ,exp (macro-name ...) that fails when i do (lambda _ (macro-name ...) 0) http://paste.lisp.org/+6XYR
<sapientech>*where i get the error: definition in expression context
<amz3`>sapientech: can you make a paste with a bit more context
<amz3`>what is the #{% g6267-procedure}# please
<dsmith-work>sapientech: Or better yet, paste the source of the macto
<dsmith-work>macro
<amz3`>spauldo-afk: did you succeed at binding SDL_Rect?
<retroj>does guile support #; syntax to comment a single sexp?
<evhan>retroj: It does.
<retroj>thank you
<amz3`>I almost have boolean search working, I'm wondering how to make negation work
<amz3`>maybe it's better to filter the result of the rest of the query against the negation
<amz3`>then I'll work on phrase search
<amz3`>and after that I will dig bm25f
<amz3`>and then I'll have a look at stemmers, which will be the real thing for full-text search
<amz3`>in the mean time, i go to sleep :)
<amz3`>night!
<OrangeShark>night amz3`
<mark_weaver>sapientech: first of all, I strongly recommend against using 'define-macro' in new code. please use 'define-syntax' instead.
<mark_weaver>I'd be very surprised if 'eval-when' is appropriate here. it almost never is.
<mark_weaver>sapientech: if you can paste a self-contained example that exhibits the problem you're having, I can help more efficiently