IRC channel logs

2016-08-16.log

back to list of logs

***karswell` is now known as karswell
<jlicht>hi guile! How do I create a regexp in guile that can match either: an alphanumeric character, the '[' character, or the ']' character?
<OrangeShark>jlicht: I believe you can do [][a-zA-Z0-9]
<jlicht>OrangeShark: thanks. That was somehow less complicated than all the things I tried XD
<OrangeShark>] has to be the first character if you want to be able to match it
<jlicht>that kind of makes sense
<OrangeShark>I think that is only specific to POSIX regexp
<davexunit> http://scheme2016.snow-fort.org/
<davexunit>the program seems interesting
<davexunit>and there's a talk about guix :)
<amz3>there is a talk about artanis
<dsmith-work>Morning Greetings, Guilers
<fantazo>whats hot in guile at the moment?
<mark_weaver>guix is hot
<davexunit>yeah that's pretty much *the* big project right now
<davexunit>no other guile project receives nearly as much attention
<fantazo>why is guix hot? it's just a package manager onto which people built another distribution.
<janneke>that's one way to look at it
<cmhobbs>because it's a somewhat complex collection of programs written in guile?
<cmhobbs>my guess is the guile community is relatively small compared to other languages so a project of guix's scope takes up a lot of the more involved dev's time
<fantazo>hmm, true.
<davexunit>people often say that you can't write "real" programs in Lisp
<davexunit>so Guix is pretty great because it's a big complicated thing that is written almost entirely in Scheme
<fantazo>ok, I thought guix was just a frontend to another package manager.
<davexunit>no, it's an implementation of a package manager
<davexunit>and it's a distro
<davexunit>and it uses an init system called GNU Shepherd which is also written in Guile
<davexunit>the initial RAM disk is written in Guile, too
<davexunit>running GuixSD is the closest thing I've ever had to a Lisp machine ;)
<OrangeShark>Guix is based on Nix, which is probably what you were thinking.
<janneke>plus it's a transactional package manager that gives source/binary transparency
<janneke>and it's a nice showcase of the sillyness of creating a new language instead of using lisp
<amz3>héllo #guile!
<amz3>culturia is hot!
<amz3>:p
<fantazo>janneke, I can agree on that sentiment. as I'm also finally fed up with all the new languages people threw out in recent years.
<amz3>the 'new language' fatigue
<fantazo>go, rust, swift, elixir, what-have-you. do I have the time to re-learn some stupid syntax particularities combined with specific runtime characteristics.
<fantazo>hell, developing software is in itself hard enough. why make it even harder? my guess is the reason is that people want to feel smart and get more money by selling old-shit in a new skin.
<sneek>So noted.
<amz3>people are interested in this part of computer science
<fantazo>making new languages?
<amz3>yes
<fantazo>well, true. I was myself.
<amz3>the problem is not about making new languages, the problem as I see it, is that it's very hard to tell which one is really valuable
<amz3>javascript has the same issue with frameworks
<amz3>people create frameworks, but nobody take the time to review them
<OrangeShark>what did sneek note? lol
<amz3>dunno
<OrangeShark>amz3: ya, there is a like a new JS framework every month
<dsmith-work>sneek: hell, developing software ?
<dsmith-work>sneek: developing software ?
<sneek>I could be wrong, but developing software is in itself hard enough. why make it even harder? my guess is the reason is that people want to feel smart and get more money by selling old-shit in a new skin.
<OrangeShark>lol
<dsmith-work>sneek forget developing software
<sneek>Consider it forgotten.
<dsmith-work>OrangeShark: sneek ~~ skin
<dsmith-work>Does some kind of sloppy nick matching.
<dsmith-work>ACTION *really* should fix that..
<amz3>OrangeShark: the worst, is that people don't really explain where the ideas come from. It's just a hot potato framework that you have to swallow or you are out
<amz3>OrangeShark: e.g. someone explained that ReactJS is a re-make of some 90s GUI pratices with some bits of web components. But facebook (the creator of reactjs) never said so..
<amz3>I like to know where things come from, what lead to this particular pattern etc.
<amz3>for instance, you'll never find why MVC is not particularly a good fit for javascript frontend dev
<fantazo>the whole react-craze I haven't understood. why was/is react "hot"? and what practices are they re-using like amz3 mentioned?
<OrangeShark>amz3: I remember when it was pretty much only jQuery, which was mostly just used to get around a lot of the different quirks between browsers. Then all these frameworks started popping up
<amz3>fantazo: reactjs is hot, is competing with w3c standard aka. the web components
<fantazo>I would appreciate some fine links, because I couldn't come up with a proper reasoning.
<amz3>fantazo: I can't tell, I don't remember correctly
<amz3>fantazo: a reasoning about what?
<amz3>that's said, reactjs does some new stuff like functional programming
<fantazo>amz3, reasoning about the WHY some pattern is bad. WHY you shouldn't implement X to solve problem Y.
<amz3>I think it's the component architecture of reactjs which looks like web components which itself look like classic desktop apps
<amz3>I have the pragrammatic programmer in my bag, but it's not a book about pattern per se
<amz3>(reading about patterns is almost useful without praticing, so instead of reading books about patterns you can read about framework like elm, sly, reactjs, angular etc...)
<amz3>(I find it easier)
<amz3>(kind of)
<mark_weaver>fantazo: when I said "guix is hot", I was referring specifically to the fact that it's getting a large amount of interest, in terms of number of contributors, number of commits, traffic on the mailing lists, etc. you can decide for yourself whether we are all fools for being excited about it :)
<mark_weaver>but check out the openhub page for guix, for objective numbers of those things
<mark_weaver>anyway, I have to go afk. happy hacking
<amz3>thx
<OrangeShark>fantazo: some other projects that I think are interesting which are written in Guile is haunt, sly, and GNU Artanis
<OrangeShark>also amz3's Cultura, I need to read more about it.
<OrangeShark>*Culturia
<davexunit>OrangeShark: I think I got a patch from you in an email. just wanted to let you know that I saw it but haven't been able to look it over yet.
<OrangeShark>davexunit: alright, thanks for telling me :P
<OrangeShark>I knew you were pretty busy with that lisp game conference
<amz3>OrangeShark: thx for your interest but right now culturia is just yet-another-pet-project
<amz3>;)
<amz3>n-for-each-par-map looks awesome!
<amz3>looks like hn/firebase banned my ips or something, it's super slow
<amz3>actually from home I get a 405 not allowed
<amz3>and from the server it's super slo
<amz3>slow
<paroneayea>hello #guile
<paroneayea>ACTION hacking on pubstrate still....
<amz3>o/
<paroneayea> http://dustycloud.org/tmp/pubstrate_2016-08-16.jpg
<paroneayea>well
<paroneayea>client to server part of the activitypub protocol mostly works
<paroneayea>and I can display things
<paroneayea>getting closer
<amz3>finally HN API workks, I've put to good use n-for-each-par-map to good use
<amz3>it's also time to go to bed!
<amz3>ahaha!
<amz3>paroneayea: it looks promising, keep it steady!
<paroneayea>thx amz3 :)
<fantazo>when happens the lisp singularity? the meta lisp which combines different lisps on different implementations?
<fantazo>I mean macros should do that.
<ijp>sounds like "let over lambda" macroist silliness
<zv>yep
<zv>btw, i'm getting a different result from srfi-64 'test-equal' from (test-assert (equal? x y))
<zv>any good way to debug this?