IRC channel logs

2016-07-23.log

back to list of logs

<amz3`>wingo: can I have multiple event loop in several thread with guile fiber?
<jeffers-media>wingo: happen to take a look at my post a day ago? i was wondering why compiled elisp files are not supported
<jeffers-media>fixing this could really help startup time, which is quite slow atm
<galex-713>amz3`: oh, talking of guile-fiber, I searched on my search engines and didn’t find it :o
<galex-713>PuercoPop: ok, but I don’t think I would be able to program a db with the perfs of sql dbs… :/
<galex-713>amz3`: yes eval it
<holomorph>ACTION wonders about the wip-elisp branch…
<galex-713>it seems these time increasingly more people are interested in guile-emacs…
<galex-713>ACTION wonders why
<janneke>ACTION also needs syntax-case, apparently even harder than syntax-rules, oh well
<janneke>ACTION -> zZzz
<zv>any ideas of where to start if compiling breaks my code but `--no-auto-compile` succeeds?
<ijp>it's not easy to give advice for that situation
<ijp>if it doesn't depend on a lot of external stuff I can take a look
<zv>yeah ijp, I've extracted lines 54-439 into a module here: https://github.com/zv/SICP-guile/blob/master/sicp4.scm
<zv>when I do this, about half of my tests fail.
<ijp>1503 lines :/
<zv>When I extract thoses lines into a file called 'base' and `(load "base.scm")', it works with `--no-auto-compile` but not with regular guile
<zv>well, I'm trying to make it smaller you see
<zv>also, I highly value any general advice, be it broadly related to programming, lisp or guile specific.
<zv>particularly from you ijp
<ijp>load seems problematic
<ijp>if you are mixing phases then breakage will happen
<zv>i read the earlier document you linked about the tower, i thought that might have something to do with it
<ijp>what if you make base a module
<zv>ijp, the same number of tests fail as if I had just compiled my code
<zv>let me put together a few branches to make life as easy as possible for you
<zv>should you decide to look at it
<ijp>with respect, I was a lot more interested when I thought this was an optimisation issue
<ijp>I don't see any runnable tests in that repo
<zv>ijp: it works fine when not loading
<zv> https://github.com/zv/SICP-guile/commit/35775307d0b737412e406d3104c2040d40a3090c
<zv>ah, i forgot to push tests
<zv>so, now when you run `guile --no-auto-compile sicp4.scm`, everything works fine
<zv>when you run `guile sicp4.scm`, things break
<ijp>what kind of errors are you getting
<zv>a little tough to drill down because of the nature of the evaluator
<zv>the point is that the code is exactly identical, but loading it causes an error
<ijp>and I said `load' is a problem
<zv>i see
<zv>modules of course do the same thing
<zv>depending on where I insert the `use-modules` in the file (of course always inserting it prior to any of it's exports being used)
<zv>i.e, I get different numbers of test failures
<ijp>your code is broken anyway
<ijp>no eval-arithmetic.scm
<zv>sorry, let me add that in, I just put that in a sec ago
<zv>added
<ijp>okay, and I'm getting no bugs with autocompilation
<zv>on master or external-evaluator-base?
<ijp>nothing in the log files
<ijp>master
<zv>external-evaluator-base is where I use `load`
<zv>`evaluator-base-as-module` is where I put it in a module
<zv>i gotta use my grave symbols more judiciously
<ijp>still nothing
<zv>in any case ijp, I appreciate you spending even 5 minutes on this, i'm sure this is painful to see for someone with experience with actually programming lisp
<zv>ijp: nothing failed?
<ijp>a lot of warnings, obviously, but no errors that I can see, and nothing in the .log files
<zv>as far as I can tell, the srfi-64 default test runner doesn't always output failures to a log file
<zv>you have to look in the stdout
<ijp>nothing
<zv>i've noticed that as well -- something will fail and the test files dont popular
<zv>i'm on 2.1.3-867316
<zv>could that be a problem?
<ijp>(except the warnings, and the obvious interpreter IO stuff)
<ijp>zv: possibly
<zv>what version are you on?
<ijp>stable before current
<zv>ok
<zv>im building stable 2.0 now
<zv>ijp: yep
<zv>everything works great now
<zv>sorry to kerfuffle your time
<ijp>yeah, be careful when running non-stable guiles
<ijp>maybe there is an issue with 2.1, maybe not, but we'll need to reduce the example much further to figure that out
<zv>so, in regards to modules
<zv>any way to redefine a module's internal functions later?
<zv>i.e if you have (module A (def fn1 (fn2)) (def (fn2) 2)) & you (use-module (A)) and later (def (fn2) 3) and then call fn1
<zv>is there any way to have fn2 override the definition inside of module A?
<ijp>you can change those bindings, yes
<zv>but it seems to me that fn1 will call the fn2 inside it's own module
<zv>(at least from my bugs)
<zv>even if I define fn2 later
<ijp>yes, you need to define it in the right place
<ijp>at the repl, I'd just switch to the original module with ",m" and redefine it the
<ijp>in actual modules, you generally shouldn't be doing this, but you can with module-set!
<zv>is there no way to manipulate the internals of a module?
<ijp>I just gave you one
<zv>i mean in code
<zv>without EXPLICITLY doing so
<zv>i.e, late binding of functions?
<ijp>if we don't count goops, and I wouldn't, then not really
<zv>i see
<zv>thanks anyway ijp
<ijp>ACTION tests something
<janneke>ACTION has given-up on syntax-case for now, and PEG, now trying to get records and lalr up
<adfeno>Hi everybody! :D
<adfeno>I have a noob question, how do I import a library? E.g.: Mailutils?
<adfeno>Oh got it :D
<paroneayea>hi!
<paroneayea>sorry I wasn't around to talk about guile-elisp
<paroneayea>I had a minor surgical procedure and was afk for a couple days
<wingo>o/
<shymega>paroneayea, hope it went well!
<shymega>speedy recovery