IRC channel logs

2016-07-22.log

back to list of logs

<amz3`>actually parsing a big than RAM xml file is possible in guile
<amz3`>without any addition :)
<amz3`>ssax parser can do it
<wingo>o/
<amz3`>the problem is that it's much slower than libxml
<amz3`>wow... this is very slow, I need to test against master to see what happens
<wingo>are you sure the input port is buffered?
<amz3>wingo: I don't know
<wingo>did you open the port from a file? in that case it is probably buffered appropriately and buffering isn't the problem
<wingo>if it's a socket the port is probably unbuffered by default and you need to `setvbuf' on it
<amz3>it's file port
<amz3>it's a file port
<civodul>also make sure to open it as utf-8
<wingo>or at least not ascii :P
<civodul>i'm saying that because utf-8 decoding has a fast path on 2.0
<wingo>yeah and ascii is oddly a slow path on 2.2
<janneke>woot, mes finally runs define-syntax and syntax-rules and based or & when macros
<janneke>ACTION is *happy*
<amz3`>:)
<galex-713>What is the most efficient way to store s-exps?
<galex-713>sql or mongodb?
<galex-713>Because just storing their raw text representation, especially with really repetitive symbols and fixed data type structure, would take probably too much room
<ijp>I don't really understand the question
<galex-713>like, if I want to make a voxel-sandbox game where every block is a sexp
<galex-713>If I just store an ascii sexp for each block it will take a looot of room
<galex-713>so I’d like a way to store sexp, but in binary and compressed form
<galex-713>Yet having good db perf
<ijp>neither of your options sound particularly good
<galex-713>?
<galex-713>what options?
<daviid>galex-713: not answering your quiz, but afaict we do not have mongodb bindings, and more importantly, it is not free s/w
<ijp>how is it not free software?
<daviid>i might be wrong, but i kind of remember someone wrote about mongodb not being free s/w, sorry if it is, i did not check and have confused with another db engine
<PuercoPop>galex-713: checkout conspack
<PuercoPop> https://github.com/conspack/cl-conspack
<galex-713>PuercoPop: is it of the same order of efficience of mariadb/mongodb dbs?
<ijp>measure first, no point committing to a complicated persistence solution otherwise
<amz3`>ijp: that's what I'm figuring out
<amz3`>galex-713: how do you want to reason about the stored sexp will also drive your choice
<amz3`>what do you plan to do with the sexp?
<amz3`>eval it?
<daviid>amz3`: did you not wrote here a little while ago that mongodb was not free?
<daviid>"MongoDB Download Center: Develop your next application with our enterprise products, free for evaluation and development." does not sound particulalr y GPL to me
<amz3`>mongodb is AGPLv3 https://github.com/mongodb/mongo
<amz3`>daviid: no
<daviid>ok tx
<PuercoPop>galex-713: sorry, wrong channel completly
<PuercoPop>it is similar to BSON but for sexps. You can use it as inspiration. MongoDB is neither efficient nor effective though
<daviid>hum. ".. most of the mongodb source files are ... AGPL. files in the client/, debian/, rpm/, utils/mongoutils, and all subdirectories thereof are made available under the terms of the Apache License, version 2.0", which is incompatible with both GPL2 and GPL3, afaict
<ijp> https://www.gnu.org/licenses/license-list.en.html#apache2
<daviid>ok
<amz3`>ah ok