IRC channel logs

2016-07-15.log

back to list of logs

<galex|713>Hi
<galex|713>How do I set the content bound to a quoted symbol?
<galex|713>because I can’t do (set! (string->symbol some-string) some-content)
<galex|713>So I’d like something like elisp’s “set” is to “setq”
<ijp>short answer, you can't
<ijp>longer answer, you can do it for top levels, but not other variables
<galex|713>how to do it for top level?
<ijp>module-set! I think
<galex|713>And why can’t you do that with scheme while you can with elisp?
<ijp>because the scheme designers decided it was a bad idea
<ijp>and they were and are right
<galex|713>oh wait there is symbol-set! (just found it)
<galex|713>Why?
<galex|713>What if you want to write some vars value in files whose name is the name of the var?
<ijp>this has never occurred to me ever
<galex|713>and you have enough variables so that you want to iterate through a list of them
<galex|713>ah ok…
<galex|713>Strangely I always encounter problems other don’t… maybe I use to do stuff wrong
<ijp>lexical scope means names don't matter
<ijp>a lesson lost on the designers of almost every language you can name
<galex|713>so what if you want to DRY and use the same word for naming variable and the associated file?
<galex|713>*variables
<galex|713>ijp: ^
<ijp>I macro it
<ijp>I'm not sure why you are associating variables and files in the first place
<galex|713>so that I can keep data among executions
<ijp>I have no idea what you mean, and I don't really care tbh
<galex|713>like I want a variable content to restore after the process stopped/restarted
<daviid>I can't make 2.0.12, from the source at least, I just pulled: http://paste.lisp.org/+6VAA
<cky>Congrats on the 2.0.12 release!!! :-D
<amz3`>o/
<amz3`>and my database tower crumble...
<amz3`>things seems to work when actually they only happen to work!
<amz3`>does anyone has a tutorial on how to make coverage work?
<amz3`>what can I do that is not bogged to fail? that is the question
<amz3`>looks like another bug in wiredtiger...
<profan> /win 16
<profan>eh
<profan>ACTION scurries away
<civodul>Hello Guilers!
<civodul>Thank You wingo!
<civodul>congrats on getting 2.0.12 out the door
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>Hmm. On https://www.gnu.org/software/guile/libraries/ The Snd link http://www-ccrma.stanford.edu/software/snd/ should probabably be https://ccrma.stanford.edu/software/snd/snd/snd.html
<amz3`>seems like my use of wiredtiger is orthogonal to the use of mongodb
<amz3`>at least they don't seem to use the indices provided by wiredtiger
<amz3`>yeah greping through their code there is no index table in mongodb
<amz3`>bah!
<amz3`>this is (was?) promising a promising project, but now with mongodb in the mix I'm not sure anymore
<amz3`>especially since I heard that they (mongodb) make dubuious choices
<amz3`>I recognize my inability to work with SQL, I am hopeless after 5 years in the industry I still can't write SQL without checking every single command
<amz3`>the worst in this wiredtiger bug story, is that my code is also buggy but I managed to find the bug through my faulty code :))
<ArneBab_>amz3`: is checking every single command a problem or rather a strength? ☺
<daviid>hello guilers! am i the only one who can't build 2.0.12? http://paste.lisp.org/+6VAA
<daviid>nonetheless, congrat for the release of course!
<daviid>i build from the source, i can try the tarball, though i shouldn't have to
<amz3`>ArneBab_: the problem is that I fear to write SQL because of the time it takes me to do so
<amz3`>but obviously I should do so, to improve my knowledge...
<daviid>wow! so that's it: 'make distclean' was not enough, you need 'git clean 'dxf', so now i can compile from the source as well
***frofroggy1 is now known as frofroggy