IRC channel logs

2016-06-28.log

back to list of logs

<amz3>héllo :)
<taylan>R7RS-large Red Edition ballot is up...
<mthl>hum?
<taylan>ACTION votes for SRFI 1, 14, 111, 126, 132, 133, 134, 135, and votes against a string library (since it's superfluous with SRFI 135). abstains on other questions.
<taylan>mthl: R7RS-large is being developed edition by edition, since it's supposed to cover a lot of ground. this is the first edition.
<taylan>these are unlike drafts because each edition covers different topics
<mthl>ha! thanks for teaching me something. ;)
<ArneBab>taylan: could you explain a bit why you chose that?
<ArneBab>I like it that they build on SRFIs
<ArneBab>ecraven: I just added the missing definition to make tail.scm run on Guile: https://github.com/ecraven/r7rs-benchmarks/pull/17
<ArneBab>^ this should fix the last real run failure in the benchmarks
<ArneBab>for guile
<ArneBab>(the only other failures are timeouts)
<ArneBab>ecraven: ctak completed for me in 225 seconds
<ArneBab>with guile-2.1.3
<ArneBab>ecraven: so if you change your CPU_Limit to 720, that would be one more completed benchmark
<ArneBab>ecraven: the ulimit might cut in a bit early for ctak, because guile is working multithreaded there.
<ArneBab>wingo: the equal-test in r7rs benchmarks looks like it’s something which could actually use benchmarking: https://github.com/ecraven/r7rs-benchmarks/blob/master/src/equal.scm
<ArneBab>wingo: you need to load the Guile-prelude before running that: https://github.com/ecraven/r7rs-benchmarks/blob/master/src/Guile-prelude.scm
<wingo>istr that test includes circular data structures
<wingo>that's why it times out on so many schemes
<wingo>ACTION shrug
<taylan>ArneBab: well, SRFI 1 (lists), 14 (charsets), and 111 (boxes) are pretty obvious choices for standardization. 126 is my preference for hash tables. 132 looks like an OK sorting library. 133 (vectors) is very slightly modified 43. 134 looks like an OK queue library. 135 (immutable texts) is a step towards making strings themselves immutable. on others, I'm simply indifferent; I neither desire
<taylan>them nor think they would be harmful.
<taylan>SRFI 69 (hash tables) is sadly out because exposing the eq and eqv hash functions is incompatible with a moving GC; this is why R6RS had a different hashtable library, and 126 builds backwards compatibly on that.
<civodul>wingo: do you want me to look at NEWS for 2.0.12?
<civodul>i can try and schedule some time for that tonight
<wingo>civodul: that would be grand!
<wingo>i didn't make it all the way through guile's bug list but i got close
<civodul>awesome
<wingo> http://debbugs.gnu.org/rrd/guile.html fwiw
<wingo>maybe we should do monthly 2.1.x releases until 2.2
<wingo>like, every 1st of the month, starting this friday perhaps
<nalaginrut>wingo: +1
<amz3>nalaginrut: o/
<ArneBab>wingo: so there’s no chance to make equal.scm work in Guile?
<ArneBab>taylan: having SRFI-1 by default sounds great, yes.
<ArneBab>wingo: monthly releases sounds great
<dsmith-work>{appropriate time} Greetings, Guilers
<wingo>people
<wingo>are thee no time nerds here
<wingo>surely there is a time aficionado
<wingo>that can review zefram's patches
<dsmith-work>I only know about TAI because of ieee-1588
<dsmith-work>None of that other stuff
<dsmith-work>Gregorian and Julian and whatnot
<amz31>héllo again
***amz31 is now known as amz3`
<amz3`>talking about streams: https://news.ycombinator.com/reply?id=11994485&goto=item%3Fid%3D11992684%2311994485
<amz3`>«I've noticed recently that especially in online discussions, the term "cognitive load" is used as a catch-all excuse to rag on code that someone doesn't like. It appears to be a thought-terminating cliché.»
<wleslie>"You have to be logged in to reply"
<amz3`> https://news.ycombinator.com/item?id=11994148
<ijp>"Don't make me think"
<amz3`> http://hyperdev.fr/notes/api-cognitive-load.html
<amz3`>ijp: I have that book, I did not read it yet, is it good?
<amz3`>it's about design right?
<ijp>it's fine, I guess.
<ijp>I haven't looked at in like 5 years, but the name sticks in my head at these times
<fudouri>hello
<fudouri>I'm getting kinda lost in the guile documentation; all I want to do is step through my code executing - but the documentation says I need to be in a recursive REPL to use debugging commands, but I can't find it anywhere how to enter one without producing another error first
<ijp>you'll get one at a breakpoint
<ijp>see ,break and ,break-at-source
<fudouri>... yeah, I just found out about add-trap-at-procedure-call!
<galex-713>ijp: ,break-at-source is broken
<galex-713>or anyway never found someone who knows how to use it
<ijp>not broken, subtle
<fudouri>now I just need to be able to print the current source location and I'm happy
<ijp>I did explain this to you before galex-713
<janneke>i think the debugger is broken in master...break-at-source could be friendlier
<amz3`>I only used ,bt once
<fudouri>now when I hit a breakpoint and step through, how can I see the current source location?
<amz3`>,bt
<fudouri>this is all somehow not what I imagined how stepping through scheme code woudl work
<ijp>there isn't really a repl command for it
<ijp>stepping through a lot of code is not really the intended use
<fudouri>then what can I use to do that?
<janneke>ACTION wrote an emacs GUD integration, but the guile-side of those patches did not land ing guile yet
<ijp>ACTION calls /me police
<ijp>janneke: what's needed on the guile end?
<janneke>ijp: something like this: http://lists.gnu.org/archive/html/guile-devel/2014-08/msg00005.html
<amz3`>wow
<fudouri>... there is no command to print the current source location, or is there?
<fudouri>(source location with source code)
<janneke>,frame ?
<fudouri>that just shows the function I'm in
<amz3`>with line no?
<amz3`>you want to print the actual procedure body code?
<civodul>mark_weaver: why was SRFI-25 reverted on stable-2.0?
<civodul>wingo: i've pushed NEWS; thanks to daviid for doing an initial pass!
<civodul>the only thing i didn't know what to say about is the GOOPS item at the beginning
<civodul>so i left that one to you
<amz3`>THE doc of my new graphdb https://git.framasoft.org/a-guile-mind/guile-wiredtiger/blob/master/graphitisay.md
<amz3`>the doc is missing (vertex-with-label context label) which retrieve vertices that have the given LABEL
<amz3`>and same with edge
<amz3`>uids actually
<amz3`>ACTION looking for a good example