IRC channel logs

2016-06-18.log

back to list of logs

<random-nick>how would I obtain a addrinfo for a tcp connection?
<dsmith>ijp, Yeah!
<dsmith>random-nick, is getsockname or getpeername what you are looking for? https://www.gnu.org/software/guile/docs/docs-2.0/guile-ref/Network-Sockets-and-Communication.html
<random-nick>dsmith: no, I want to connect the socket to a address
<random-nick>dsmith: the manual says the addrinfo way is encouraged
<dsmith>sneek, later tell random-nick https://www.gnu.org/software/guile/docs/docs-2.0/guile-ref/Network-Databases.html
<sneek>Will do.
<dsmith>sneek, later tell random-nick Check out the various index pages, like https://www.gnu.org/software/guile/docs/docs-2.0/guile-ref/Concept-Index.html See the addrinfo entry. Follow the link
<sneek>Got it.
<daviid>boring naming things quizz time: suppose you have the GI bindings and scheme slightly higher level API to read a enumeration description form a gir, which is where I am now
<daviid>then a higher level procedure uses that 'machinery' to read the gir content and import/build the language version of the data... would yu call such procedure gbank-enum-import or gbank-enum-build-interface ? I've seen both naming conventions
<daviid>for now I made my choice to *-import, which is ok I guess
<Bobbejaantje>Leeeeeeenaaaart in C minor
<Bobbejaantje>Lennart lennart lennaaaaart
<Bobbejaantje>LENNAAAAAART
<Bobbejaantje>Thank you, thank you.
<ijp>finished?
<Bobbejaantje>Wrong channel, sorry, tha was meant for #gentoo-chat-exile.
<madsy_>Automated guile builds for Windows coming soon (tags and HEAD from master). Also runs the unittests on 64-bit Windows via QEmu/KVM :) https://i.imgur.com/vLTSsHe.png
<amz3`>paroneay`: my project does crawl html pages over https using gnutls and htmlprag
<amz3`>it extract href with sxpath
<amz3`>paroneay`: https://framagit.org/a-guile-mind/hyper
<amz3`>not sure what you need, HTH
<wingo>dsmith: i can reproduce those port-related errors on 32-bit
<sneek>Welcome back wingo, you have 1 message.
<sneek>wingo, dsmith says: 32bit make check EOF errors: http://article.gmane.org/gmane.lisp.guile.devel/18344
<wingo>both cross-compiled and natively bootstrapped
<wingo>interesting stuff :)
<wingo>ACTION happy for hydra
<wingo>ah, it seems the difference is down to the locale :/
<wingo>or no? i dunno
<wingo>wow that one was exciting too
<wingo>apparently if you have a size_t x
<wingo>and an int64_t y
<wingo>and you say y = -x, then y is always positive; i think.
<wingo>embarrassing that i am still ignorant here
<amz3`>wingo: My search engine works correctly actually, there is no problem with hanging downloads provided my internet connection is good enough;
<alchemizt>any plan for when 2.2 will be released? i'm enjoying the speed improvements in the snapshots
<amz3`>alchemizt: what do you do with speed?
<amz3`>IIUC you are not the only one expecting 2.2 release :D
<amz3`>it will be grand!
<alchemizt>amz3`, nothing that flashy, it's just nice to have a speedy scriptable scheme
<amz3`>I'm curious that is all
<alchemizt>a friend told me to try out racket, but it felt slow in comparison to guile 2.1.2
<amz3`>to know what people do with guile
<alchemizt>networking/web stuff
<amz3`>drracket is slow, I don't know about racket itself
<alchemizt>i'm looking for a scriptable lisp to use when i'm not writing golang or clojure
<amz3`>ah ok
<alchemizt>i took a second look at guile after i noticed the web revamp
<alchemizt>and i like the massive documentation
<alchemizt>a better story for guile packages and third-party libs would be nice though
<amz3`>they are scheme benchmarks around, I can't recall who did them but probably a search engine can help
<amz3`>alchemizt: in practice I don't find it's problem
<amz3`>a lot of people complain about it tho
<alchemizt>this site was the best i could find, and it's nice, but could be much better: http://sph.mn/content/3e73
<amz3`>but maybe it's only because other language "have it"
<alchemizt>you come to appreciate the convenience
<amz3`>amz3:
<amz3`>oops
<amz3`>alchemizt: http://ecraven.github.io/r7rs-benchmarks/benchmark.html
<alchemizt>in clojure it's clojars, clojure-toolbox, and lein deps - in golang it's go get, godocs.org, golanglibs
<amz3`>yeah, but in my practice guile projects are not big enough to require packaging
<amz3`>I just copy/paste dependencies in my project directory and I'm good to go
<alchemizt>that feels messy to me
<amz3`>and when I patch something, I copy/paste it back to the main repo
<alchemizt>i like writing my own libs and using the language's own infrastructure in my projects
<alchemizt>ie, go libs on githuub, clojure libs on clojars
<amz3`>the problem with packaging, is that it's lot of trouble when you have to commit in several projects to get a feature working
<alchemizt>i know
<alchemizt>go had that problem for a while, because "go get" didn't include versioning by default
<wingo>yeah we don't really know what to do :) we had a plan to make a collection of guile libs called 'guildhall' but it didn't take off enormously
<alchemizt>i saw the threads on guile-users
<wingo>on the other hand guix is packaging many modules, which works really really well
<amz3`>I had this issue with django projects, splitting is nice habit but not a road without troubles
<wingo>only that it's quite centralized and doesn't facilitate random package addition
<alchemizt>if the library/package distribution framework is there, it starts to become self-sustaining
<wingo>though guix is quite accepting of new modules, so maybe that's the thing. dunno.
<alchemizt>despite it's warts, the chicken guys have a nice system
<alchemizt>i'm not sure if i entirely trust a package repo on some random kitten-tech.co.uk website, but hey, it works
<amz3`>I don't think so. It's the same with any pypi, cpan-like repository. There's not review of the code
<amz3`>at least with guix there is somekind of review
<alchemizt>i'd just like to be able to search a central index to find available libraries
<amz3`>what about a search engine?
<amz3`>that is cosmectic... IMO
<amz3`>also you can come here and ask for help
<alchemizt>being in one place helps ppl find existing code
<alchemizt>encourages reuse
<amz3`>reuse happens nonetheless
<alchemizt>and for newcomers to guile, it gives them confidence that there's more than just an interpreter
<amz3`>sure, shiny things helps but it's not a strong argument since it's only cosmetic
<wingo>the nice thing about guix is that it includes guile as well. so you have have some confidence that no matter what distro the user is running, they will be able to use a guile that is known to work well
<alchemizt>cosmetic implies it's not useful
<alchemizt>if it was shiny but unhelpful, i'd agree about being cosmetic
<wingo>alchemizt: to answer your 2.2 question... i will release 2.1.3 this w/e hopefully, provided the build servers go green
<alchemizt>wingo, awesome
<wingo>and from there i don't think there are major additional things to do before 2.2
<alchemizt>is there a ubuntu ppa maintainer?
<amz3`>cosmectic is visual stuff, it's not useless just less significant that other aspects (speed, ease of use, free software, community...)
<wingo>maybe just one or two more maintenance releases
<wingo>or maybe nothing, maybe 2.2 can go out as-is
<wingo>we'll see
<amz3`>alchemizt: I use to do Python for all my projects, but Guile is much more powerful I think that Python even if there is less community and cosmetic stuff like a central repo
<amz3`>alchemizt: that said I don't use guix
<amz3`>I'm wondering whether guix made some progress regarding dual boot
<alchemizt>amz3`, i'm not expecting a shiny web index, i'd be happy to run something like apt-cache search blah apt-get install blah equivalent for guile libs
<alchemizt>command line
<amz3`>guix does that, but there is not everything
<amz3`>everything -> every guile libs
<amz3`>alchemizt: maybe the good question is: what do you want to do? then one can help you figure how to do it
<alchemizt>nothing right now, just chatting
<alchemizt>lurking otherwise
<amz3`>for instance, I would love to use guile in the browser to create a web based mail reader
<amz3`>\\cc ijp
<alchemizt>i wouldnt mind being able to use guile from golang
<amz3`>but I know that to do that, I will need an IMAP and SMTP library nonetheless for which there is no solution right now I think
<amz3`>alchemizt: AFAIK, golang is difficult, maybe very difficult to package for guix so there is no much use of it in the community
<alchemizt>that's surprising
<alchemizt>the base language itself or third-party stuff?
<amz3`>again AFAIK, it's because guix aim for reproducible builds and go relies on binaries to bootstrap itself
<alchemizt>ahh
<alchemizt>i'm all in favor of reproducible builds
<alchemizt>now if only embedded linux devs and android custom rom devs would get on that bandwagon
<amz3`>guix simplify a lot of things regarding reproducibility. I hope we could use it at work someday
<amz3`>tho the problem we have has more to do with a broken build system
<amz3`>the project is not correctly split into libraries basically there is a single binary for processus something like busybox
<amz3`>yes the problem has more to do with the program itself that the build system, but it has impact on the build system which is made very much complex because of the way the programs are built
<amz3`>and of course, we have single repository for everything :p
<amz3`>maybe that's where i took inspiration for my own projects :D
<amz3`> /join #guix
<alchemizt>i watched some of the fosdem presentations on it
<amz3`>I think is a revolution
<amz3`>I think it is a revolution
<amz3`>alchemizt: what I like about guile is that touch of exploration guilers do, I think it's very important compared to languages like Python where only common-sens rules
<amz3`>of course clojure is kind of also a similar beast
<alchemizt>i love clojure, but not its startup time
<alchemizt>and i'm not one of those live in the repl people
<amz3`>I think for instance of minikanren there is no such thing in other languages except clojure
<amz3`>I think things like minikanren, guix and parser combinators clues that makes guile a really good platform
<amz3`>and all in all, let's be honest, outside of PHP and somewhat Javascript, there is not much free software project built upon most languages
<amz3`>I think about end user projects like webmail, bugtrackers, forums and stuff...
<alchemizt>that kind of stuff isn't as sexy as it used to be
<amz3`>of course there is a lot of projects using Python, but at the end of the day there is no fully featured project in Python. It's only libs
<amz3`>alchemizt: which kind of things?
<alchemizt>you can get a lot of that for free via basic SAAS offerings
<alchemizt>webmail/bugtrackers/forums
<alchemizt>ie, squirrel, trac, phpbb
<alchemizt>i doubt many want to build new versions of those
<alchemizt>discourse is one example
<alchemizt>mattermost (open source slack alternative) is another
<amz3`>honestly I'm not motivated to build anything using javascript or Python.
<amz3`>I think that from a language engineering point of view, those languages are lacking behind or on hold
<amz3`>even if there is new version of javascript every year, it's backward compatible with broken stuff
<amz3`>I don't want to teach my friend those languages
<amz3`>but at the same time, learning Guile is a strong take as you can't for instance develop everything in Guile as you could do with javascript
<amz3`>I think full stack guile has a long story to come
<amz3`>as soon as ijp restart its work ;)
<dsmith>wingo, Wow. Yeah, I wouldn't have expected that. But I don't work with *64_t's much.
<dsmith>wingo, Yey! make check all is happy!
<civodul>hello!
<civodul>wingo: do you have a copy of https://www.gitorious.org/guile-sqlite3/guile-sqlite3.git/ elsewhere?
***Guest28872 is now known as micro`
<janneke>amz3`: browser support for guile is still somewhat weak
<amz3`>somewhat?
<amz3`>civodul: did you try guile-wiredtiger ? :-)
<civodul>no, how does it relate?
<amz3`>it's a database library like sqlite
<amz3`>except there is no SQL, you query the database using scheme
<amz3`>you have a similar concept to tables and indices
<amz3`>it's also GPLv2 or GPLv3 ;)
<civodul>oh, ok
<civodul>in this case i really need sqlite3 though :-)
<amz3`> https://framagit.org/a-guile-mind/guile-wiredtiger
<amz3`>ah ok
<civodul>it does sound interesting, though!
<amz3`>thanks
<janneke>amz3` i remember seeing something about w3c and lisp, cannot seem to find it though
<amz3`>I completed my tutorial about guile parser combinator with a csv parser example
<amz3`> http://hyperdev.fr/notes/getting-started-with-guile-parser-combinators.html
<civodul>nice tutorial
<amz3`>janneke: there is saying that boils down to the fact that javascript should have been a lisp or more precisly a scheme
<amz3`>civodul: thanks :)
<amz3`>janneke: also, there is some discussion on javascript commitee to include tail call optimization
<amz3`>outside of that I'm not aware
<amz3`>ACTION wonders how to push forward my search engine...
<amz3`>ACTION wonders how to push forward his search engine...
<amz3`>or i could rewrite guile-parser-combinator to use exceptions
<amz3`>janneke: it is said that javascript is (somehow) inspired from scheme
<amz3`>fun fact i've been working on this hyper search engine for almost 2 years
<paroneayea>amz3`: oh thanks :)
<amz3`>it has been more difficult to do than with pgsql, tho
<amz3`>paroneayea: yw
<amz3`>pgsql already provide tables, and tsearch2 extension to do full text search
<janneke>amz3`: yes, apart from its annoyances (map with extra arguments, eg) and closing stanzas like )};))])}, javascript isn't too bad
<amz3`>hyper doesn't do full text search
<amz3`>anyway, the way FTS is implemented is pgsql is that if you want to i18n the stemming/rooting of words into keywords you would have to implement it in C
<amz3`>here it's done in scheme
<amz3`>though there current keywording algorithm is a simple split over the text
<amz3`>you could imagine to build more keywords (with different weight) and compute the rank of the query against the database
<amz3`>wait, I never finished that part in guile
<amz3`>right now, in hyper the ranking is the most simple or almost simple you can do
<amz3`>everytime a keyword appears it counts as 1
<amz3`>appears in the page
<amz3`>and them you sum each keyword score to obtain the score of the page
<amz3`>page are sorted according to this score
<amz3`>wait I don't do page rank either
<amz3`>so much do be done
<jlicht>amz3`: hyper looks like a very fun project. Did you already think about extending it with some boolean queries? (and, or, xor, not etc)
<amz3`>jlicht: that's the funny thing!! I think I let that do be done in scheme, that the all point of a personal search engine
<amz3`>you can create queries in scheme
<amz3`>yeah I am thinking about and or and xor... hmm... let me think...
<amz3`>because I was thinking about using gremlin graph traversal over srfi-41 steams
<wingo>sneek: later tell civodul yes i do
<sneek>Got it.
<amz3`>but one could also implement a text DSL like search engines do... but it's less funny I think
<amz3`>something like (AND "hyper" "search" "engine")
<amz3`>in hyper, `and' procedure from above is actually named `search*` this is the way to AND two keywords
<amz3`>two or more keywords
<amz3`>that's when two results are "merged" based on keywords
<amz3`>merge is a vague term
<amz3`>`or' procedure is two calls to `search*`
<amz3`>the problem you have once you introduce `or' is that those set operations are done fully in memory
<amz3`>actually it's also the case of `and'
<jlicht>amz3`: you could implement it like this, sure, but if you later have ranking + fuzzy matches, it probably is not that straight forward anymore
<amz3`>right now `and' assumes you can feet all operands results into memory and does the intersection online
<jlicht>so some kind of implementation that is not 'just' a set operation on several search results might be needed
<amz3`>another algorithm could rank each first and only keep all the top 10 or 100 do provide results to the user
<amz3`>the definition of fuzzy match is abstract to me
<amz3`>gremlin comes in when you can express the "fuzzy" match to build 'and', 'or', 'xor' expressions as a walk on the knowledge graph
<amz3`>this is a group of keyword querying
<amz3`>but you also need to query sub-keyword informations
<amz3`>knowing when to pre-compute the sub-keyword informations is intersting
<amz3`>like for instance, levenstein distance do you pre-compute levenstein distance between all the keywords on the fly when needed or at parsing time?
<amz3`>levenstein distance allows to know the distance between two words char by char, and allows for instance to implement "spell checking"
<amz3`>(spell checking is not concept similarity, but orthograph similarity)
<amz3`>jlicht: in gremlin you chain for the following operators (compose (stream-filter (lambda (x) xxx) gremlin-back gremlin-out) to create the and/xor/or/not query
<amz3`>but right now that think about it again, it seems like the previous implementation i've done of gremlin querying doesn't allow me to use it right away
<amz3`>because the data is not really a graph, it's a bit different
<amz3`>hmm..
<amz3`>yes, that's it, the sugar language to query the database there's is two primitives over a tuple space
<amz3`>I have still the same problem as in the beginning I've started to think about this issue
<amz3`>it's that the uav database doesn't output streams of results
<amz3`>instead it returns a list of results
<amz3`>as soon as the uav database output streams of result you can compose stream-map procedure that implement graph querying over a possibility infinit set (!) of data
<amz3`>I'm kiding about the fact it can be infinite
<amz3`>to do that you need to be able to implement resumable computation using some async stuff over the network but it's possible
<amz3`>wait... but this is a big issue
<jlicht>glhf with the async stuff, amz3`. It seems you have some big plans for hyper :)
<amz3`>because the fact is that in gremlin, composition of stream-map procedures sometime you need to fully consume the stream...
<amz3`>yes! the stream is not infinite because the database is not infinite
<amz3`>so no problemo :p
<amz3`>but if you always add stuff to the database, it could be a long running process
<amz3`>but right now with hyper, you fetch all the pages to parse, once at the beginning of the work of the worker process, instead of generating a stream of resulting recomputing the pages to crawl next at each iteration of the worker
<amz3`>is only visible to hyper-worker.scm what was in the database when it started, so it always finish
<amz3`>there is another thing though, it doesn't re-add a url when it was already scored against the crawler
<amz3`>crawler score pages based on when during the parse it found the page
<amz3`>say it starts at hyperdev.fr at score 10, and find gnu.org at score 9
<amz3`>10 - 1 = 9
<amz3`>every new like gets the score it's page in minus 1 until a link is scored 0
<amz3`>at that point the url is not crawled
<amz3`>that another reason the crawler stops
<amz3`>figuring the score of each page, allows to know how deeps it will crawl it's links by default it's 10
<amz3`>that has nothing todo with scoring keywords in pages
<amz3`>but I guess google does that
<amz3`>there is always a score propagation algorithm in searching even and/or/not/xor is a score propagation it's just happens to be binary
<amz3`>tho, the score might be multidimensionnal to simplify
<amz3`>simple text search is binary
<amz3`>the point of commercial search engine is to turn the multidimensional score into a 1 dimensionnal space
<amz3`>as if we couldn't figure out multiple paradigms
<amz3`>input = search, results = html picture of results
<amz3`>some search engines convert natural language sentences into database queries
<amz3`>it seems like so
<amz3`>but when you look at it, you have to implement every single kind of sentence coordination word even sometimes formulae
<amz3`>but most of the time it's simplified to this kind of sentence:
<amz3`>what is A and B and C?
<amz3`>but in reality nobody does that!
<amz3`>nobody ask such question
<amz3`>or atl east it's one of the kind of question we ask
<amz3`>or at least it's only one of the kind of question we ask
<amz3`>+only
<amz3`>and asking more complicated question doesn't work either as the natural language is too weak to expresse that
<amz3`>maybe we could write it in natural language something like: what is hyper or move?
<amz3`>(or "hyper" (and "move" "gnu"))
<amz3`>hmm... actually it should be written: (stream-append (stream-search* "hyper") (stream-search* "move" "gnu"))
<amz3`>stream-xor is more complicated
<amz3`>in theory you should consume the whole stream to know whether is not already present in another stream
<amz3`>to compute the presence of a object using lists you need to sort both lists
<amz3`>otherwise you can implement a partial order or something like that
<amz3`>I don't know how this works!
<amz3`>that's the first answer the creator answered me when I started getting interested in gremlin to use to do web developpement
<amz3`>«how to sort a stream?»
<amz3`>In my implementation in Python of gremlin I consume all the stream to sort it
<amz3`>wait, but... and/or/not/xor can apply to each page
<amz3`>(and (xor "hyper" "combinator") (or "move" "gnu"))
<amz3`>(and (xor "hyper" "combinator") (or "move" "gnu") (not "commercial))
<amz3`>this is funny
<amz3`>this. is. funny.
<amz3`>I never though of that, that way.
<amz3`>!
<amz3`>actually search* is busted!
<amz3`>(stream-filter (lambda (keyword) ((and (xor "hyper" "combinator") (or "move" "gnu") (not "commercial))) keyword)) (uid-by-attribute-stream 'keyword))
<amz3`>I'd like to move and outside of the lambda at the same the stream-filter
<amz3`>I'd like to move `and' outside of the lambda at the same +level as the stream-filter
<holomorph>o.o
<amz3`>I've been dreaming a long time about how to implement a vm there
<amz3`>well strange
<amz3`>feeling
<amz3`>(xor "hyper" "combinator") in terms of hyper means, does this document contain the keyword "hyper" excusive or "combinator"
<amz3`>and I have uid as input
<amz3`>Ah need a procedure that retrieve the keyword list associated with a document
<amz3`>this time we are sure the keyword list associated with a document is finite, bear with me
<amz3`>((xor "hyper" "combinator") (uid->keywords uid))
<amz3`>(xor (list-ref (uid->keywords uid) "hyper") (list-ref (uid->keywords uid) "combinator"))
<amz3`>there is xor in Guile?
<amz3`>fx!
<amz3`>so it's actually
<amz3`>(logxor (list-ref (uid->keywords uid) "hyper") (list-ref (uid->keywords uid) "combinator"))
<amz3`>let's define (uid->keyword uid) now
<amz3`>(map car (query* (name?) ((uid? 'keyword keyword??) (keyword?? 'name name?))))
<amz3`>which returns every keyword in a document given the uid of the document
<amz3`>now that xor is implemented one can implement and/or/not too!
<amz3`>but I wanted to let the xor outside of the stream-filter not sure why
<amz3`>that's probably when parser-combinator comes in...
<amz3`>that's probably when combinators* comes in...
<amz3`>I can't actually xor/not/or/and documents that way
<amz3`>the return type of xor is the its input type
<amz3`>jlicht: thanks!
<rekado_>efraim: thanks for your efforts in switching to qt-modular!
<rekado_>is core-updates open for commits again?
<rekado_>I have the pulseaudio bluetooth commit here that I forgot to push for too long.
<lfam>rekado_: Wrong channel?
<cbaines>Hey, quick question, is there a way in a function to get a reference to that function, or do you have to bind it to a symbol?
<kwrooijen>Hey guys, I was wondering: When I need to do some sort of recursion I can use letrec. But I could also define a new procedure within the current procedure. Is there any preferred to do it?
<kwrooijen>To put it in another way: Are there any downsides to defining a procedure instead of using letrec?
<dsmith>kwrooijen, Nope. Also, you can use named-let
<dsmith>kwrooijen, As in (let NAME (....) .... (NAME args)) The typical name for NAME is "loop".
<kwrooijen>oh interesting
<kwrooijen>Didn't know that
<dsmith>kwrooijen, Bottom of https://www.gnu.org/software/guile/manual/html_node/while-do.html
<dsmith>kwrooijen, letrec is prob best for mutually recursive things
<kwrooijen>dsmith: As in two functions calling each other?
<dsmith>kwrooijen, Exactly
<kwrooijen>Yeah that does make sense
<kwrooijen>Thanks for the info :)
<dsmith>kwrooijen, Hmm. That's probably the whole point of letrec, actually
<daviid>amz3: https://github.com/NalaGinrut/guile-csv [by wingo and nalaginrut], just found by chance, was looking for something else
<mark_weaver_alt>amz3`: a few comments on http://hyperdev.fr/notes/getting-started-with-guile-parser-combinators.html
<mark_weaver_alt>amz3`: in one place, you use 'eq?' you compare characters, but 'eq?' is not guaranteed to work sensibly on characters
<mark_weaver_alt>please use 'eqv?' instead
<amz3`>ok
<mark_weaver_alt>amz3`: also, you mispelled 'parse-success' as 'parse-sucess' in a few places
<madsy_>hey mark_weaver_alt
<mark_weaver_alt>hi madsy_! I saw that you're making some progress with Guile on 64-bit Windows
<madsy_>Well, not much on 64-bit yet I'm afraid. But I try to help out where I can (and have time)
<madsy_>I'm just finishing up an automated jenkins build server for Windows builds. Maybe you people could use it too?
<amz3`>mark_weaver_alt: thx
<madsy_>It cross-compiles from origin/master and runs the guile unit tests on Windows XP 64-bit in Qemu
<madsy_>All you need is to press a button after pushing and wait a while :)
<wingo>neat!
<madsy_>Hopefully it won't be dog slow on my linode instance..
<wingo>ok let's release a 2.1.3, hydra seems to be stuck in a death loop of no disk space
<wingo>ain't even going to try to update gnulib now tho :P
<mark_weaver_alt>wingo: sounds good!
<janneke>wingo: would you be willing to help me pick-up Emacs GUD integration after the release? the main bit should be an old that has guile use gnu style error messages in backtraces and frame commands
<wingo>janneke: happy to review patches :)
<wingo>and in general i'm happy to use gnu style in general
<janneke>wingo: thanks. i'll dust them off rsn
<wingo>ACTION doing a distcheck
<madsy_>Just finished my first v2.0.11 build from jenkins with automated unittests. Here's how the log looks like http://www.mechcore.net/files/guile/win32/consoleText.txt (~10 MiB)
<mark_weaver_alt> madsy_: thank you for that. I'll look at it later
<madsy_>mark_weaver_alt: 2.0.11 is pretty old. I'll set up periodic builds of master/HEAD tomorrow.
<madsy_>I just tested 2.0.11 because I know it builds
<mark_weaver_alt>madsy_: the stable-2.0 branch might also be useful to test
<madsy_>Noted
<mark_weaver_alt>since that will become 2.0.12 before too long
<wingo>garrrrr, distcheck failure because guix's ld-wrapper is very silly
<wingo>that i have to set some environment variable to allow "make install" to a non-guix location to work... silly
<wingo>release tomorrow then
<wingo>night