IRC channel logs

2016-06-05.log

back to list of logs

<civodul>fitzgen: the INSTALL file exists in the release tarball; maybe you're building from a Git checkout?
<fitzgen>civodul: I am indeed working with a git checkout
<fitzgen> https://www.irccloud.com/pastebin/xZbCWcC0/
<civodul>i can't access that over Tor
<fitzgen>it is the commit I have checked out
<civodul>the instructions to install a release are https://www.gnu.org/software/guile/manual/html_node/Obtaining-and-Installing-Guile.html#Obtaining-and-Installing-Guile
<fitzgen>9454068a54a4e9e84db61dc42d9a5d7a544a7ece
<fitzgen>I don't want to install a release, I would like to build from source and then hack on Guile
<civodul>when building from Git, you need to run "autoreconf -if" first
<fitzgen>ACTION tries
<fitzgen>hmm looks like I need to help it find gettext? https://pastebin.mozilla.org/8875008
<civodul>yeah, gettext and pkg-config
<fitzgen>civodul: how would I specify to autoreconf where gettext and pkg-config are located?
<civodul>fitzgen: their m4 files need to be in the ACLOCAL_PATH so they can be found
<fitzgen>civodul: like this?
<fitzgen>./autogen.sh ACLOCAL_PATH=/usr/local/Cellar/gettext/share/aclocal
<fitzgen>Still getting errors about gettext macros
<fitzgen> https://pastebin.mozilla.org/8875013
<civodul>what does "aclocal --version" say?
<fitzgen>aclocal (GNU automake) 1.15
<civodul>hmm, should be fine
<fitzgen>civodul: ahhhhh ok
<fitzgen>civodul: so I temporarily put all my home brew binaries ahead of my system ones in my PATH
<fitzgen>and things seem to be going further now
<fitzgen>\\o/ autogen.sh completed successfully
<fitzgen>civodul: thanks a ton for your help
<fitzgen>very appreciated
<civodul>fitzgen: glad you succeeded!
<fitzgen>well, configure is still giving me a hard time :)
<fitzgen>but much closer
<fitzgen>isn't finding my libffi now
<galex-713>What’s FFI?
<galex-713>oh, speaking of INSTALL/HACKING/etc., I can’t find a TODO file
<fitzgen>\\o/ ok configure completed
<fitzgen>civodul: do you happen to know anything about Guile's GC?
<fitzgen>ah I see it is Boehm
<galex-713>davexunit: you learnt opengl with C I suppose right?
<daviid>mark_weaver: I further read your comments, the ice-9/boot, r4rs source code and came to the conclusion I should only provide a procedure [not a syntax] call-with-input-typelib [no more with-input-from-typelib], and that should not call dynamic-wind. Thanks for your input. Here is the new code extract and manual entry: http://paste.lisp.org/+6SVM/1 review welcome
<fantazo>how do you add a time value of 'a month' to a time object in guile? I suppose hacking something together with the posix tm:* helpers will do the trick, but I'm asking out of my sheer comfort zone of coming from some oop languages which have: now + 1.month
<fantazo>or: now.beginning_of_day
<fantazo>means writting (beginning_of_day (current-time)) as a way to do that in guile.
<galex-713>Hi
<galex-713>davexunit: the opengl problem of sly wasn’t because of opengl, I recompiled and for some strange reason it works (or did you fixed something to the git repo?) and now the error is “sly/game.scm:176:20: Uniform not found: "model"”
<galex-713>oh this also “Failed to compile shader: 0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES”
<galex-713>
<galex-713>seems to be related to shaders
<Lennart_cucks>So '(open-pipe* OPEN_WRITE "nonexistent-executable")' does not raise an exception but just prints 'no such file or directory' to the stderr. Any way to make it raise some kind of exception?
<amz3>héllllllllllllllo #guile!
<amz3>nalaginrut: o/
<amz3>I know what I gonna do today!
<amz3>a tutorial about guile combinators \\cc davexunit
<amz3>davexunit: I can't git clone https://git.dthompson.us/guile-parser-combinators.git because the certifcate is not valid
<efraim_>there's a flag you can pass it to ignore invalid ssl certificates
<amz3>yeah, I know, just notifying davexunit because I think he meant to use valid certificates
<guile-guest9>so, just passing by to ask status of the guileemacs project
<guile-guest9>has anybody heard anything?
***Lennart_cucks is now known as mladic
<guile-guest9>I find nothing on the mailing lists archives for this year, but guileemacs branches seem to be active
<guile-guest9>I wonder if we'll have guile-powered emacs by emacs 30 =)
<amz3>here is the draft of guile-parser-combinators intro http://hyperdev.fr/notes/getting-started-with-guile-parser-combinators.html
<amz3>wdyt?
<paroneayea>wingo: ooh cool, I look forward to looking at it
<paroneayea>wingo: busy days the next few days but I hope to get to it in the next week.... maybe from the airport today? :)
<amz3>paroneayea: what are you talking about?
<amz3>wingo: ^
<amz3>I have a strange bug in my search engine, where the download of an url hangs forever
<amz3>I'm wondering how I can debug this
<amz3>yeah, there is no timeout on http-get stuff
<amz3>so I'm stuck
<amz3>maybe I should use select somewhere
<amz3>is it a poxis behavior that I don't know about?
<amz3>I don't know a lot about posix
<amz3>everything I know about posix (one or two things) I learned here!
<wingo>amz3: you on 2.0 or master?
<wingo>and is it http or https?
<amz3>I'll check
<amz3>2.0
<amz3>everything is broken now need to debug
<amz3>I'm too lazy to debug it knwo
<amz3>sorry
<wingo>lol :)
<amz3>:)
<wingo>:)
***mladic is now known as Heinrich-Lo`Toya
<marusich>Can anyone recommend a good introduction to macros? I'm learning lisp for the first time, and I have not learned about macros in lisp before, and I have read the Guile manual's chapters regarding macros, but it's still unclear to me.
<marusich>The Guile manual's chapters on macros/syntax seems to assume the reader is familiar with macros in lisp, and describes how Guile provides both "hygienic" macro features and traditional macro features. None of which is very useful for a beginner.
<marusich>If anyone knows of a good explanation / illustration of macros in Guile or Scheme in general, I would really appreciate the info.
<marusich>I am reading SICP also, but they don't seem to discuss Macros, at least not so far in first few chapters...
<marusich>I wish I could understand the Guile manual's explanations, but when I read those sections I feel like I'm just missing some context or basic knowledge that the manual assumes :/