IRC channel logs

2016-05-31.log

back to list of logs

<civodul>wingo: could you "git clone https://gitorious.org/guile-zmq/guile-zmq.git" and move it elsewhere sometime? :-)
<guile-guest9>Hi. When compiling libguile/fports.c from Guile 2.0.11, I get the following error: "fports.c:612: error: 'POLLIN' undeclared (first use in this function)"
<guile-guest9>I tried to enable all POLL* constants in lib/poll.in.h, plus a reconfigure, but that did not work: "sed -i 's/# define POLL/define POLL/g' lib/poll.in.h"
<guile-guest9>I meant: sed -i 's/# define POLL/#define POLL/g' lib/poll.in.h
<ozzloy>i just included an svg into a skribilo doc and it got converted to a png in the html output. how do i leave it as a svg
<ozzloy>?
<lloda>wingo: wdyt of this EERRORRR: OR: invaliidn vpoalrtid buf peroort bu#(#vu8(117) 0 2 #f (22 . 0))ffe
<lloda>r #(#vu8(117) 0 2 #f (22 . 0))
<lloda>I'm getting those since the ports work was merged
<dsmith-work>Morning Greetings, Guilers
***dsmith is now known as dsmith-wor
***dsmith-wor is now known as dsmith-work
***chaos_ is now known as Chaos`Eternal
<Walakea>why does pdfmod depend on mono libraries?
<mark_weaver>Walakea: what is pdfmod, and how does this relate to GNU Guile?
<Walakea>sorry, wrong room
<mark_weaver>np :)
<amz31>I'm rewriting my blog engine in GNU Guile
<amz31>actually the markdown parser works pretty well
<amz31>I have only one bug, I can't type for instance ftw*
<amz31>any star inside a text is interpreted as a command char for emphase
<amz31>I guess we should live dangerously
<amz31> http://hyperdev.fr/
<amz31>also code is not highlighted yet...
<galex-713>amz31: I wrote a blog engine with GNU Bash once, then abandonned before making internationalization work because I decided to make it in elisp, then decided elisp wasn’t good enough and I would wait for guile-emacs in order to do it with guile, is the core code difficult or not?
<galex-713>s/difficult/complex/
<paroneayea>hello, *
<davexunit>hey paroneayea
<davexunit>how goes the move?
<paroneayea>davexunit: just turned in our keys to the old place
<paroneayea>spent all of yesterday cleaning out the old place
<paroneayea>on our 7th anniversary!
<paroneayea>so spending today as a bit more of a relaxing day
<davexunit>no better way to spend it!
<davexunit>great
<paroneayea>anyway, that was prety much the craziest move I've had
<paroneayea>glad it's over
<paroneayea>well, excepting some unpacking :)
<davexunit>at the end of the month it will be my turn. need to wrangle a whole bunch of contractors, too.
<davexunit>paroneayea: on a guile related note, Sly now has some basic support for particle effects
<davexunit> https://media.dthompson.us/mgoblin_media/media_entries/72/sly-particles-optimized.gif
<paroneayea>davexunit: yay re: particle effects!
<paroneayea>good luck re: move / contractors
<davexunit>thanks!
<paroneayea>particle gif is fun
<davexunit>yeah! and the implementation was rather short!
<davexunit>and the high-level interface is functional
<davexunit>the particle positions are a function of time, basically.
<paroneayea>:)
<galex-713>Hi, what’s the quickest way to know where do come a macro/function: guile core specific, some guile module, r5rs, r6rs, r7rs, srfi-n, etc.?
<galex-713>I mean why is there a single guile module instead of r5rs/r6rs/r7rs/srfi-n modules?
<taylan>whoop whoop https://lists.gnu.org/archive/html/guile-user/2016-05/msg00027.html
<galex-713>what is #'(exp) in scheme?
<galex-713>what does mean the #' ?
<ijp>it's a form of quoting used in macros
<galex-713>is there a difference with just quoting with ' ?
<ijp>yes
<galex-713>otherwise what’s the difference and where do I find it explained in the manual? I’m reading the first example of 6.10.3 and still didn’t see the explanation
<ijp>it's explained further down
<galex-713>oh wait there’s a reference to this notation in the following paragraph, let’s see if that’s explained then
<galex-713>oh ok cool
<ijp>I don't know what you are planning to write, but are you really sure you need a macro for it
<galex-713>I’m not writing anything, I’m reading the manual
<galex-713>from beginning to end
<ijp>that sounds unpleasant
<galex-713>(except some sections I quickly passed over like vhashes, vlists, and maybe something else)
<galex-713>ijp: what sounds unpleasant?
<ijp>reading the manual front to back
<galex-713>yeah but the epsilon's developer said me guile manual was good to learn properly scheme/guile, especially the section 3, but I read it and it seems I still doesn’t know most of the neat things of scheme/guile
<galex-713>ijp: ^
<galex-713>let’s say readed it because I’m tired of not knowing if it’s explicit enough I’m talking of past stuff
<JJDD>hi
<JJDD>I get the following error in guile
<JJDD>ERROR: Unbound variable: progn
<JJDD>why could that happen?
<ijp>because progn isn't defined in guile
<ijp>nor any scheme
<JJDD>ok
<ijp>progn is what? begin?
<JJDD>so it isn't defined in lisp either?
<davexunit>begin, yeah
<davexunit>JJDD: progn is in emacs lisp
<davexunit>and I think common lisp
<JJDD>oh ok, so it's just scheme
<JJDD>and you use "begin" instead?
<davexunit>yes
<JJDD>thanks
<ijp>I doubt clojure calls it that either
<ijp>it's just a really bad name
<ozzloy>clojure uses (do ....)
<galex-713>ijp: is there another way to learn?
<galex-713>do is a better name than begin
<galex-713>progn is an understandable name in relation to prog1, prog2, etc.
<dsmith-work>I kinda like "begin" better than "sequentially-evaluate-list-of-expressions-with-the-result-being-last-expression-in-the-list"
<galex-713>dsmith-work: do is better :p
<galex-713>even better than { } like in C
<ijp>do was already taken
<galex-713>loop would has been a better name for do
<galex-713>ijp: ^
<ijp>sure
<ozzloy>clojure has a (loop ...) too
<galex-713>ozzloy: to do things like do right?
<galex-713>btw, I still didn’t get the difference between do and a when inside a let
<galex-713>Except someone on #scheme said me it wasn’t a good idea of putting everything inside the first arg of do
<galex-713>and to put the do inside a let
<ozzloy>galex-713, yeah, i think clojure's "loop" is guile's "do"
<galex-713>Making me reconsider using do instead of while
<galex-713>*the difference between do and while
<galex-713>ozzloy: I think it is better understandable
<dsmith-work>do is just syntax sugar that most people can't remember how to use anyway.
<random-nick>galex-713: you can break from a while
<galex-713>random-nick: and not from a do?
<galex-713>(btw, how can you break from a while?)
<ijp>back in the day(tm), do only had a single variable
<random-nick>galex-713: with break
<galex-713>random-nick: ohh ok
<ozzloy>ijp, LUXURY! back in my day we had magnets!
<random-nick>galex-713: it's accessible only in a while body
<galex-713>ijp: why? also maybe the problem is that by default the variable inside do doesn’t have to be incremented/changed-over-iterations so you can use do as a while inside a let
<galex-713>random-nick: why isn’t it accessible from while?
<ijp>because they didn't think to generalise it till like 1970 or something
<random-nick>ozzloy, LUXURY! back in my day we had a pen and paper!
<galex-713>ijp: why do you mean by generalizing it and what’s the link between the fact do can bind several variables and the generalizing it till like 1970 or something?
<ijp>that is one hell of an eliza sentence
<dsmith-work>heh
<ijp>All I know is that the first scheme paper explicitly mentions that it uses the "more general" version of do, rather than the less general one
<ozzloy>what is an eliza sentence?
<galex-713>ozzloy: M-x doctor
<random-nick>galex-713: you mean from do? because do is in rnrs but while is guile-specific and can use a guile-specific feature (escape prompts) to implement break
<galex-713>ahhhhh ok
<galex-713>random-nick: ^
<galex-713>ijp: why do people believe I’m an AI :(
<galex-713>It is a bad experience to see you actually fail at turing test
<ozzloy>galex-713, ah
<ijp>I've failed it so often that I'm listed in fsbot's ",botstack" command
<galex-713>xD
<galex-713>,botstack
<ijp>fsbot is the #emacs bot, not the #guile one
<galex-713>oh wrong channel
<galex-713>yeah right
<dsmith-work>galex-713: fsbot is not in this channel
<galex-713>dsmith-work: yeah I just rembembered
<galex-713>ijp: what do you mean by listed? there is only your name in fsbot's ",botstack" command
<dsmith-work>do us jsut weird. Feels very unschemely to me. Probably is only in there because earlier lisps had it.
<amz3>héllo al
<dsmith-work>amz3: greets
<amz3>taylan: kuddoz for the release
<ozzloy>oh, is al here? i haven't seen him in ages
<ijp>dsmith-work: basically, yes
<amz3>ozzloy: :p
<ijp>foof-loop is sorta backwards compatible with do, which makes the syntax kinda weird
<galex-713>I’ve a question: any of you succeed to compile guile from sources?
<amz3>ijp: can you explain foof-loop in 3D experience for me?
<amz3>galex-713: not recently
<amz3>I mean I week ago yes
<amz3>galex-713: why?
<dsmith-work>Currently, master is failing to build on 31bit machines. Well, intel 32bit anyway.
<amz3>I'll check on 64bit
<dsmith-work>64 bit builds fine for me.
<galex-713>amz3: it does error
<galex-713>on my machine
<galex-713>amz3: what’s the branch of the most recent version?
<galex-713>v2.1.2?
<amz3>depends what you seek... I am on wip-ethreads
<amz3>Sorry, I don't know
<amz3>I always read master any except for ethreads
<amz3>ACTION should do that instead of looking up the doc on the web
<ijp>as a rule, you probably shouldn't be building master
<random-nick>amz3: what are ethreads?
<random-nick>wip-ethreads*
<galex-713>what is wip?
<galex-713>what does mean wip?
<ijp>work in progress
<random-nick>galex-713: work in progress
<galex-713>ahhhh ok
<galex-713>ijp: also, when you said it should be unpleasant to read guile ref front to back, do you know something less unpleasant/easier to do to learn guile/scheme?
<galex-713>ijp: before I got advised to read guile ref I was reading r5rs front to back, is it better?
<ijp>it's shorter, but that's about it
<ijp>basically, references don't usually make for good tutorials
<ijp>half the stuff in the guile manual you aren't going to need to know for a good while yet
<ijp>(if at all)
<galex-713>where is the verb?
<galex-713>I mean, what’s “half the stuff in the guile manual I’m not going to need to know for a good while yet”?
<amz3>random-nick: there is two things in ethreads AFAIK, better buffered read/write (something like that, I'm not sure I understand) and another thing that implements `async' keyword in scheme
<amz3>random-nick: it looks like 8sync, I'm not sure what's the difference anymore..
<amz3>galex-713: write code that the best you can do to learn a language
<ijp>I suppose "are"
<galex-713>amz3: you mean “write code that*’s* the best […]”?
<amz3>galex-713: I code anything in guile, like we talked earlier here in the chan about parser combinators so I implemented then, so did davexunit and stis they are competing somewhat (not mine) but it's not pollution
<galex-713>amz3: and well depends before someone said me about macros on #emacs, even writting a lot of code I would have never heard about macros
<amz3>uhu, I'm been introduced to lisp family BECAUSE of MACROS
<amz3>(and ai)
<galex-713>amz3: I was introduced because of emacs :p
<galex-713>And because lot of people from GNU did love it
<amz3>galex-713: write code *that's* what is best to learn a language
<galex-713>amz3: also is there a punctuation mark between “stis” and “they are competing” in your earlier message?
<amz3>galex-713: I think guile is nice based on my readings and staying here...
<galex-713>(sorry I need punctuation with english, I’m fine without it using french, italian, etc. but that’s because there’s a lot of little keyword in these languages that are mandatory to make logical connections)
<galex-713>amz3: yeah it seems so
<amz3>it's a semi colon
<galex-713>ok cool
<amz3>the programs are competing
<amz3>it's nice to have a different view of things, like story is told several times before you get the real track of the thing so that you don't have to think about it to remember it...
<galex-713>amz3: the problem is that staying alone coding a lot make me recode a lot of already-invented things that are sometimes already best achieved by others
<amz3>galex-713: no
<amz3>there is value
<amz3>not everything is better in the other implementation
<galex-713>why do you mean by that?
<amz3>also anyway, you needd to pratice keyboard-chair sport to grok it
<amz3>galex-713: every implementation has bugs, mis-behavior, you think everything is perfect the first time?
<amz3>my principle is that if I can do it and it's interesting, it's awakes questions, desire or something I try to code it
<galex-713>amz3: of course not, but a peer-reviewed implementation has way more chances to be better of one of my implementations
<amz3>there is three implementations of parser combinators alors each of which does things differently
<galex-713>amz3: what is “alors” in english?
<galex-713>amz3: I got disconnected some seconds, your first message began with “there is three implementations” and mine with “amz3: what is ‘alors’ in english”?
<galex-713>did you post something meanwhile/did you get my last message?
<galex-713>oh :(
<galex-713>Anyway, is anybody able to compile origin/master?
<galex-713>amz3: I got disconnected some seconds, your first message began with “there is three implementations” and mine with “amz3: what is ‘alors’ in english”?
<galex-713>did you post something meanwhile/did you get my last message?
<amz3>galex-713: I code disconnected too
<amz3>wait, I post the thing
<random-nick>amz3: from my point of view your latest message is the one with alors and parser combinators
<amz3> http://dpaste.com/11WMMZ5
<amz3>galex-713: alors == then
<amz3>but it's not well structured!! sorry :)
<galex-713>amz3: ah ok, like in french
<amz3>sorry it's a second language or third language or stuff...
<amz3>I think I'm better at french
<galex-713>pm? :)