IRC channel logs

2016-05-21.log

back to list of logs

***M-TimePath is now known as M-TimePath1
***M-TimePath1 is now known as M-TimePath2
***M-TimePath2 is now known as M-TimePath
***M-TimePath is now known as TimePath`
<davexunit>wrote a simple dynamically resizing vector http://paste.lisp.org/display/316492
<davexunit>just for fun
<davexunit>someone in #scheme was complaining about not having them
<paroneayea>wingo: http://pamrel.lu/7b4fd/ there, repasted, and http://pamrel.lu/d955e/ here's the context again
<paroneayea>wingo: I submitted that patch with your help in nailing down the cause, but it was >6 months ago :)
<paroneayea>so it's on the C side, so I doubt it's contified but maybe
<paroneayea>I had found out that my activitystuff code got slower with guile 2.2 by a large margin and so we discovered it was the SCM_VALIDATE_THUNK which was doing it, you suggested I remove it
<paroneayea>oh
<paroneayea>it was (delay) which did it, not (values)
<paroneayea>my bad.
<amz3>héllo :)
<amz3>davexunit: I think sxml->html could be a nice addition to Guile stdlib
<amz3>I found it in Haunt
<amz3>ACTION is improving his markdown parser
<davexunit>amz3: yeah it might be useful to include there
<amz3>right now I'm copy pasting the thing directly in my program :p
<amz3>... on another topic, I had a look at my nginx stats on my server, guile-log article has a lot of visitor \\cc stis
<amz3>I'm wondering why
<wingo>paroneayea: it's not related to call-with-values though is it?
<wingo>that's thunk?
<wingo>i wanted to make a different fix for that, to answer basic procedure arity questions via parsing the object code..
<wingo>maybe i can fix that nowish
<paroneayea>wingo: yeah I was mistaken
<paroneayea>sorry :)
<jmd>How can I define a function which is to take a variable number of arguments?
<masoudd>jmd: You can do (define (pro arg1 arg2 . rest) (display arg1) (newline) (display arg2) (newline) (display rest) (newline))
<masoudd>jmd: that example takes at least 2 args
<masoudd>'rest will be a list of the rest of the arguments
<random-nick>jmd: or if you already know all the possible numbers of arguments you can use case-lambda
<jmd>masoudd: How can I call that recursively?
<masoudd>I don't see any difference with other procedures in that regard
<masoudd>(define (pro . rest) (display rest) (newline) (unless (null? rest) (pro (cdr rest))))
<random-nick>jmd: btw the variable doesn't have to be named rest
<jmd>masoudd: But then the second call to pro will be a list.
<masoudd>Right. hmm
<random-nick>apply?
<masoudd>yeah
<jmd>b
<jmd>Will that also work the same for module-define! ?