IRC channel logs

2016-04-23.log

back to list of logs

<paroneayea>davexunit: https://mobiforge.com/research-analysis/the-web-is-doom
<koz_>Does Guile have something similar to 'python -m SimpleHTTPServer'?
<mark_weaver>Guile does include a simple web server, but I'm not familiar with what python has so I don't know how they compare.
<mark_weaver>see section 7.3 of the guile manual
<koz_>mark_weaver: Oh, thanks!
<koz_>I'm not saying it has to be *exactly* identical - I just wanted to see if similar functionality existed.
<mark_weaver>well, for example, guile's built-in web server doesn't include out-of-the-box support for serving static files from a directory on the filesystem.
<mark_weaver>but that's an example of something that would be quite easy to do
<mark_weaver>you need to write some code that dispatches on the requests and generates the responses
<mark_weaver>but for simple cases, that code can be very small
<koz_>mark_weaver: Well, my whole reason for asking is that I wanted a simple test webserver to serve local pages into my browser for previewing purposes.
<koz_>(like, run inside a directory to see what it'd look like in a browser)
<mark_weaver>try nginx
<rain1>doesn't file:/// work for that?
<koz_>rain1: It does?
<rain1>thats how i check html stuff im working on
<koz_>rain1: OK. Well, if that's the case, even better.
<mark_weaver>for static files containing suitable filename extensions, file:/// works fine in my experience.
<koz_>mark_weaver: Well, that's all I really plan to be testing with.
<mark_weaver>I've even tested javascript programs that way
<mark_weaver>I have to go afk. happy hacking!
<koz_>mark_weaver: Thank you! I'll probably chime back here if I run into any issues.
<cojy>hi guilers
***xyh is now known as xieyuheng
***xieyuheng is now known as viva-cicada
***viva-cicada is now known as xieyuheng
<wingo>moo
<wleslie>wingoo!
***random-nickname is now known as random-nick
***karswell` is now known as karswell
<wingo>mew
<daviid>heya!
<daviid>wingo: any news wrt bug#20093 ?
<daviid>wingo: till it's fixed I'm locked in the past :) and love future...
<wingo>interesting bug, i had forgotten about that
<wingo>tx for the report :)
<wingo>no news now but i will take a look
<paroneayea>ACTION has fmt working locally
<paroneayea>maybe time to package for guix..
<daviid>paroneayea: is it not in guildhall already?
<daviid>guild list-packages -> ... i wak-fmt 0.7-2 formatting combinator library
<paroneayea>daviid: oh, I dunno, I don't use guildhall
<paroneayea>daviid: though the version I have running here is newer
<paroneayea>0.8.4
<daviid>paroneayea: ah, much better
<daviid>paroneayea: maybe you could update the guildhall package
<daviid>ACTION hides :)
<paroneayea>daviid: sounds useful, but I don't really have time / am personally interested enough to learn to do that right now
<daviid>sure
<wingo>tough to work on guildhall when one has guix :)
<ijp>basically no reason to
<ijp>as an aside, fmt is probably more cool than useful
<paroneayea>ijp: maybe :)
<paroneayea>ijp: I'm writing a little MUD
<paroneayea>so it would kind of be nice to have some ways to write things out rather than doing a billion string-join / string-append / format hacks
<ijp>which is fair
<paroneayea>ijp: but I'd like to have it packaged even just for the cool factor
<ijp>I have a similar fondness for (sxml transform) but I may be one of the few people who actually use that
<paroneayea>I *did* listen to a talk wingo gave some time ago about how he'd like to try out fmt but knows it wouldn't be efficient to do all that procedure based composition in guile's current compiler but hopefully in the future, etc etc :)
<paroneayea>I think it was at a javascript conference about scheme, or the reverse.
<ijp>IO and efficiency don't really go anyway
<random-nick>paroneayea: http://www.schemeworkshop.org/2014/slides/Wingo2014.pdf
<random-nick>paroneayea: on page 22 he mentions fmt