IRC channel logs

2016-04-21.log

back to list of logs

<cojy>what should i use as a buffer to build up strings?
<Chaos`Eternal>helo mortals
<ozzloy>i found the definition of emit! it's a macro defined in the same file. i missed it before because i was searching for "(define (emit"
<lloda>someone should write (define-method*)
<paroneayea>hm, interesting
<paroneayea>so GOOPS provides the #:allocation #:class/#:each-subclass slot option
<paroneayea>and then a method for accessing it:
<paroneayea>(class-slot-ref <my-class> 'my-slot)
<paroneayea>however it's not very useful
<paroneayea> http://pamrel.lu/53261/
<paroneayea>looks like you need to initialize an instance before (class-slot-ref) does anything
<dsmith-w`>[appropriate time] Greetings, Guilers
***dsmith-w` is now known as dsmith-work
<wleslie>happy Friday, dsmith-work!
<dsmith-work>wleslie: heh
<wleslie>en advance.
***daviid is now known as Guest21726
***daviid` is now known as daviid
<paroneayea>so would it be correct to say this
<paroneayea>the scheme convention is that function* is the fancy sugar version of function often? :)
<paroneayea>I have a situation where I have the version of something which people will probably use most often
<paroneayea>which is the sugar version
<paroneayea>and only rarely will they use the non-sugar one, but indeed sometimes they will
<df_>I think it's fairly ill-defined, but that may be as close to a definition as you'll get
<df_>also not only function*, sometimes macro*
<df_>* may do something iffy and break established rules
<daviid>lloda: mark wrote a define-method*, let me see if i can find it
<daviid>here: http://paste.lisp.org/+6QHT [untested, never even tried it, the code as mark pasted it here a while ago...]
<daviid>lloda: ^^