IRC channel logs

2016-04-16.log

back to list of logs

<guile-guest5>Howdy!
<guile-guest5>Do you know how can I delete a node from an SXML tree?
<guile-guest5>I'm trying to do this in Guile: http://modis.ispras.ru/Lizorkin/sxml-tutorial.html#hevea:modif
<guile-guest5>(Example 27)
<davexunit_>guile-guest5: an sxml tree is just a nested list, so you can simply traverse it with a loop that builds a new tree, leaving out the elements that you don't wnat.
<davexunit_>want*
<guile-guest5>davexunit_: Thanks
<jmarciano>I try to compile guile-gtk, but I get error: No package 'gtkgl-2.0' found and don't know where to find that package.
<jmarciano> http://ftp.gnome.org/pub/GNOME/sources/ searched here, but it is not there
<daviid>jmarciano: guile-gtk is unmaintained, see guile-gnome instead https://www.gnu.org/software/guile-gnome/ which has a (gnome gtk) module, a gtk2 binding still, but that's what we have
<jmarciano>now I see the message
<jmarciano>that is nice, I will take that one to build in my system
<jmarciano>first I need to compile g-wrap
<daviid>jmarciano: yes either g-wrap or guile-cairo, as you wish, wrt guile-caito, do read carefully what i wrote on the download page... you must grab the source from the git repo, not the tarball...
<daviid>* guile-cairo
<jmarciano>for gnome, from git?
<daviid>jmarciano: no, just guile-cairo
<daviid>you may grab the tarballs for g-wrap and guile-gnome, but you my as well install all from git repos, which I personnally find a lot better, because you don't need to wait for releases, when patches come out, just git pull and mke again...
<daviid>if that becomes your choice too :) read the developer page instead of the download page [for all 3]
<jmarciano>I know that, of course, I have git. But releases are important, as I keep source of what works with version number, as I need to copy it multiple times and re-install multiple times from same version.
<daviid>jmarciano: ok, as you wish. but wrt to guile-cairo, no option, you must grab the sources from the git repo
<jmarciano>these wrappers will be built: atk cairo glib gtk libglade pango
<jmarciano>so that is for guile-gnome
<calher>davexunit_: Markdown for Haunt? https://github.com/greghull/sundown-guile
<daviid>jmarciano: this is not the cpmplete set, but you see it will build gtk, so fine. just in case you'd lke to know, the complete lst would be this:
<jmarciano>so shall I install guile-cairo first?
<jmarciano>websites look nice for guile-gnome and guile-cairo, simple and viewable on text browsers
<daviid>jmarciano: yes, guile-cairo and g-wrap first, then rerun the configure step for guile-gnome
<jmarciano>aha ok
<darthlukan>what is the basic style guide for guile code? Spaces over tabs? 2 or 4 spaces? etc.
<darthlukan>I was digging around and didn't find anything explicit
<jmarciano>I see guile-gnome was searching for indent and did not find it. Just to let you know. No error.
<calher>Speaking of guile-gnome, why do first_programs/app_icon.scm and menus_toolbars/simple_menu.scm fail to run on Guile 2.0 on Ubuntu Trusty-based systems with guile-gnome2-gconf, guile-gnome2-glib, guile-gnome2-gnome, guile-gnome2-gnome-ui, and guile-gnome2-gtk installed?
<calher>(From https://github.com/yang-qu/gtk-tutorial-using-guile-gnome)
<jmarciano>link 404
<calher> https://github.com/yang-qu/gtk-tutorial-using-guile-gnome
<daviid>jmarciano: the complete wrapper list is, for info: atk cairo corba gconf glib gnome-vfs libgnome pango gtk libglade libgnomecanvas libgnomeui
<jmarciano>yes, sure, though I don't need too many
<daviid>jmarciano: of course, you're good if it buils gtk
<jmarciano>for me is more important like MIME, extrapolation of variables, text parsing, etc
<daviid>calher: this is old, i'm not aware, would not trust, and besides, it says 'This project converts C code in gtk tutorial': we don't need that, we write pure scheme code to use guile-gnome
<jmarciano>I guess Guile need some main website with all guile resources on it.
<taylan>jmarciano: like http://gnu.org/s/guile ?
<jmarciano>that one is main site I know
<jmarciano>it gets updated I see
<calher>daviid: Ah, OK. Is there any example code for GUIs in Guile?
<jmarciano>writte purely in Guile...
<daviid>jmarciano: here as well http://sph.mn/content/3e73
<daviid>calher: in gtk/examples/
<jmarciano>that one is much better for me
<calher>daviid: Where is "gtk/"?
<daviid>calher: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/gtk/examples/
<calher>Thanks, daviid.
<jmarciano>guile website is written in guile, seems more complex than it has to be if it would be written in markdown
<jmarciano>upmf is not on the list on sph.mn
<jmarciano> http://www.nongnu.org/upmf/
<daviid>jmarciano: writing sxml is a lot better then markdown,imo. mardown is good for 1 page ultra simple thing, like a todo list, behond that, you want scheme
<jmarciano>I would really like to understand this reasoning
<daviid>I have to go afk
<jmarciano>see you
<calher>I keep getting ("no code for module" (gnome glib)) even though I installed glib stuff for Guile.
<stis_>hej guilers!
<daviid>calher: I have to quit irc now, but will be back later or tomorrow, then I can [try to] help, stay tune :)
<paroneayea>ACTION writes an actor model system on top of guile
<paroneayea>and 8sync
<daviid>calher: back for half an hour. did you ,use (gnome-2) before ,use (gnome glib) [or any other gnome module]?
<calher>I ran them as-is from the repo, daviid.
<daviid>I don't understand. could you fire up a new guile repl and enter ,use (gnome-2)
<calher>daviid: scheme@(guile-user)> ,use (gnome-2)
<calher>scheme@(guile-user)>
<daviid>perfect, now ,use (gnome glib)
<daviid>calher: some examples work, others not, because very old and nobody patched them yet... for info
<calher> http://tu4mg5lztsupaeds.onion.to/p/guile.txt (no apparent failure, success)
<daviid>good, then you're good to go... :) guile-gnome hacking!
<daviid>calher: there are self executable examples and a demo as well, from within which some work, some not ... but worth trying the demo and look at the source
<calher>daviid: I hear that a lot with Guile. Everything's old and nothing works.
<daviid>calher: guile-gnome works perfectly, just some example have not been updated
<calher>oh ok
<daviid>calher: try to go to this dir gtk/examples/guile-gtk-demo [where you untared] and ./guile-gtk-demo.scm
<calher>How do I cd in Guile?
<daviid>(chdir ...)
<ijp>I added a meta-command for it to my .emacs, but I never use it
<daviid>but the demo is an shell, execute it from the terminal instead
<ijp>s/.emacs/.guile/
<daviid>ijp: oh that's nice, could you paste?
<ijp>(define-meta-command ((cd foo) repl dir) "cd DIRECTORY" (chdir dir))
<daviid>calher: I ment the demo is a script, run it from a shell...
<calher>compiling
<calher>woohoo!
<ijp>obviously you'd need to use-modules (system repl command)
<calher>It Works! :D
<daviid>ijp: thanks
<daviid>calher: great
<calher>Dafuq--
<calher>exec guile-gnome-2 -s $0 "$@"
<calher>why not just load stuff with normal guile
<daviid>calher: you can use both solutio: either exec guile-gnome-2 -s $0 "$@" and then you do not have to import (gnome-2), or exec guile -s $0 "$@" then you _must_ import (gnome-2)
<calher>I guess the shebang is gonna be weird either way.
<daviid>sneek: later tell jmarciano instead of upmf, you may look at guildhall https://github.com/ijp/guildhall
<sneek>Got it.
<daviid>calher: the shebang is there only for scripts