IRC channel logs

2016-04-08.log

back to list of logs

<wingo> http://research.microsoft.com/pubs/244803/preprint.pdf
***[X-Scale] is now known as X-Scale
<davexunit>paroneayea: looking at your haunt patch finally
<davexunit>the URI building doesn't look correct
<davexunit>(string-append "/" blog-prefix (site-post-slug site post) ".html")
<davexunit>I think it should be
<davexunit>(string-append blog-prefix "/" (site-post-slug site post) ".html")
<davexunit>no?
<guile-guest8>just curious if anyone knows what theme that would be on the guile site in the examples? looks really nice.
<davexunit>guile-guest8: I'm not sure if it corresponds to any particular named color scheme.
<paroneayea>davexunit: probably, but I copied the style from blog.scm
<paroneayea> (define (post-uri post)
<paroneayea> (string-append "/" (or prefix "")
<paroneayea> (site-post-slug site post) ".html"))
<davexunit>paroneayea: oh
<davexunit>well that's wrong, too.
<davexunit>grr.
<davexunit>I'll fix.
<paroneayea>davexunit: how about you fix both and push the patch? :)
<davexunit>sure
<davexunit>but I need to test the patch still
<davexunit>and make sure my sites still build
<davexunit>paroneayea: pushed
***guile-guest8 is now known as ouano
<ouano>paroneayea: was that comment about copying the style from blog.scm about the color theme?
<paroneayea>ouano: nope
<paroneayea>was about url routing
<ouano>oh okay.
<paroneayea>davexunit: I was thinking
<paroneayea>it might be nice to have a wrapper object around blogposts and etc
<paroneayea>davexunit: that can be used to generate *both* the atom and the blog feeds
<paroneayea>er
<paroneayea>builders
<davexunit>maybe
<davexunit>would be easy for someone to write themselves, though.
<paroneayea>so like
<paroneayea>(let ((blog (blog-builder "path/to/blogposts"
<paroneayea> #:prefix "/blog/")))
<paroneayea> (site
<paroneayea> #:builders (list (blog-blog blog)
<paroneayea> (blog-feed blog)
<paroneayea>
<paroneayea>davexunit: not sure if it gives much advantage
<paroneayea>you're right, it would be easy
<paroneayea>just thinking out loud, anyway
<davexunit>returning a site wouldn't be good, because a user needs to edit other things
<davexunit>returning a list of builders would work
<paroneayea>davexunit: I mean this is someone using it :)
<dsmith-work>Happy Friday, Guilers!!
<paroneayea>davexunit: I guess the main advantage:
<paroneayea>it would allow someoen to have multiple blogs on a site
<paroneayea>though is that really useful? I dunno
<davexunit>you can already have multiple blogs, no?
<davexunit>you can make as many builders as you want and filter the posts list as necessary
<paroneayea>davexunit: but you can only have one posts directory right?
<davexunit>yes
<davexunit>perhaps that could be changed, but currently I see no need to do so.
<paroneayea>fair enuf!
<paroneayea>it is simpler as it is.
<davexunit>distinguishing between multiple sites could be implemented currently by attaching new metadata
<davexunit>and filtering based on that for each sub-blog
<paroneayea>ACTION nods
<davexunit>unless there is something missing for filtering... there might be. that would need adding.
<wingo>moo
<holomorph>baa
<wingo>mark_weaver: did you have a chance to think about the wip-ports-refactor?
<wingo>ACTION goes ahead with it, implementing more of the things i mentioned in the recent mail
<wingo>and updating NEWS
<amz31>héllo guilers!
<wingo>greets :)
<paroneayea>hello!
<paroneayea>wingo: I'm re-reading the email
<paroneayea>it's more fun than doing the next things on my todo list ;)
<wingo>:-)
<Jookia>does guile have any good profiling tools?
<paroneayea>Jookia: yes, see statprof
<paroneayea>in the manual
<paroneayea>it's quite nice!
<ozzloy>is it possible to do html comments in sxml simple?
<ozzloy>i tried (sxml->xml '(!--)) but that didn't work. did a bit of searching the web too
<davexunit>ozzloy: no
<davexunit>comments are not part of the markup
<davexunit>just like you can't represent a Scheme comment in a Scheme sexp
<davexunit>they are *ignored*
<ozzloy>bummer
<ozzloy>i'm guessing there also isn't a way to output pretty-printed xml?
<davexunit>not built-in to sxml simple
<davexunit>you could write your own pretty printer
<jmd>"pretty" and "xml" do not fit together in the same paragraph.
<ozzloy>davexunit, where would i start with that?
<davexunit>ozzloy: if you want comments and pretty printing, what you probably want is hand-written XML
<davexunit>SXML is for serialization/deserialization for machines, not humans.
<davexunit>ozzloy: take the source to sxml->xml and modify it
<davexunit>you'd need to track things like indentation level and such
<ozzloy>i don't want to hand write xml, no. i am writing html for a site. i want to have easter eggs in the html
<ozzloy>i'd rather write sxml or something like it than xml
<ozzloy><tag>this is the content of the tag "tag" and in case you've forgotten, here's a reminder of what tag this is in:</tag>
<ozzloy>i hate that
<ozzloy>at least it doesn't do that with the start and stop indicators for the tag itself
<ozzloy>open-starting"tag"tag tag close-starting"tag"tag tag content open-closing"tag"tag tag close-closing"tag"tag
<rain1>you could make a copy of th elibrary and add a new tag to it
<ozzloy>i might just do that.
<davexunit>yeah, I have written my own serializers
<davexunit>for HTML output I use this https://git.dthompson.us/haunt.git/blob/HEAD:/haunt/html.scm
<davexunit>that's the nice thing about s-expressions
<davexunit>it's easy to traverse them, pattern match, and do what you need
<ozzloy>davexunit, what are you using for git.dthompson.us ? cgit?
<ozzloy>gitweb, i see
<ozzloy>it looks nice, did you style it specially?
<davexunit>ozzloy: I used a style someone else made
<davexunit>this http://kogakure.github.io/gitweb-theme/
<ozzloy>cool
<ozzloy>i'm looking through the code right now to hide the autocompile message. i see there's a "turn-on-debugging?" and a "turn-off-debugging?" which are both boolean. what's up with that? why not just one boolean named something like "debugging?"
<davexunit>could be old cruft
<ozzloy>that makes me sad inside like this: T_T
<ozzloy>gah! "(or turn-on-debugging? (and interactive? (not turn-off-debugging?)))"
<ozzloy>oh, there is a comment above it
<paroneayea>davexunit: you didn't push the "fixed" version, right?
<paroneayea>it looks like you pushed basically what I sent you
<paroneayea>davexunit:
<paroneayea>oops
<davexunit>paroneayea: right
<paroneayea>davexunit: want me to push you another patch, or do you want to do it?
<paroneayea>it seems pretty simple to do regardless
<turbopape>What's going on guys davexunit and paroneayea ? new version cooking up ?
<sneek>turbopape, you have 1 message.
<sneek>turbopape, amz3 says: the repository for guile javascript backend is at https://gitlab.com/ijp/guile.git
<davexunit>turbopape: new release of Haunt, a static site generator, sometime soonish.
<paroneayea>turbopape: I'm using it for 8sync's site design.
<turbopape>cool !
<turbopape>All the best :)
<turbopape>amz3 tell me more about the js backend, please ?
<ozzloy>davexunit, thanks for the help
<davexunit>np
<ozzloy>rain1, oh, i didn't see your comment before
<ozzloy>rain1, i'll look into that too
<ozzloy>gtg, later
***M-TimePath is now known as TimePath
<paroneayea>davexunit: patch emailed.
<davexunit>oh another?
<davexunit>what are we adding this time?
<davexunit>:)
<paroneayea>davexunit: the thing we just discussed
<paroneayea>fixing the prefix order
<paroneayea>in the string-append
<paroneayea>for both filesx
<davexunit>ah!
<davexunit>sorry
<davexunit>cool
<davexunit>thank you!
<paroneayea>:)
<paroneayea>nw
<paroneayea>er
<paroneayea>yw
<Jookia>'no worries' works just fine
<Jookia>:P
<paroneayea>not as nice as you're welcome though :)
<davexunit>will apply next time I'm at my laptop
<ozzloy>hakuna matata
<ozzloy>it means "no worries"
<Jookia>she'll be right
<ozzloy>for the rest of your daays
<paroneayea>wingo: it looks like your (ice-9 epoll) could be pretty easily separated from wip-ethreads
<paroneayea>it doesn't look like it depends on the other stuff really?