IRC channel logs

2016-04-06.log

back to list of logs

<daviid>rain1: it crashes if you run the script over "Clutter"
<daviid>I guess your implementation too?
<daviid>in a C example they do this:
<daviid>... GIAttributeIter iter = { 0, };
<daviid>... while (g_base_info_iterate_attributes (info, &iter, &name, &value)) ...
<daviid>what should be the proper make-c-struct call?
<rain1>it's working
<rain1>(Printing attributes for zerosuperior)
<rain1>(Printing attributes for zstroke)
<rain1>I didn't get a crash
<daviid>did you let it go to the end? there are more then 5000 infos in Clutter, 5x more then for Gtk
<daviid>did it actually print any struct? if yes can you tel me the index of the info which has attrs? tx
<rain1>what crashes?
<daviid>my implementation of g_base_info_iterate_attributes crashes when called above the "Clutter" namespace, where it works fine using the "Gtk" namespace: so I wonder if yours works on Clutter? did you try?
<rain1>try what ?
<rain1>I've not used g_base_info_iterate_attributes
<daviid>the example you pasted a while ago, but using Clutter instead of Gtk
<rain1>yes I did that just now
<daviid>ok, so, did you get any attributes printined? Gtk has none, how about Clutter?
<rain1>none
<rain1>I think attributes might only come from other objects
<daviid>none, hum i wonder why my impl works on Gtk and not on Clutter
<rain1>have you tried it in C first?
<daviid>rain1: I'm not a very good C guy by the way, why did you do (iter (make-c-struct (list '* '* '* '*) ... and not (iter (make-c-struct (list '*) ...
<daviid>rain1: I don't have [yet] a C snipset compilable...
<daviid>do you?
<rain1>good question about make-c-struct
<rain1>that struct is shown as 'opaque' in the documentation
<rain1>but that isn't good enough for us
<rain1>if you look at the actual header file defining it you can see it's 4 pointers
<daviid>rain1: ah ok thanks
<daviid>pretty scary, I did not change anything and now it worked
<rain1>that's the worst!
<daviid>ah I now why now!! muuuuuch better to know and my mistake here, a tipo on the require call... must be tired :)
<daviid>good!
<rain1>define* is not doing what i want
<rain1>keys appear in #:rest
<rain1>is there a way to have that not happen?
<rain1>I suppose I'll just not use #:rest
<ijp>"When #:key is used together with a rest argument, the keyword parameters in a call all remain in the rest list. This is the same as Common Lisp."
<ijp>you could post-process the rest list
<paroneayea>o/
<rain1> https://www.gnu.org/software/guile/static/base/img/kid-robot-and-extension-legs.png
<rain1>who grew these great guile logos?
<ijp>huh, I didn't notice the logo changed
<ijp>I think sirgazil did the (G), don't know about that robot though
<davexunit>he also did those drawings
<ijp> http://sirgazil.bitbucket.org/en/blog/2015/designs-for-guile/
<rain1>he did a great job, tehy are wonderful sketches
<ijp>my initial reaction in june "<davexunit> can we work a lambda into that? ;) <ijp> davexunit: no lambdas please"
<davexunit>haha
<taylan>There was an alternative with a lambda. I thought it was pretty nice too.
<ijp>lambdas are too cliché at this point
<taylan>but yeah sirgazil's art is beautiful :)
<davexunit>I replace the swooshes on my nike's with lambdas
<ijp>and having parens in your logo is way less common :)
<davexunit>I call it the slambda
<davexunit>wingo gave a talk about guile some years ago in which he sang this to the tune of "the sound of silence": Hello parens my old friend. I've come to hack with you again.
<ijp>maybe we should beg sirgavil for some nice manual css too
<rain1> https://notabug.org/rain1/guile-zenity ok added a logo for guile zenity - just put the two logos together
<cojy>rain1: it looks awesome :D
<bavier>rain1: you may want to include a license header in zenity.scm
<fhmgufs>rain1: I wanted to ask, whether I can help with the development of guile-zenity, since that would be a really good project for me to get started with Scheme.
<fhmgufs>What do you think?
<rain1>yes please !
<rain1>what do you want to do? :)
<fhmgufs>I think add more things!
<rain1>great :)
<davexunit>is there a zenity library that can be linked against instead of using system()?
<rain1>Color Selection Dialog, Scale and Text Information are the simplest to add support for I think
<rain1>if you are interested in any of those
<rain1>fel free toPM me if you have any questions
<fhmgufs>Ok, I'll start now.
<rain1>ill check if there exists a library, I don't think so
<rain1>another nice thing is to make small simple example programs, that will help beginners a lot
<rain1>I've made couple - ideas for more are welcome :)
<jackdaniel>erm, anyone is proficient in guix (package manager) and wants to have a presentation on pkgsrc conf in krakow about it? (1st june)
<wingo>jackdaniel: perhaps try #guix :)
<jackdaniel>yeah, already did, sorry for multi#
<wingo>mark_weaver: you around?
<wingo>i have patches for you to look at :)
<wingo>on wip-port-refactor
<rain1>how do i check if i port is still open before writing to it?
<rain1>if i just write i get 'broken pipe'
<wingo>that could mean the port is open but the fd is broken
<wingo>you need to install a sigpipe handler
<rain1>oh thanks! ill try