IRC channel logs

2016-03-13.log

back to list of logs

<paroneayea>wingo: davexunit: http://article.gmane.org/gmane.lisp.steel-bank.devel/19495
<paroneayea>maybe of interest
<davexunit>paroneayea: I have basically 0 faith that webassembly is going to turn out well.
<paroneayea>davexunit: orly?
<paroneayea>in a technical or freedom way?
<davexunit>and this further reinforces it.
<davexunit>both.
<paroneayea>or both
<davexunit>I don't have concrete reasons to cite (well, maybe this lisp thing now) but I just have a hunch that it's not going to go well.
<davexunit>freedom is definitely down the tubes, though.
<davexunit>but it pretty much already was with JavaScript anyway.
<paroneayea>I feel like yes, freedom already was down the tubes
<paroneayea>but I would be happy to not write javascript itself
<davexunit>yes, that is a plus.
<JeanLouis>if I want to write guile in emacs, is there any guide how to make it easier?
***ft_ is now known as ft
<ozzloy>JeanLouis, idk about a guide, but geiser helps
<ozzloy>janneke, http://www.nongnu.org/geiser/
<ozzloy>janneke, woops, meant that for JeanLouis
<ozzloy>JeanLouis, also i've heard that http://www.neilvandyke.org/quack/ is goo, but don't use it myself (yet)
<ozzloy>i've heard it goes with geiser
<ozzloy>well
<JeanLouis>Geiser turned on automatically, only that it has too many commands, I don't know where to start.
<ozzloy>i would start with C-c C-a from inside a .scm file
<ozzloy>that starts a guile repl, compiles the scm, loads it to the repl, puts cursor in repl, bam, you can start repl-ing
<JeanLouis>ozzloy: let me try
<JeanLouis>it loads it in repl? but not evaluate it?
<janneke>ACTION resent Friday's broken patch to guile-devel :-(
<janneke>anyway, finally some real progress on running guile-2.0 + guile-next
***M-TimePath is now known as TimePath`
<rain1>hi
<janneke>hi rain1
<rain1>I wanted to report a issue with geiser
<rain1>I could explain it here?
<janneke>rain1: possibly, it may work better when a geiser-hacker responds...
<amz3>hey rain1 did you settle on a project yet?
<rain1>no
<ozzloy>JeanLouis, sorry, i passed out
<ozzloy>JeanLouis, i think it gets evaluated
<JeanLouis>ozzloy: alright
<JeanLouis>ozzloy: the only thing I see is ,m (guile-user)
<JeanLouis> https://rcdrun.com/images/upload/tmp/2016-03-13-18:34:19.jpg
<paroneayea>hey wingo, would it be useful for you if I tried to rebase the elisp code again and added complete sentences for the subject line of the commit?
<paroneayea>I'm a little bit nervous about rewriting bipt's phrasing but I got some encouragement on guile-devel to do it.
<wingo>paroneayea: good day :) no strong opinions, haven't had a chance to look at it
<janneke>ACTION ... building set of skip v4 patches on guix also handling eval.go
<JeanLouis>how can I use (atom primitive in Guile?
<rain1>the equivalent in scheme is SYMBOL?
<JeanLouis>From this link http://www.paulgraham.com/rootsoflisp.html I am reading this: http://lib.store.yahoo.net/lib/paulgraham/jmc.ps and want to do the practice with (quote and (atom...
<JeanLouis>that should be scheme: atom? Right?
<cojy>i think (define (atom? x) (not (pair? x))) should be enough for that paper
<JeanLouis>thanks, only not working as expected
<JeanLouis>how do I load scheme standard into guile?
<cojy>JeanLouis: can you give an example of it not working?
<cojy>i dont htink it's in the standard
<cojy>oh in that paper it returns nil to pun false
<cojy>but the test is the same
<JeanLouis>I know I can load scheme in guile... but how
<cojy>guile is scheme
<cojy>and there is no atom? predicate in any scheme standard afaik and i just looked
<cojy>and any of them wont be like lisp, since we dont use nil as a false value in scheme
<cojy>you will have to either rewrite everything or adapt the paper
<rain1>guile -l file.scm
<JeanLouis>I found atom?
<cojy>i saw some incorrect ones floating around so i hope you didnt get one of those :S
<JeanLouis>I am learning basics
<JeanLouis>if someone can help my, why do I need atom?
<JeanLouis>like (atom? 'a) why do I need it?
<JeanLouis>expression is atom or list, ok
<JeanLouis>atom? is to verify that it is a list?
<mark_weaver>available type predicates in standard scheme include: null? pair? boolean? number? symbol? vector? etc
<mark_weaver>atom is from lisp, but not part of scheme
<JeanLouis>it is in guile
<JeanLouis>I got what is quote, car, cdr, very nice, I used it already. but what does atom? check?
<turbopape>if something isn't a pair or a list
<rain1> http://clhs.lisp.se/Body/f_atom.htm
<rain1>it's part of common lisp
<rain1>a different language than scheme
<mark_weaver><JeanLouis> it is in guile
<mark_weaver>JeanLouis: what are you asserting is in guile?
<turbopape>actually it is in the little schemer
<rain1>turbopape, we are looking at paul grahams code right now
<JeanLouis>I want to learn seven primitive operators
<turbopape>ok
<mark_weaver>in lisp, an atom is anything that's not a pair
<mark_weaver>iirc
<JeanLouis>1. quote, 2. atom 3. eq (clear), cdr, car, etc
<JeanLouis>mark_weaver: that confirms my idea
<JeanLouis>could I then first check with atom? and if pair, do cdr?
<mark_weaver>there's no 'atom?' in scheme
<mark_weaver>if (pair? x) is true, then (cdr x) is valid
<mark_weaver>s/if/if and only if/
<JeanLouis>I am in guile, there is atom?
<JeanLouis>scheme@(guile-user) [13]> (atom? 'a)
<rain1>but you defined it
<JeanLouis>nooo can it be...
<JeanLouis>oh yes
<mark_weaver>heh
<JeanLouis>hahahh
<JeanLouis>scheme@(guile-user) [13]> (atom? 'a)
<JeanLouis>thanks cojy
<mark_weaver>JeanLouis: btw, that [13] means that you are 13 levels deep within error REPLs.
<mark_weaver>if an error occurs while evaluating an expression you type, then guile launches a sub-REPL, initially labelled [1]
<mark_weaver>that's actually a debugger where you can investigate what went wrong.
<JeanLouis>aha yes
<mark_weaver>if you don't want to debug, then you could normally exit out of that sub-REPL with ",q"
<JeanLouis>but I often pass errors, end re-evaluate
<mark_weaver>gotta go afk for a while...
<JeanLouis>if I do ,q I get one number back only
<JeanLouis>you can no longer claim to have invented a new language, but only to have designed a new dialect of Lisp http://www.paulgraham.com/diff.html