IRC channel logs

2016-03-05.log

back to list of logs

<daviid>folks, I solved my make distcheck / texi2dvi bug, so nobody needs to worry anymore :)
<paroneayea>well
<paroneayea>looks like the emacs hackathon is tomorrow!
<paroneayea>so here I am, reading documentation on the guile compiler tower
<paroneayea>wow
<paroneayea>
<paroneayea>the "An Introduction to CPS" part of guile-next's manual is *really* nice
<paroneayea>nice job wingo!
<amz3>héllo :)
<burhanloey>hello
<wingo>tx paroneayea :)
<paroneayea>:)
<paroneayea>wingo: how do you feel about working towards merging bipt's emacs lisp enhancements into master?
<paroneayea>I might give a shot at it at the hackathon tonight
<wingo>i feel good about it :)
<paroneayea>though of course I'm totally naieve about this stuff
<paroneayea>but I did spend last night reading the docs and trying to read over the code
<wingo>i think that code needs a maintainer, and if you want to be that person (even if temporarily) that would be swell
<paroneayea>wingo: I'd *like* to learn to be that maintainer
<paroneayea>since I care a lot about the project
<paroneayea>though I'm going to ask a lot of dumb questions if I try
<wingo>please do ask the questions, happy to answer
<paroneayea>wingo: :)
<wingo>i was going to say that i was in a similar position with guile a few years ago (completely ignorant, grappling with someone else's code) but probably you're not as ignorant and also in your case you have someone to ask
<wingo>so it could go ok :) expect understanding to take a while, but it can come eventually
<wingo>*as ignorant as i was
<paroneayea>wingo: ha, you understimate the depths of my ignorance!
<paroneayea>but I will try
<paroneayea>wingo: there is one thing I should ask about immediately, since there are only two conflicts in merging the code, and only one of them is a real conflict
<paroneayea>wingo: oh wait I see part of it
<paroneayea>wingo: so you removed dead-slot-maps in assembler.scm and added slot-maps
<paroneayea>from death to life!
<wingo>:)
<wingo>actually it was related to unboxing
<wingo>used to be there was only one bit of information: live or dead
<wingo>now it's live scm, live unboxed, or dead
<wingo>er
<wingo>something like that
<paroneayea>wingo: ok cool
<paroneayea>so bipt added something new to the asm record
<paroneayea>which is to-file?
<paroneayea>"to-file?" I should say
<paroneayea>not a question on my part :)
<wingo>:)
<paroneayea>it looks like it's clear enough to me how to merge that though
<wingo>i was having problems with elisp recently incidentally
<paroneayea>I'll try it
<wingo>cross-compiling
<paroneayea>oh yeah?
<wingo>because by default elisp compiles everything
<paroneayea>yes I noticed that
<paroneayea>starting guile-emacs is sooooo sloooooooow right now
<wingo>but to boot it needs to eval...
<paroneayea>hm
<wingo>i wonder why it's slow
<paroneayea>wingo: it compiles every .el file
<wingo>anyway
<paroneayea>and doesn't save it
<paroneayea>so every start is a slow compile-geddon for now
<paroneayea>something which can be optimized I'm sure
<paroneayea>by simply actually compiling
<wingo>paroneayea: one quick way to speed things up would be to do the equivalent of -O0 fwiw
<paroneayea>(sorry, I didn't mean to interrupt)
<wingo>another would be to save the .go files
<paroneayea>wingo: oh, what does -O0 do?
<wingo>see scripts/compile.scm
<wingo>like -O0 versus -O2 when compiling c
<wingo>-O0 disables most optimizations
<wingo>anyway
<wingo>i wanted to get elisp to use an interpreter instead, when evaluating things at compile-time
<wingo>because it goes (or used to go?) elisp->tree-il
<wingo>and so you should be able to just interpret the tree-il
<wingo>by passing it to primitive-eval
<wingo>but i didn't manage to make it work; something about modules.
<wingo>anyway i shouldn't distract you, i think :)
<wingo>hehe, i should not answer questions with questions, that will not clarify anything :)
<paroneayea>no it's interesting
<paroneayea>wingo: let's see if this compiles
<paroneayea>I really don't want all of bipt's hard work to bitrot.
<wingo>yeah
<wingo>good luck, you are doing god's work ;-)
<paroneayea>lol