IRC channel logs

2016-03-03.log

back to list of logs

<Chaos`Eternal>helo guilers
<Chaos`Eternal>is there any solutions about pairing parenthesis automatically in REPL, just like paredit-mode in emacs
***mario-go` is now known as mario-goulart
***sbp_ is now known as sbp
***civodul changes topic to 'Welcome to #guile. See http://gnu.org/s/guile for more information. This channel is logged, see <https://gnunet.org/bot/log/guile>. Summer of code! https://libreplanet.org/wiki/Group:Guile/GSoC-2016'
<amz3`>héllo :)
<amz3`>feedback on my event loop would be very nice :)
***berndj-blackout is now known as berndj
<fhmgufs>Hello again. I've learned some Scheme now and want to use guile-gnome. :)
<fhmgufs>But how can I use these nice gobject generics?
<fhmgufs>In this example it fails: https://pastee.org/w7ef6
<fhmgufs>It works with the normal functions. But they are too normal. :)
<fhmgufs>It says: "In procedure append: Wrong type argument in position 1 (expecting empty list): #<<gtk-menu-bar> 112c8b0>"
<fhmgufs>I mean the append lines.
<amz3>fhmgufs guile-gnome doesn't seem like the more approachable library :)
<amz3>looking at your paste
<amz3>fhmgufs: append, is not list.append like in python, it takes two lists as argument
<amz3>for instance you can imagine the following run:
<amz3>scheme@(guile-user)> (append (list 1 2) (list 3 4))
<amz3>$1 = (1 2 3 4)
<amz3>if you want to create a list out of two items, you can do the simply:
<amz3>(list menu-bar file)
<fhmgufs>amz3: I know that.
<amz3>so what are you trying to do ?
<fhmgufs>So there's no gobject generic for the menushell append function of course.
<rain1>I didn't know guile gnome works
<rain1>I would like to try it
<fhmgufs>It works quit well, also for beginners.
<rain1>I was waiting for cairo?
<fhmgufs>I got it from git.
<rain1>i guess i didn't understand the situation
<rain1>ah
<fhmgufs>amz3: The docs said that there's a redefined function for each gobject method.
<fhmgufs>So I was searching for the append method of GtkMenuShell.
<fhmgufs>(the same as add for GtkContainer or show-all for GtkWidget in my paste.
<amz3>the name is probably not append.. but i don't know.
<amz3>where did you see the name append? GNOME documentation of guile-gnome's doc?
<fhmgufs>The GObject method is called append.
<amz3>from where? C API or Guile API?
<fhmgufs>The normal Guile GNOME function which I will use then is gtk-menu-shell-append.
<fhmgufs>:( It doesn't look well if I use generics for everything except from this one.
<fhmgufs>Maybe I'll just use the longer functions.
<rain1>how hard was it to install?
<fhmgufs>Easy.
<amz3>rain1: easy if you follow the instructions
<fhmgufs>Exactly.
<amz3>daviid: heya, we are talking, about guile-gnome.
<amz3>tldr: is there a method called `append` in guile-gnome?
<daviid>hello guilers
<daviid>amz3, cool
<fhmgufs>rain1: I built g_wrap first and then guile-cairo from git.
<rain1>ill try git clone, then guix environment guix
<rain1>./autogen.sh
<fhmgufs>daviid: So do you know an answer to my question? :)
<amz3>I don't think g-wrap was updated since I added it to guix
<daviid>fhmgufs: not sure :) what question?
<amz3>we could provide packages for guix for other components, I did not do it because there was patch :p #lazy
<rain1>would be so nice if there is guix package to just install guile-gnome it
<rain1>for the new version
<amz3>rain1: do it will review :)
<fhmgufs>daviid: These gobject generics having the same name like the GObject methods ...
<fhmgufs>I wanted to use append for GtkMenuShell.
<amz3>is there a append, method, I'm not sure never seen it
<fhmgufs>So they aren't available for all Objects?
<fhmgufs>Wouldn't be bad. But it looks inconsistent if I use them at one point and don't use them at an other point.
<fhmgufs>:)
<amz3>I'm looking the source of grip, clutter and gnome I don't find "define-method (append"
<daviid>fhmgufs: is this a gnome 2 method? we do not have binding for gnome 3
<fhmgufs>It's gnome 2.
<daviid>fhmgufs: do you have a minimal example ?
<rain1>got some errors with ./autogen.sh going to give up here
<fhmgufs>daviid: https://pastee.org/w7ef6
<fhmgufs>It works with gtk-menu-shell-append of course.
<amz3>rain1: paste the error please :)
<daviid>amz3 what are you looking for exactly?
<rain1> https://paste.debian.net/411490/
<rain1>but I think I'll rather wait for next release than debug this
<amz3>rain1: wait don't be lazy ;)
<fhmgufs>rain1: I didn't have this error. It's 30 min since I compiled it.
<daviid>rain1: this is an autotool problem, not guile-cairo
<amz3>rain1: do you have libtool?
<daviid>paste this to guix please
<amz3>installed
<rain1>i know
<daviid>fhmgufs: looking to your example, give me a sec
<amz3>has anyone, had a look at my event loop post on guile-user?
<rain1>I saw the post but not sure what event loop is
<amz3>I know it's fully OT, but zeronet is fully awesome too
<rain1>is it better than IPFS?
<amz3>rain1: it's mature!
<amz3>sorry
<amz3>at least it works shiny things
<amz3>s/works/show
<amz3>IPFS is just a tech a this point, zeronet provides a programming platform already used, there is already a lot of website
<amz3>s/website/apps
<janneke>i'm trying to create a patch for guile (master) but keep getting
<janneke> BOOTSTRAP GUILEC language/tree-il.go
<janneke>Warning: Unwind-only `stack-overflow' exception; skipping pre-unwind handler.
<janneke>
<janneke>any ideas?
<daviid>fhmgufs: your example was incomplete, but (append menu item) raises an exception indeed: not sure it s a bug due to the fact that append is a core procedure, wingo may have decided _not_ to make it a generic on purpose, will talk to him adn will let you know. so you have to use gtk-menu-shell-append for the time being. here is a working axemple based on yours ... http://paste.lisp.org/+6MCB
<fhmgufs>daviid: Thanks a lot. But what was wrong with my example?
<daviid>janneke: hello! I'm awfully sorry we never answered your 4 patches wrt guile-gnome gdk-event signals iirc! terrible! but I really really expected wingo to give an opinionated opinion about your patches...
<wingo>ACTION no time for guile-gnome these days
<daviid>fhmgufs: how about comparing and ansering yourself?
<daviid>wingo: I understand, but I meant 'I expected you to read', which does not take that much time, but I know, you already have days > 24h :)
<fhmgufs>daviid: I can't find any differences (Sorry :)). ??
<fhmgufs>And my example did work (with gtk-menu-shell-append).
<fhmgufs>But thanks anyway. ;)
<daviid>fhmgufs: ok, your welcome
<janneke>daviid: thanks for coming back to me!
<daviid>wingo: append is listed (3 methods) in guile-gnome's manual, and there is an example, gtk/examples/guile-gtk-demo/demos/menus.scm that uses it, so I guess it's a bug: do you have any ideia, intuition, what could have caused we 'lost along the way' (since when? guile-2 maybe? I don't know) append to become a generic?
<wingo>i think append is defined as a generic in (gnome generics) or something
<wingo>search for define-generic
<wingo>you have to import that particular module iirc
<daviid>wingo: ok thanks
<wingo>i don't have a checkout on this machine
<daviid>ah, will try, I thought the odule was imported reexrported, the example does iport it either ... but will try
<daviid>wingo: append is not defined in (gnome gobject generics): ... #:export (get set emit connect-after block unblock disconnect connected? invoke create-signal get-signals get-properties get-property-names find-property)
<daviid>where esle could it be defined, wonder?
<daviid>wingo: I see it has been overwritten for GtkListStore, in ./gtk/gnome/overrides/gtk.defs, for GtkListStore, GtkTreeStore, but not for GtkTreeStore, so I guess this is it
<daviid>oh ^^ I ment: it has not been overriden for GtkMenuShell
<cojy>is there a function to see how much time somethign takes to execute like (time ...) in racket?
<cojy>nice guile shift/reset absolutely destroyed racket
<cojy> https://paste.debian.net/411557/
<cojy>implemented some of Eff in guile here with shift/reset