IRC channel logs

2016-01-10.log

back to list of logs

<amz3>Héllo :)
<amz3>Today I'm diving into GOOPS!
<amz3>héllo daviid, I'm working on a goops tutorial, and I was wondering whether it's possible to retrieve arguments passed to make in initialize?
<daviid>amz3: the question is malformed: the user calls make, the 'protocol' calls initialize. users can, if they wish, when necessary, define initialize methods for their class, or any class by the way. there is no goops 'way to retreive...' because there is no need to, but you can peek [and parse] its args, like for any other procedures
<amz3>yes, I would like to avoid to peek and parse its args like a regular procedure call
<daviid>amz3: it's nice you want to write a tuto, but, you should really study first [I posted links here for you a while ago] _and_ write a couple of thousands lines of goops code, asking for review... imo
***jmd` is now known as jmd
<peterbrett>Hi all
<peterbrett>I'm having fun with MinGW32 building guile!
<peterbrett>Unfortunately, the build appears to be hanging
<peterbrett>It's stuck on GEN guile-procedures.texi, and I can't work out how to determine what's going wrong
<peterbrett>Is this a step that's expected to take 100+ minutes of CPU time?
<davexunit>peterbrett: no.
<peterbrett>davexunit: Okay, so that means something is definitely going wrong ;)
<davexunit>yeah, most likely. I'm not sure what that problem would be, though.
<peterbrett>Oh that's fun
<peterbrett>meta/guile is running itself in a loop
<peterbrett>It's an exec loop
<peterbrett>That seems easy to fix :)
<peterbrett>davexunit: Thank you for the rubber duck debugging assistance :)
<mark_weaver>peterbrett: iirc, GEN guile-procedures.texi is the first time that the guile executable is run, so problems with guile will often show up there.
<peterbrett>mark_weaver: It turned out that GUILE_FOR_BUILD was set to "guile"
<peterbrett>mark_weaver: Rather than the absolute path to my installed GUILE executable
<peterbrett>mark_weaver: I should probably submit a patch that makes configure whinge if GUILE_FOR_BUILD==guile
<peterbrett>...or at least a bug report :)
<mark_weaver>are you cross-compiling? fwiw, that might not work correctly unless the two versions of guile are identical.
<mark_weaver>(i.e. from the same version of the source code0
<mark_weaver>)
<peterbrett>Yes, I'm cross-compiling, and yes, I'm building 2.0.11 with 2.0.11
<mark_weaver>okay
<mark_weaver>sure, a sanity check to make sure GUILE_FOR_BUILD is an absolute path would be helpful I guess
<davexunit>peterbrett: glad you were able to find the culprit :)
<peterbrett>mark_weaver: Bug filed :)
<mark_weaver>peterbrett: thanks!
<wirrbel> (compile '(+ 32 10) #:to 'assembly) does not work on my guile repl
<wirrbel>ERROR: no such language assembly
<wirrbel>am I doing something wrong or does my guile installation not match the manual?
<mark_weaver>wirrbel: it sounds like it can't find its .go files. did you run "make" ?
<wirrbel>I have installed guile to /usr/local so I am not working in a dev installation
<mark_weaver>oh, are you using 2.1?
<wirrbel>it is a build off of 2.2
<wirrbel>from the repo
<wirrbel>using homebrew on macos
<wirrbel>as a package manager
<mark_weaver>the assembly language doesn't exist in 2.1
<wirrbel>there are .go files for languages elisp, ecmascript cps brainfuck bytecodescheme tree-il value
<mark_weaver>nevermind my earlier suggestion about .go files
<wirrbel>so it is compiled to bytecode directly?
<mark_weaver>scheme -> tree-il -> cps -> bytecode, iiuc
<mark_weaver>cps is the new analogue to assembly, with the continuations as labels
<wirrbel>if I (compile ... #:to 'cps) I cannot grok the result $1 = #<intmap 0-39>
<wirrbel>can it be pretty printed somehow?
<mark_weaver>sorry, I have to go afk
<mark_weaver>see section 9.4 of the manual
<mark_weaver>(intmap-fold-right acons <intmap> '()) may help
<mark_weaver>but to be honest I haven't been playing with this new intmap representation of cps. this is wingo's area.
<wirrbel>okay
<wirrbel>thank you
<mark_weaver>my focus has been elsewhere
<mark_weaver>okay, good luck!
<mark_weaver>the easier way to see what things compile to is to use the ,x REPL command on a compiled procedure.
<mark_weaver>e.g. (define (f x) (+ 32 x)) and then ",x f"
<mark_weaver>but I have to go