IRC channel logs

2015-12-26.log

back to list of logs

<cmhobbs>how can i check if two integers are equal? i'm trying to put together a simple even or odd scenario
<cmhobbs>ah, eq?
<mark_weaver>cmhobbs: use '=' to compare numbers for numerical equality
<mark_weaver>eq? means something else and probably doesn't do what you want for large integers
<mark_weaver>eqv? tests operational equivalence, which is meaningful for numbers but means something different than numerical equivalence, e.g. (eqv? 1 1.0) => #f
<amz3>héllo :)
<daviid`>hello guilers
<cmhobbs>daviid`, afternoon :D
<goglosh>is there a way of making syscalls from guile?
<wingo>goglosh: guile wraps posix; see the manual. but there's nothing like ljsyscall or some other generic syscall library
<wingo>ljsyscall in luajit is really nice :)
<goglosh>thx
<davexunit>wingo: I still have yet to try the new flonum optimizations in guile master, but does this code snippet look like something that can benefit from it?
<davexunit>I'm doing a lot of writing to f32 bytevectors
<davexunit>to dynamically fill OpenGL vertex buffers for moving sprites