IRC channel logs

2015-12-18.log

back to list of logs

<nalaginrut>morning guilers~
<CustosLimen>hi
<CustosLimen>anybody had time to look at fat_mutex bug yet ?
<mark_weaver>CustosLimen: I'm looking now. Thanks for the detailed report. I think your fix is not quite right, but you've helped me understand the problem and I'm working on a fix.
<mark_weaver>actually, your fix might be right.
<mark_weaver>if so, the code can be moved out of the outer 'if' as well, since the same code is in both branches.
<mark_weaver>t->block_asyncs-- should also be done before calling 'scm_syserror'
<CustosLimen>mark_weaver, I was unsure about that
<CustosLimen>the block asyncs
<CustosLimen>its rather complicated and probbably best not to rush applying fix upstream
<CustosLimen>but just want to know if there is something obviously wrong with patch
<mark_weaver>CustosLimen: no, I suspect your patch is good.
<mark_weaver>thanks!
<CustosLimen>ok no problem, thank you also
<ozzloy>paroneayea, wow, that's such a great idea! i like each sentence breaks and wraps
<civodul>Hello Guilers!
<frofroggy>Hello civodul!
<dsmith-work>Happy Friday, Guilers!!
<madsy>Happy Friday dsmith-work
<daviid>happy friday all!
<civodul>yeah, Happy Friday! :-D
<wingo>:-)
<paroneayea>happy friday indeed :)
<wleslie>Friday was pretty good, you'll enjoy this one.
<wleslie>Also Saturday morning is worth while.
<amz3>héllo
<paroneayea> http://stackoverflow.com/questions/34301050/how-do-i-format-the-digit-precision-of-my-repl-output-in-lisp/34301604#34301604
<paroneayea>neat that you can control pretty print in common lisp pretty printer
<paroneayea>based on dispatch
<guile-guest4>Hi, is there a built-in procedure like
<guile-guest4>(range 2 5) => (2 3 4 5)
<guile-guest4>?
<paroneayea>guile-guest4: (iota)
<guile-guest4>paroneayea: Thank you very much :)
<paroneayea>(use-modules (srfi srfi-1))
<paroneayea>(iota 4 2)
<paroneayea>(4 items, starting with 2)
<paroneayea>to make range, you could do
<paroneayea>scheme@(guile-user)> (define (range start end)
<paroneayea> (iota (+ 1 (- end start)) start))
<paroneayea>scheme@(guile-user)> (range 2 5)
<paroneayea>$6 = (2 3 4 5)
<guile-guest4>That's exactly what I need. Thanks again!
<linas>so .. is there some way to annotate a guile thread, so that I could give it some human readable name (and then display it)?
<linas>So (all-threads) just lists a bunch, but no clue as to which is which ...
<linas>what I really want is something like ps or top for guile threads
<civodul>at worst, you could always have a weak-key hash table that maps threads to names
<linas>thanks civodul Yes, I could hack something; I was wondering if maybe there was some under-documented feature I wasn't aware of.
<civodul>not that i know of
<linas>OK, next trick question: has anyone gotten guile to run on android?
<linas>Just daydreaming about porting my software stack ...
<davexunit>linas: no, but I would like that :)
<davexunit>I would like to open up the android terminal and open a guile repl :)
<linas>I looked at what it would take to port C/C++ to android, and after step 12 of installing IDE's my eyes glazed over
<linas>But still ...
<linas>Although, for my app, some rasberry-pi-ish type device is a more likely target.
<civodul>ISTR that beuc (former Savannah hacker) cross-built Guile for Android some time ago
<civodul>he reported a couple of bugs back then
<linas>!
<linas>very good
<civodul> https://lists.gnu.org/archive/html/guile-user/2014-06/msg00011.html
***__ransom__ is now known as ransom_