IRC channel logs

2015-11-14.log

back to list of logs

<mark_weaver>koz_: yes
<koz_>mark_weaver: And if I'm hashing numbers, should it be hashq or hashv?
<koz_>I assume hashv.
<davexunit>oh jeeze, just hearing the horrific news from paris. civodul doesn't live in paris, right?
<davexunit>:/ I hope civodul and family is okay
<madsy>davexunit: Horrible :/
<madsy>One would think the french had taken their share after the Charlie Hebdo attacks
<mark_weaver>koz_: for numbers, it has to be hashv, and that works for symbols as well.
<mark_weaver>bah, terrible news from Paris :-(
<koz_>Yeah, terrible news indeed.
<koz_>mark_weaver: But for symbols, hashq will be more efficient, right?
<mark_weaver>koz_: possibly, marginally so.
<mark_weaver>civodul works in Bordeaux, so I guess he's not too close to Paris.
<koz_>mark_weaver: I see, thanks.
<davexunit>mark_weaver: thanks
<davexunit>I couldn't remember where he was located.
<paroneayea>yeah, I hope ludo is ok
<koz_>I've just defined a module and loaded its file into the REPL, but I can't seem to play with its functions.
<koz_>(even the exported ones)
<paroneayea> https://www.youtube.com/watch?v=JUD_JwG0alg&index=12&list=PLXr4KViVC0qJAsNuDeQzhFDjMK1gEdls8 is an interesting talk
<paroneayea>basically argues that even though racket has so many sequence datastructures, almost everyone just uses linked lists because so many operations support them, even when other structures are clearly better
<paroneayea>and provides a library that has a unified API for many common sequence operations based off of clojure's similar library
<koz_>I've just defined a module and loaded its file into the REPL, but I can't seem to play with its functions.
<koz_>(even the exported ones)
<koz_>What do I need to do to make this possible?
<daviid>koz_: can you paste?
<daviid>do you use geiser?
<koz_>daviid: Yeah, I use Geiser, and I loaded the file with C-c C-b.
<daviid>could you try ,use (<module name>)
<daviid>if the path is in %load-path of course ...
<koz_>Works!
<koz_>Thanks for that.
<daviid>wc!
<koz_>Back to rewriting my tree structure as a state machine.
<daviid>koz_: i was curious, the ,use and ,friend commands do not depend on geiser, there are guile repl 'special' commands [see the manual for others...]
<koz_>daviid: As an Emacs user, I could hardly *not* use Geiser.
<koz_>It's pretty amazing.
<daviid>yes
<koz_>Also, Geiser is not responding too well to the vhash-cons* functions. I get this prompt in the minibuffer: ((ice-9 vlist):vhash-consv t-118636 t-118637 t-118638)
<koz_>What gives?
<koz_>Can I use vlist-append to combine two vhashes, and will that destroy their vhashness? Assume there are no overlapping keys.
<paroneayea>wingo: heya, you suggested I pass in a patch to the (make-promise) arity check thing
<paroneayea>so I did http://debbugs.gnu.org/cgi/bugreport.cgi?bug=21514#8
***heroux_ is now known as heroux
***cataska_ is now known as cataska
***healer` is now known as healer
***mario-go` is now known as mario-goulart
***sbp_ is now known as sbp
***ft_ is now known as ft
***add^__ is now known as add^_
<paroneayea>civodul!
<paroneayea>glad do see you're ok.
<paroneayea>er, glad to
<civodul>heh
<jralls>mark_weaver: There's an interesting problem with guild on OSX 10.11: Apple has this protection called SIP and it prevents passing DYLD_LIBRARY_PATH to subshells so guild can't link dependencies.
<jralls>mark_weaver: https://developer.apple.com/library/mac/documentation/Security/Conceptual/System_Integrity_Protection_Guide/RuntimeProtections/RuntimeProtections.html#//apple_ref/doc/uid/TP40016462-CH3-SW1
<jralls>mark_weaver: One work-around is to disable SIP. Another is to build bash and change guild's shebang.
<jralls>mark_weaver: Neither is especially palatable. Can you think of something better? Could Guild be converted to a proper executable?
<jralls>mark_weaver: Or made so that env guile is the shebang?
<taylan>is there a way to determine if a port is a void port?
<cpc26_>I think OSX as an OS is over and everything will be a "phone" soon. Guile _has_ to be Apple Store. Looks like sudo is disabled too. Definitely no access to system locals. http://devstreaming.apple.com/videos/wwdc/2015/706nu20qkag/706/706_security_and_your_apps.pdf
<holomorph>even our servers will be phones
<cpc26_>yeah, I need a new distro or better hardware - I like the keyboards and the use of natural materials. Dislike the company and OS.
<koz_>cpc26_: What do you mean by 'use of natural materials'?
<cpc26_>metal not plastic
<koz_>Ah, you mean 'use of non-petrochemical materials'.
<cpc26_>correct
<cpc26_>plus I like it when the battery does not feel like it will fall out
<koz_>Frankly, the way I see it, Apple has the blood of suicide victims on its hands.
<cpc26_>yeah, that too
<koz_>I know that the way these things are manufactured isn't good in general, but Apple leads the pack for horribleness in *that* department.
<koz_>Crapple's anti-GPL crusade is also quite morally off-putting IMHO.
<cpc26_>I agree Apple is horrible people
<cpc26_>I am throwing my mbp out today
<koz_>MBP?
<cpc26_>Mac Book Pro
<koz_>Ah. Good move.
<koz_>I'd sell it on to a Crapple cultist personally.
<koz_>But I'm me.
<cpc26_>yeah - would like to find something decent as I do use laptops
<koz_>cpc26_: Are you in need of extreme power, or would something more modest do?
<koz_>Also, where in the universe are you located?
<cpc26_>I dev so I need something decent but I go to desktop when I need real horsepower. I am in the USA
<koz_>Hmm. Seen this? https://shop.libiquity.com/product/taurinus-x200
<cpc26_>no and thanks!
<Petit_Dejeuner>"Crapple's anti-GPL crusade is also quite morally off-putting IMHO." I saw something about that the other day. The last paragraph of the "Why Do Corporations Support Open Source?" section in this. http://www.shenlanguage.org/lambdassociates/htdocs/blog/the_problems_of_open_source.htm
<koz_>Petit_Dejeuner: I love that your name literally means 'breakfast'.
<Petit_Dejeuner>"And as corporations encourage the development of these new liberal licenses, we find that Stallman is being exorcised as an aging hippy, not 'with it', an embarrassment, uncouth, and so on."
<Petit_Dejeuner>koz_: You're one of the few people to know that.
<Petit_Dejeuner>As opposed to a literal translation.
<koz_>Petit_Dejeuner: I learned French at high school, from a pretty good teacher.
<koz_>This particular rant is written by the same guy who tried to use the free release of the source of Shen as a hostage to make money.
<koz_>Nothing he says is either relevant or significant.
<koz_>Citing a lack of debate for being accused of being a troll is also hilarious beyond words.
<koz_>As far as I'm concerned, he's wilfully ignorant at best, a corporate asshole-licker at worst.
<koz_>Anyhow.
<Petit_Dejeuner>Oh, he
<Petit_Dejeuner>'s not against the GPL.
<koz_>He's against software freedom generally-speaking, by the sounds of it. :P
<Petit_Dejeuner>He's against open source and free software in general. The point I'm trying to make is that he's right about the anti-GPL crusade.
<koz_>Well, Crapple are pretty unique in being that thorough, and that targeted.
<koz_>I suspect it's because The Cult of Steve is upset that legally-speaking, RMS was right about GNUStep or whatever the fuck that thing nobody cares about was.
<koz_>They're not moving away from Objective C or pouring millions of dollars into Clang because they care about quality. :P
<koz_>(hell, I'm pretty sure the move of OS X towards POSIX compliance was an accident of theft)
<koz_>Also, if you guys had to implement a state machine in Guile, how would you go about it?
<koz_>Every time I try to do it, I seem to get tangled in my own code.
<Petit_Dejeuner>koz_: TCO?
<koz_>Petit_Dejeuner: That's not really something sensible. That's like answering the question 'How do I implement a state machine in C?' with 'iteration'.
<Petit_Dejeuner>I mean something like this. http://www.lua.org/pil/6.3.html
<davexunit>koz_: in some cases it can be modeled using mutually recursive procedures
<Petit_Dejeuner>^That's what I meant.
<koz_>davexunit: I've tried doing it using vhashes and assoc-lists, but in both cases, I ended up with a really wacky codebase that misbehaved severely.
<koz_>Whenever I run up against this in any Lisp, this is a sign that I haven't understood the problem properly.
<sea``>Define your state machine as a graph, pass that graph and the current state as inputs to a transition function that selects an edge returns the new state. Call this function repeatedly and you're done
<koz_>sea``: How would suggest I implement this graph in terms of Guile data structures?
<Petit_Dejeuner>koz_: I've just written a functional graph library.
<sea``>Either an adjacency list or an adjacency matrix, depending on the density of the graph
<koz_>Petit_Dejeuner: Link please?
<Petit_Dejeuner>Take note of the second line of the readme. https://github.com/Halfwake/fraph
<koz_>Petit_Dejeuner: Thanks!
<koz_>Inefficiency can be fixed, lol. :P
<Petit_Dejeuner>I think it would take a big rewrite to implement what sea`` mentioned.
<sea``>uhm you can do it in like 3 lines
<madsy>Petit_Dejeuner: Wow.. so many bogus claims and strawmen in that anti-FOSS rant
<koz_>madsy: Yeah, once again, the guy who wrote it is a bit of a derp.
<Petit_Dejeuner>sea``: I don't meant that it would be hard, but that I have so little code it would basically be a rewrite.
<madsy>And spelling "Microsoft" as "M$".. seriously? Who does that? :D
<koz_>Petit_Dejeuner: I think that was directed to me.
<Petit_Dejeuner>ah
<koz_>madsy: I am fond of 'Micro$atan' myself. :P
<koz_>I even made a logo: http://retro-freedom.nz/images/Micro$atan.png
<Petit_Dejeuner>µSoft
<koz_>Petit_Dejeuner: You mean µ$atan, no? :P
<Petit_Dejeuner>Sure, sure.
<koz_>But then again, I've made parody logos of a lot of organizations I dislike.
<koz_>(Crapple is still missing one, because I suck at design)
<koz_>Well, organizations and tools.
<koz_>Also, would anyone have any clue as to why my Geiser seems to assume my Guile code is Chicken code sometimes?