IRC channel logs

2015-08-29.log

back to list of logs

<paron_remote>hello all!
<paron_remote> https://vanemden.wordpress.com/2014/06/18/how-recursion-got-into-programming-a-comedy-of-errors-3/ fascinating article btw
<paron_remote>also, something surprising to me, but maybe to nobody else
<paron_remote>(match 22 ((= (lambda (x) (* x 2)) (? number? x)) x))
<paron_remote>this works, but it's so weird to me
<paron_remote>that the inner x gets defined to the outer =
<paron_remote>works as in, returns 44
<wleslie>static allocation of activation records
<wleslie>that would be an awful language
<paron_remote>wleslie: as in, current behavior makes sense and otherwise would be bad? :)
<paron_remote>wleslie: I think this is probably true but my brain still has a hard time accepting this statement above as making sense
<wleslie>just one more thing I'm glad I don't have to think about
<paron_remote>wleslie: ?
<wleslie>that I can call a function while it is being called
<wleslie>there are a few non-reentrant functions in libc but they are of limited utility
<paron_remote>ACTION is lost, but it is probably my own fault
<wleslie>can you imagine a language where recursion isn't possible, not even if you pass the function as an argument to something else?
<paron_remote>oh
<paron_remote>wleslie: you're talking about the recursion link :)
<paron_remote>wleslie: I thought you were talking about my match example!
<paron_remote>okay, yes, that makes sense now, whew!
<paron_remote>oh right
<paron_remote>the pattern matching flows in revese
<paron_remote>aways hard for me to wrap my head around
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<ArneBab>paroneayea: thank you for the recursion link!
<ArneBab>it was a very interesting read
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<paron_remote>ACTION trying to implement this algorithm from scratch
<paron_remote>I'm probably getting a lot wrong
<paron_remote>I've never just implemented an algorithm out of a spec before
<daviid>it would be nice if someone knowledgeable could update our webpages 'à la Guix'
<civodul>agreed
<civodul>we could ask Guix's web designer
<daviid>that would be really nice indeed
<daviid>civodul: I released guile-gnome while your were drinking wine at the beach :)
<civodul>oooh, nice!
<civodul>congrats on that!
<daviid> https://lists.gnu.org/archive/html/guile-gtk-general/2015-08/msg00000.html
<daviid>thanks
<civodul>good work
<civodul>we need Guix packages now ;-)
<daviid>I am now working on a guile-clutter release, getting very close [I drastically improved guile-clutter configure steps as well]
<daviid>yes, I did ask here already
<daviid> https://lists.gnu.org/archive/html/guile-gtk-general/2015-08/msg00002.html
<daviid>civodul: a guix guile-gnome package would really be nice, we'll get there. I'm of course also interested to learn/use/package myself for guix and guixsd if possible on my laptop [I doubt right now, wifi, i5, ...] but i follow my plan to get gule-gnome and guile-clutter on their feet :)
<paron_remote>daviid: civodul: he offered
<paron_remote>to update the guile website
<paron_remote>however then I think he started to look if there was some friendly intro to guile itself he could follow along with, and that's the last I heard him mention of it...
<daviid>mark_weaver: could you, maybe, look at Jan Nieuwenhuizen patches and give me some feedback? I see you pushed one of his previous patch ... and I cold do with some code review, I really want to concentrate on guile-clutter now
<daviid>paron_remote: fantastic!
<paron_remote>he even put together some really cool looking logos
<paron_remote>however, I'm not at my home computer
<paron_remote>so I can't pull up the logs
<daviid>paron_remote: later send a link, i'd like to look at them
<daviid>let's teach him guile then! :)
<paron_remote>civodul: maybe if you sent an email saying you heard he was interested and that got you excited, that might incentivize further working on the site?
<daviid>do we not have a good intro somewhere? surely there are some somewhere
<daviid>mark_weaver: sorry to annoy you with this, but if you are willing to look at and help, here: https://lists.gnu.org/archive/html/guile-gtk-general/2014-07/msg00000.html
<paron_remote>daviid: I really think there isn't a simple starting point for guile, I gave my best "starting advice" here: https://www.reddit.com/r/guile/comments/3fb3um/need_help_learning_gnu_guile_and_gnu_guix/
<paron_remote>and I think we can do better
<daviid> https://www.gnu.org/software/guile/docs/master/guile-tut.html/index.html#Top
<paron_remote>daviid: that tutorial assumes a lot of the process of getting comfortable in a scheme'y language will happen elsewhere
<daviid>ok, I'm not very good at this, but we should try to get this webdesigner to redo our guile webpages :) he's good
<daviid>we'll become famous! I just found a bug in clutter itself, working on our binding for 1.12.2 :), a bug which is in clutter up to their master branch! it took me 2 days to convince them, since the first reaction is "something is wrong with your binding, I don't know what and I am not interested in knowing, I can't read lsip anyway ... "
<civodul>heh
<civodul>ACTION discovers http://www.wedesoft.de/aiscm/
<civodul>pretty wild stuff
<daviid>cool stuff indeed, i'll look deeper when ni can
<daviid>and it uses goops, clever guy :)
<taylanub>'(guard (x (else #t #t)) #f)' results in the compile error 'cond: else must be the last clause in subform (else #t #t) of (cond (else #t #t) (else (re-raise)))' and I can't figure out where in Guile's sources this happens. I searched the whole 2.0.11 tree for "re-raise" and it only occurs twice in a comment
<taylanub>to clarify: that's a bug; it chokes when the else of a guard has more than one expression. (rnrs exceptions) BTW