IRC channel logs

2015-08-28.log

back to list of logs

***dmiles_akf is now known as dmiles
<daviid>weird! within the core of a method, this works
<daviid> (receive (child tvals)
<daviid> (clue-grid-make-child child-bg child-fg)
<daviid> (add-child grid child 0 0 1 1)
<daviid> (clue-grid-child-text-changed-callback child tvals))
<daviid>
<daviid>where clue-grid-make-child returns (values an-actor a-cutter-text)
<daviid>but if I change that to return (list an-actor a-cutter-text) and use match like this:
<daviid> (match (clue-grid-make-child child-bg child-fg)
<daviid> ((child tvals)
<daviid> (add-child grid child 0 0 1 1)
<daviid> (clue-grid-child-text-changed-callback child tvals)))
<daviid>
<daviid>it fails:
<daviid>No applicable method for #<<generic> attach (1)> in call (attach #<<clutter-grid-layout> 4334720> (#<<clutter-actor> 41156c0> #<<clutter-text> 4115060>) 1 0 1 1)
<daviid>as if in the match version, child was bound to (list an-actor a-cutter-text) and not an-actor
<daviid>but if I (pk child) (pk tvals) before calling (attach ...) I get the correct answer
<daviid>;; #<<clutter-actor> 43d4c60>
<daviid>;; #<<clutter-text> 43d4680>
<daviid>
<daviid>I'll use receive for now, but I really wonder what's happening here
<nalaginrut>morning guilers~
<wleslie>morning Alan
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
<daviid>happy friday!
<taylanub>happy friday :)
<taylanub>ACTION needs a way to debug syntax-case macros...
<taylanub>oh, I found the bug pretty quickly after all. gotta love (relatively) clean code.
<dsmith-work>Happy Friday, Guilers!!
<OrangeShark>happy friday!
***michel_mno is now known as michel_mno_afk
<dsmith-work>Wooo. 94 people in the channel. A new record?
***cluck`` is now known as cluck
<taylanub>ACTION did a huuuge overhaul: https://github.com/taylanub/scheme-bytestructures much simplified API
<taylanub>now it should actually be possible to read the README without being driven mad at the complexity :P
<taylanub>I'll write a test suite and once I'm done I'll announce this on the ML I guess. it was no good two years ago but after adding the macro API and especially after this vast simplification of the design I'm very happy over it.