IRC channel logs

2015-07-22.log

back to list of logs

<civodul>daviid: you need to be admin of the project and to log-in on Savannah
<civodul>from there there are several menus
<daviid>civodul: ah ok, I am a member but not an admin
<daviid>rlb: you're a g-wrap admin, can you add myself as an admin maybe?
<daviid>rotty1: ^^ you too coiuld add me I suppose
<rotty1>sneek: later tell daviid are you tupi @ savannah?
<sneek>Got it.
***michel_mno_afk is now known as michel_mno
<amz3>héllo :)
<civodul>the new Guix is here! https://news.ycombinator.com/item?id=9928563
<amz3>how can I do something like alist-ref ?
<amz3>assoc!
<amz3>assoc-ref to be exact
<tohoyn_>hello
<tohoyn_>I get the following results:
<tohoyn_>scheme@(guile-user)> (atan (tan -0.5+2.0i))
<tohoyn_>$1 = 1.070796326794897+1.9999999999999996i
<tohoyn_>scheme@(guile-user)> (tan (atan -0.5+2.0i))
<tohoyn_>$2 = 0.1176470588235294+0.4705882352941177i
<tohoyn_>is there something wrong here?
<amz3>heya davexunit ;)
<davexunit>hey there
<dsmith-work>Wednesday Greetings, Guilers
<amz3>greethings :)
<stis>heya guilers!
<amz3>hey stis
<amz3>I did a few babysteps with building a markdown parser using guile-log, the code is https://github.com/amirouche/artanis-website
<amz3>it's a poc for artanis website
<amz3>"poc" or wip
<amz3>if the guile-log fails to build on prolog things it's ok you can still `make build` and `make serve`
<amz3>next parser will be for wikipedia I guess :)
<stis>amz3: I plan to make it possible to decide in ./configure what to get.
<stis>e.g. prolog or not cause it is heavy
<amz3>IIRC a file is missing in git
<stis>Oh is it in the earlier checkout you did or where I work at the head?
<nalaginrut>davexunit: I've heard that you want to wrap markdown parser with FFI rather than write a new one in Scheme? ;-)
<davexunit>nalaginrut: I want a pure Sheme one ultimately
<davexunit>but I want to quickly wrap the hoedown library with the FFI
<davexunit>and have *something*
<nalaginrut>alright, we may have a pure Scheme one later ;-P
<nalaginrut>I spend all my hack power on async server core, or I can write a buggy one quickly
<davexunit>pure scheme would be most flexible, but slower.
<davexunit>at least if I were to implement it. :)
<stis>is the parser the speed limiter?
<nalaginrut>davexunit: come on, efficiency is not necessary for a static-page-generator
<nalaginrut>please don't worry about it
<nalaginrut>if not too slow to generate a page in whole night...
<davexunit>I sound like a broken record at this point, but I want to implement it using parser combinators where the input characters are represented as a SRFI-41 stream
<davexunit>using port->stream
<davexunit>I just devote all of my time to guix so it never happens.
<stis>do the parser combinators ontop of minikanren no?
<nalaginrut>davexunit: amz3 has written a markdown parser with guile-log, maybe you want to take a look
<nalaginrut>amz3: is that you, right? ;-)
<davexunit>stis: I want 0 external dependencies and to do them in a monadic style
<davexunit>I have a un-version controlled scheme file sitting on one of my computers that does it, more or less.
<stis>ok
<davexunit>I'm also not confident working in the relational paradigm yet
<davexunit>gotta work through "the reasoned schemer"
<stis>minikanren is really small, you can include it in your sources and get 0 dependencies
<davexunit>I'm not a fan of bundling
<davexunit>I don't think relational programming is necessary here.
<davexunit>the implementation with monads is very nice.
<nalaginrut>IMO, we can rewrite many thing in modern way and Guile's cool stuffs, so if any possible, I don't want to introduce any unmaintained lib too...
<dmiles_afk>in some uses of guile-log are people not using the prolog syntax exension?
<stis>well it gives you backtracking
<dmiles_afk>(that is they want to work in S-expr)
<stis>dmiles_afk: yes, I would say that people knows mostly scheme here and prefere kanren over prolog
<dmiles_afk>makes sense.. sometimes i prefer scheme syntax
<davexunit>stis: is there a distinct advantage? my parser combinator implementation is LL, which I guess means that it doesn't handle left-recursive grammars. would using relational programming make it easy to write a GLL parser that can handle left-recursive grammars?
<davexunit>that would be a selling point to me.
<stis>davexunit: let us refhash this as f -> f g no?
<davexunit>I don't follow.
<dmiles_afk>opencog uses guile as their default scheme right?
<stis>parsing f is like parsing m or parsing f then g
<davexunit>okay
<davexunit>or rather: parsing f means parsing f OR g
<davexunit>in my libary: 'f -> g f' is fine
<davexunit>'f -> f g' is an unbounded loop
<davexunit>or rather unbounded recursion
<stis>that's inherent in the functional meaning of these parsers no?
<davexunit>I'd like to stop the recursion of f if g can be parsed
<davexunit>I've seen an implementation of GLL in racket but I haven't fully grokked it
<davexunit>lots of continuations
<davexunit>btw, guix 0.8.3 was released today. upvote on HN if you have an account :) https://news.ycombinator.com/item?id=9929809
<davexunit>(shameless-plug "guix-0.8.3")
<stis>davexunit: cool!
<davexunit>=> #t
<stis>davexunit: why is it so important to have left recurrsiveness, can you examplify
<davexunit>I haven't fully grokked it yet, honestly, and I need to refresh my memory about this stuff.
<stis>If your mind is wired in thinking in parser combinators I don't see a left recursive feature as especially important. But maybe i'm wrong.
<davexunit>maybe it's not
<stis>I written a prolog parser and a python parser. I really didn't have any problems with left recursiveness.
<davexunit>I have more to learn, which begs the question if I should be the one writing a parser combinator library ;)
<stis>I actually postulate that you will be aböe to get a "left recursive free" parser spec for almost any language out there if you search.
<davexunit>yeah, it could very well be not worth pursuing.
<davexunit>maybe I should just dump my parser combinator module on guile-user and look for critiques
<stis>davexunit: that's a good idea, also you are right about a 0 dependency for this framework is a good idea.
<stis>I just wish that kanren was included in guile.
<dmiles_afk>is there a version of non minikanren in scheme?
<dmiles_afk>(that is like full kanren)
<stis>I have made the original kanren sources work on guile. And iI think we have a kanren in guild-hall, just that I don't know if it is minikanren or full kanren
<stis>guile-log pretty much sports a kanren interface as well
<dmiles_afk>too bad SF is down with http://kanren.sourceforge.net/
<dmiles_afk>(that one is supposed to be full.. was the version you ported in CHICKEN scheme?)
<dmiles_afk>(if so.. then its full)
<stis>it was a long time ... let me check
<stis>dmiles_afk: no I lost it in the last upgrade of my computer
<stis>but I think I remember that it was the full version
<dmiles_afk>i understand.. i have lost things that took me sooo long to create.. one such loss was a codemerge of EcoLisp and SWI-prolog
<dmiles_afk>(so there was no datatype conversion when being called from one or the otehr)
<dmiles_afk>secretly i need to understand why everyone only uses miniKanren
<stis>dmiles_afk: I based my interface on the that kanren source code
<stis> http://www.cs.indiana.edu/l/www/classes/c311/a13/kanren.ss should be the same kanren
<dmiles_afk>good i was hoping :P
<dmiles_afk>hoping just now that most of this time you'd been thinking about kanren vars and such in guile-log you hadnt been religated to the miniKanren-only world.. but are mentally in the full kanren without saying
<dmiles_afk>(not that i know the differnce)
<stis>well I think that full kanren and minikanren uses the same kind of variabling
<stis>an assoc list
<stis>but yes I am living in the full kanren world
<stis>I referred to minikanren because of the size of that codebase and perhaps also that it might be in pubklic domain
<stis>not sure about those things.
<stis>ok got to go CU hackers.
<daviid>hello guilers
<sneek>Welcome back daviid, you have 1 message.
<sneek>daviid, rotty1 says: are you tupi @ savannah?
<daviid>got it
<daviid>rotty1: yes i am, and speaking of it, I would like to change my savannah login for daviid, did try but didn't find how to do it :)
<rotty1>daviid: I suspect your username is immutable
<daviid>yeah, i just came accross http://savannah.gnu.org/maintenance/RenamingAccounts/, nothing was done yet to solve this small problem ...
<daviid>just asked on #savannah, but no answer
<rotty1>daviid: I now made you an admin on g-wrap
<daviid>rotty1: thank you
<rotty1>daviid: thank you for putting out a g-wrap release :-)
<daviid>wc! i'm working on a guile-gnome release now, then guile-clutter
<daviid>i'd like to split these on savannah as well, because they are really 2 different beasts
<daviid>rotty1: are you still working on sbank?
<daviid>rotty1: I did see variaous guile gir projects, 2 or 3, can't remember, I wonder what would be the best one to pick and start to work on, what is your idea?
<rotty1>daviid: I don't know the current state of the "competitors" for sbank (my own spin at it). sbank is/was running quite nicely on Racket, but Guile's missing some basic functionality -- mostly the dynamic-link deficiency due to the libltdl brokenness recently discussed on guile-devel
<daviid>rotty1: nothing could be done to overcome this [filename w/wo extension iirc] problem? is that why you stopped? [like I wouldn't be able to solve it either then]
<rotty1>rotty1: (working on sbank) not ATM, but getting Guile up to speed wrt. (spells foreign) is still on my TODO list. The probably not-so-great thing about sbank from a Guile perspective is that it depends on quite a few libraries not part of Guile.
<daviid>rotty1: just added and posted a news item for g-wrap, but it says 'A news manager of this project will have to review and approve the news.', are you the news manager ? [can't see anything about that]
<rotty1>hmm, I'll check
<davexunit>what is sbank?
<daviid>davexunit: guile gir binding
<daviid>written by rotty1
<daviid>davexunit: https://wiki.gnome.org/Projects/GObjectIntrospection/Users
<daviid>can't access guile-gir: 'Gitorious.org is migrating all the repositories to Internet Archive. The repositories will soon be available for read-only access, with original clone URLs preserved.' but it's been ages they display this message and nothing is becoming available ...
<daviid>rotty1: sbank was started before guile-gir, I think, but did you looked at it maybe?
<rotty1>daviid: no, but I probably should
<rotty1>(I've been having a mostly hack-less last two years, and am just now beginning to pick up speed again)
<daviid>rotty1: I understand. well for the time being guile-git is unavailable anyway
<rotty1>In theory, all that is required to get sbank running on Guile is implementing (spells foreign) and (spells gc), IIRC
<daviid>Ok. I did not looked at sbank yet though, and from what you said earlier, if it depens on quite a few other lib not available in guile, maybe I would not be 'so much' interested :) don't know yet
<daviid>s/depens/depends
<daviid>right now i want to get guile-gnome 2.16.3 out, then guile-clutter 1.12.2, then I should try to work on more recent clutter version
<daviid>rotty1: i'd like to split guile-gnome and guile-clutter at savannah, the savannah main page, git repo, homepage and documentation: what should I do, fill a new project request ?
<daviid>sneek: seen wingo?
<sneek>I last saw wingo on Jun 24 at 08:05 pm UTC, saying: and how long prerelease will take, no idear.
<davexunit>wingo's been gone for awhile
<daviid>davexunit: on holiday maybe
<rotty1>daviid: well these other libraries work on Guile, there just not neatly packaged
<daviid>rotty1: ok.
<rotty1>(they are available as dorodango packages, but I really need to set up a dorodango repo, work on the documentation)
<daviid>oh rotty1 by the way: guile-lib does not seem to have a pc file, would like to add me as a guile-lib member I could try to add this, it would be nice because of g-wrap, guile-gnome[clutter] dedpend on it and there is currently no way to check for the version number
<daviid>rotty1: you mean an sbank [and dependencies] guild-hall package(s)?
<daviid>rotty1: still no g-wrap news item, did you find out who the moderator?
<daviid>we need to fix goops, if andy remains unavalaible for much longer [hope not!]
<daviid>ACTION has always wanted to fix and maintain goops, oh well so much to do
<daviid>rotty1: I know you're a goops pretty good user, are you also aware of its implementation?
<rotty1>daviid: not really; it's been a long time, and I did not really look into goops itself, although I played around a bit with tinyclos
<daviid>ok
<rotty1>daviid: I also get the message "only news manager can approve news". Probably some obscure permission setting...
<rotty1>daviid: you're now a member of guile-lib
<daviid>oh weird isn't it? #savannah doesn't answer any quizz either
<daviid>rotty1: ah, many thanks! will work on a .pc file soon
<rotty1>cool
<civodul>daviid: BTW, congrats on the new G-Wrap release!
<daviid>civodul: thank you! same for guix, amazing work!
<daviid>civodul: do you know who's moderating 'news' entries, per project, on savannah?
<civodul>sneek: later tell daviid news entries are moderated by each project's admins
<sneek>Okay.