IRC channel logs

2015-07-19.log

back to list of logs

<paroneayea>o/
<zacts>hi
<paroneayea> http://the-little-prover.github.io/
<paroneayea>and here's the source https://github.com/the-little-prover/j-bob
<zacts>hm... I have a note to leave for davexunit on the J-Bob scheme files for The Little Prover
<zacts>and anyone else who may be reading the book
<zacts>can the bot here do this?
<zacts>I want to tell davexunit that if he want's to use j-bob with guile, to _only_ load j-bob.scm, and not the other two scheme files
<zacts>if you load all of the scheme files at once little-prover.scm will conflict and cause your (J-Bob/step) procedure calls to never return or complete
<zacts>I even did ,trace on this
<zacts>it ends up in an infinite loop / tail recursion
<zacts>but (load "j-bob.scm") is all you need, and it should work fine
<zacts>just fyi
<artyom-poptsov>zacts: Hi. You could tell sneek bot to pass a message to another person like this: "sneek: later tell <nickname>: <message>"
<amz3>héllo :)
<please_help>what's the right way to do O(1) in-order traversal in an arbitrary-arity tree?
<please_help>does cps with brothers/children and chaining even work? Doesn't seem too O(1).
<please_help>actually, is it even sensible to expect O(1)?
<jmd>"O(1) traversal" sounds like a contradiction to me.
<davexunit>I don't really know exactly what's being asked for, but when I think about a tree, I think logarithmic time complexity.
<please_help>O(1) in the sense of space, not time
<mark_weaver>please_help: there are no pointers from children to parents, so you need space proportional to the depth of the tree.
<mark_weaver>I don't see how that can be avoided, in any programming language.
<please_help>mark_weaver: there is the trivial solution of making K passes and marking how many children were visited in fields of the nodes
<mark_weaver>please_help: well, okay, then you are just moving the storage to the nodes, basically giving the algorithm O(N) space.
<mark_weaver>but sure, you can do that in scheme too if you want
<mark_weaver>of course, one must be careful not to be running more than one traversal of the tree (or shared subtree) simultaneously.
<mark_weaver>(and that issue can arise in a single-threaded program, via recursion)
<zacts>sneek: later tell davexunit: check the backlogs I left you a message about how to avoid an issue with J-Bob, the little prover assistant .scm code
<sneek>Okay.
<zacts>sneek: later tell davexunit: this would have been at around 03:20 AM Eastern Time in the USA
<sneek>Okay.
<paroneayea>zacts: cool to hear/know
<paroneayea>sneek: later tell davexunit: http://games.greggman.com/game/programming_m_c__kids/ article you might find interesting, for Sly reasons and etc
<sneek>Will do.