IRC channel logs

2015-07-02.log

back to list of logs

***karswell` is now known as karswell
<nalaginrut>morning guilers~
<sneek>nalaginrut, you have 1 message.
<sneek>nalaginrut, ArneBab says: related: Springfield Javascript Framework Repository: https://twitter.com/thesifter/status/611253413578326017 — so many people trying to find the easy answer
<nalaginrut>ArneBab_: frankly, I believe JS&Java framework is excessive, and many guys are still trying to write new one
<nalaginrut>IMO, it's so easy to reuse other frameworks, so people can write new one quickly
<nalaginrut>for Scheme, write a new and productive one is not so easy ;-(
<ArneBab_>nalaginrut: I think there are many, many people writing JS or Java, and they invest huge amounts of time into finding a better way to do something (and using that to implement the next thing they get paid for). And they are racing all the time to get a competitive advantage over each other, so there’s a big pressure to adopt the next big thing.
<ArneBab_>but that’s mostly an outside observation…
<nalaginrut>well, that's why I plan to write Artanis as monolithic architecture, since we have few choices in Scheme...
<ArneBab_>nalaginrut: I’d say just do it as it feels right. The paradigm to use will change every few years anyway.
<nalaginrut>if I have to write many things to meet the needs, why not write them all in one
<nalaginrut>although microservices architecture is popular these days
<nalaginrut>well, different languages face different situations
*nalaginrut just follow his heart...
<adhoc>nalaginrut: thats a tricky thing
<adhoc>an example of this in the recent past in the Perl world is Catalyst
<adhoc>its a web framework, and now days, a very large one
<adhoc>it has a package list of dependencies numbering more than 500 ...
<adhoc>one of the core devs broke off and started writing a replacement, that had *no* external dependencies
***michel_mno_afk is now known as michel_mno
<nalaginrut>adhoc: well, Artanis won't have too many dependencies, but its plugins could be so, anyway, depends on users...
<nalaginrut>and all the core part will in itself
<adhoc>its an interesting balance
<adhoc>being self contained means that you need to provide *all* the plugins and interfaces for all the likely things
<adhoc>and that is a whole lot of wor
<adhoc>so balance ...
<nalaginrut>well, don't expect it too perfect, there'll be compromise, definitely IMO
<adhoc>the main issue was, that the catalyst stack stagnated because it was too big and depended on too many external packages.
<adhoc>was the main reason folks split off into other projects
<adhoc>we use catalyst at work, its large, but it does alot and we can plmub into many external back end DBs, etc
<adhoc>but we also use Mojolicious, for small things
<adhoc>we never really found a web framework in the middle
<adhoc>nalaginrut: plugins are always a path to that balance, providing those APIs
<nalaginrut>adhoc: yeah, there'll be, maybe Artanis-0.3
<adhoc>i have some free time now that winter is upon us
<adhoc>you have a repo for artanis ?
<nalaginrut>adhoc: web-artanis.com
<nalaginrut>oh, the winter is coming? ;-)
<adhoc>well, yes, but it *is* winter *here*
<adhoc>so, i have time to do my own stuff =)
<nalaginrut>cool, you can stay at home when it's winter?
<adhoc>no, but i get nights and weekend off ;)
<adhoc>its not like we get snow or anything
<adhoc>its just wet and cold =P
<adhoc>i've been finishing of some projects
<adhoc>a whole lot more to go, but one is replace the web server at home
<adhoc>and maybe even replace wordpress with something nice =D
<nalaginrut>happy hacking ;-)
<adhoc>ta
<lloda>I have (readline-set! history-length 50000), but my .guile_history is being cut at < 300 lines every time I exit Guile. What am I doing wrong?
<lloda>I can't see anywhere in the Guile source where history-length is actually used :-/
<lloda>oh, scm_readline_opts[1].val
<civodul>sneek: seen wingo
<sneek>wingo was here Jun 24 at 08:05 pm UTC, saying: and how long prerelease will take, no idear.
<lloda>so apparently the history is being stifled at the default 200 when I import (ice-9 readline), and THEN when I set (readline-set! history-length 50000) it's stifled again uselessly to 50000. I think this is a bug.
<civodul>uh, sounds like it
<adhoc> ah, how do you get readline support working ?
<civodul>(use-modules (ice-9 readline)) (activate-readline)
<adhoc>excellent!
<lloda>so civodul how to fix it? I'm unfamiliar with this options interface
<adhoc>50,000 line is a lot
<madmuppet006>I have tried installing guile 2.0.11 on debian jessie .. after installing all the dependencies I have tried ./configure sudo make and sudo make install .. when I try to use guile on emacs I get an error message /usr/local/bin/guile: error while loading shared libraries: libguile-2.0.so.22: cannot open shared object file: No such file or directory and Process scheme exited abnormally with code 127 .. I have checked the /usr/local/bin/
<madmuppet006>and guile is there .. trying ./guile from that directory also results in the same error .. any help appreciated
<madmuppet006>
<madmuppet006>
<mark_weaver>madmuppet006: first of all, you shouldn't "sudo make", just "make".
<mark_weaver>what do you mean "use guile on emacs" ?
<madmuppet006>ctrl-u ctrl-x run-scheme -> guile
<mark_weaver>okay.
<mark_weaver>do you have guile installed from the Debian package as well?
<madmuppet006>no but I can do
<mark_weaver>jessie already has guile 2.0.11
<mark_weaver>at this point, if I were you, I would "sudo make uninstall" and "apt-get install guile-2.0 guile-2.0-dev"
<madmuppet006>lol there ya go .. thanks
<mark_weaver>oh, and you should install guile-2.0-doc as well
<mark_weaver>happy hacking!
<madmuppet006>thanks very much .. appreciate the help
<mark_weaver>np!
<mark_weaver>btw, as a general rule, there's no good reason to run "make" as root.
<mark_weaver>(for almost any piece of software)
<madmuppet006>may have tried it with root after no result without it .. tried looking for an answer online but google gave me lots of unrelated results
<mark_weaver>do you remember what software that happened with?
<mark_weaver>(curious)
<madmuppet006>I downloaded the source for guile installed all the dependencies in the readme and then ./configure make and make install .. emacs gave me an error and the console gave the same error
<mark_weaver>oh, this happened with guile?
<mark_weaver>what was the error?
<madmuppet006>yeah uhm /usr/local/bin/guile: error while
<mark_weaver>oh, I'm sorry, I was asking about what went wrong running "make" as your normal user.
<mark_weaver>anyway, it's not important.
<madmuppet006>sorry no it ran fine .. it was when I tried to run guile and it didnt run I tried again .. removed all files and repeated with sudo make instead
<mark_weaver>oh, I see.
<mark_weaver>thanks
<madmuppet006>only tried installing the source because last time I installed guile it was a later version than what was available in the source list
<madmuppet006>its all good now .. thanks again
<mark_weaver>you're welcome. happy hacking!
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
<davexunit>someone wrote guile bindings for a markdown library: https://github.com/greghull/sundown-guile
<davexunit>needs some work, though. no configure script or autotools files, use of C instead of FFI, etc.
<davexunit>btw, the new SRFI mantainer plans to use GitHub as the place for code review and hosting. this is obviously not good. what can we do?
<mark_weaver>bah
<davexunit>I was considering chiming in on the mailing list, but I haven't contributed to SRFI.
<davexunit>so I would prefer if someone with more weight that also thought this was bad would speak up about it.
<mark_weaver>is it arthur geckler?
<davexunit>mark_weaver: yes
<davexunit>srfi@speechcode.com was the email address used. the mail was sent to srfi-announce, which appears to have no public log that I can see.
<mark_weaver>I think Arthur probably has a negative opinion of me, based on the whole ruckus I caused over eqv? in R7RS :-(
<taylanub>wasn't it impossible to implement memoization otherwise? in that case that would be a very necessary ruckus... unless the other side had some rationale of their own for their semantics?
<mark_weaver>yes to the first question
<ArneBab_>what would be an alternative proposal?
<ArneBab_>I don’t like git, but I did use a version tracking tool (Mercurial) locally to improve the documents.
<ArneBab_>I don’t think we can request that they host writeable repos themselves, since the goal is to reduce the workload.
<ArneBab_>(though using git might not be the best tool for that…)
<ArneBab_>for argumentation: if pull-requests are used, that pulls the discussion away from srfi.schemers.org, which in turn means that when github goes broke or evil, these discussions will be lost.
<davexunit>git is fine, github is not.
<davexunit>because those of us that work on free software implementations of SRFIs will have to use proprietary software for certain interaction
<davexunit>s
<ArneBab_>does anyone want to be BCC on the mail I just wrote to Arthur Gleckler?
<ArneBab_>(please send me a msg)
<ArneBab_>I’ll still wait 15 min before sending
<davexunit>should guile-user be CCd maybe, or would that be poor form?
<davexunit>not sure how to handle this. I want to raise the issue, but I don't want to start a flamewar or other unconstructive things.
<dsmith-work>Morning Greetings, Guilers
<mark_weaver>he will likely counter: "but I explicitly offered to 'post updates on behalf of authors who would like to continue to work that way'"
<mark_weaver>still, it's a problem because people will feel some pressure to use github directly.
<mark_weaver>for one thing, authur might not respond promptly to these update requests, especially since most people will be glad to use github directly.
<mark_weaver>for another thing, SRFI authors will feel pressure to use github's web interface to accept pull requests, and I guess that requires running non-free javascript code on your machine.
<mark_weaver>actually, I'm doubtful that one can even create an account on github without running proprietary javascript.
<dsmith-work>Wow. Didn't realize it was that crazy.
<wleslie>it's a usability nightmare anyway.
<wleslie>if you want to navigate pages with vi key commands, file a pull request against your browser.
<mark_weaver>heh :)
<mark_weaver>civodul: fyi, Arthur Gleckler, the new SRFI maintainer, will be moving the SRFI repos to github and encouraging the use of pull requests, etc, for working on the draft documents.
<mark_weaver> http://permalink.gmane.org/gmane.lisp.scheme.srfi.announce/119
<civodul>baaah, this is a shame
<civodul>then again, he took the responsibility while the rest of us were watching
<civodul>and maintaining a server takes time, too
<davexunit>yes. I think it would be good if we could voice our concerns whilst not seeming ungrateful.
<civodul>yeah
<ArneBab_>I can forward the mail, I wouldn’t like to post it publicly to avoid creating pressure on Arthur.
<ArneBab_>bbl
<paron_remote>hello #guile!
<paron_remote>I have one of several potential guile projects to work on today :)
<mark_weaver>so, I started to try to create an account on github with LibreJS enabled.
<davexunit>oh boy.
<mark_weaver>it tells me: "GitHub does not support browsers with JavaScript disabled. We promise we'll behave."
<paron_remote>ha
<mark_weaver>I was going to try proceeding anyway, but then saw this:
<mark_weaver>'By clicking on "Create an account" below, you are agreeing to the Terms of Service and the Privacy Policy.'
<mark_weaver>so, I'm currently looking at the Terms of Service. https://help.github.com/articles/github-terms-of-service/
<mark_weaver>first off, as usual, they can change the ToS at any time, and need only "post a notice on our site before the changes are effective", and then "Continued use of the Service after any such changes shall constitute your consent to such changes."
<mark_weaver>it's interesting that they make a much better promise to government users:
<mark_weaver>for government users, they promise to notify you in email of the changes at least 3 days in advance.
<mark_weaver> https://help.github.com/articles/amendment-to-github-terms-of-service-applicable-to-u-s-federal-government-users/
<paron_remote>ha
<mark_weaver>so github users had better read the ToS immediately before using the service, or else they could be agreeing to anything..
<paron_remote>mark_weaver: but not to the many contractors who build software these days for the government, I'm sure :)
<mark_weaver>paron_remote: yeah, it looks like your email address has to end with .gov, .mil, or .fed.us to qualify
<mark_weaver>(although I might be wrong on that point, I didn't look carefully)
<mark_weaver>the other significant promise github users make is to indemnify github for "reasonable attorney's fees incurred by" github in connection to "any claim, demans, suit, or proceeding made or brought against GitHub by a third-party alleging that Your Content, or Your use of the Service in violation of this Agreement, infringes or misappropriates the intellectual property rights of a third-party or violates applicable law"
<mark_weaver>*demand
<mark_weaver>of course, I can understand why they feel the need to have this clause. I don't think it's evil.
<unknown_lamer>blarg
<unknown_lamer>I need to finish dusting off hcoop so we could offer hosting for things like srfis
<mark_weaver>but it does mean that by signing up for github, you are promising to pay their attorney fees, even if you did nothing wrong
<paron_remote>unknown_lamer: oh cool, didn't know you're also an hcoop person
<unknown_lamer>I wouldn't hate github as much as I do but their pull request system locks you in and I've encountered a few packages (e.g. ttrss) where the maintain literally refuses to work with you unless you use github
<paron_remote>I've seen bipt's repos there
<unknown_lamer>paron_remote: I am root!
<paron_remote>unknown_lamer: fun :)
<unknown_lamer>fun, miserable, somewhere in there ;)
<civodul>xdje: in GDB, 'pretty-printers' returns the global pretty-printers, but only those implemented in Scheme, right?
<civodul>xdje: i was expecting it to return all the pretty-printers, regardless of their implementation language
<mark_weaver>hmm, I wonder what is the full meaning of this: "You agree not to reproduce, duplicate, copy, sell, resell or exploit any portion of the Service, use of the Service, or access to the Service without the express written permission by GitHub."
<mark_weaver>does that mean that you agree to never write a github-like service?
<wleslie>you can't create a competing implementation? really?
<wleslie>yeah, that's what I read
<mark_weaver>So "service" is defined near the top as "GitHub.com web site"
<mark_weaver>I guess it depends what "reproduce" means.
<wleslie>which you duplicate every time you navigate to a github.com page
<wleslie>and no exploitation, so you can't use the site either
<mark_weaver>there's hardly any legalese I can agree to these days. almost nobody reads any of it anymore, so the most draconian stuff is now widespread and considered normal.
<mark_weaver>the FSF's legalese is a most refreshing exception...
<wleslie>yees
<davexunit>yet programmers complain the loudest about it.
<davexunit>and praise github.
<unknown_lamer>mark_weaver: I think that clause is in the github tos so they can get you prosecuted under the cfaa if you h4x0r them
<wleslie>yes, but programmers also use ruby. they are a silly lot.
<unknown_lamer> https://kallithea-scm.org/ looks promising for a github replacement
<davexunit>just yesterday I was involved in a disagreement where someone blamed Guile's use of the LGPL as the reason why it cannot be used on iOS, playstation, xbox, etc.
<unknown_lamer>there's also a proposal to add activitystreams based federated pull requests
<mark_weaver>unknown_lamer: what does "h4x0r" mean? :)
<unknown_lamer>davexunit: ha! blaming the victim
<davexunit>I don't know how to counter such things.
<unknown_lamer>I just tell people they hate freedom and are destroying society and they should feel bad ;)
<davexunit>this idea that "permissive" licenses are the solution to companies imposing serious restrictions on their software/hardware platforms.
<unknown_lamer>... because permissive licenses aren't why we have those locked down systems in the first place
<unknown_lamer>I get into this argument a lot ha
<davexunit>if I say that I think the problem is with the companies I get responses like "yeah sure I'll just go talk to Sony to let me use Guile on PS3"
<unknown_lamer>it hurts because sony just provides the platform. the developers are who make sony their money.
<unknown_lamer>and strict signing etc screw over the developers... and they could just refuse but instead embrace it
<unknown_lamer>like all of my friends who hate DRM while loving that HTML5 + mozilla now have DRM for netflix...
<davexunit>yeah
<davexunit>I have such a love/hate relationship with software. I hope it doesn't kill me.
<unknown_lamer>"but not it works better!" right, but why are we accomodating them when they are being evil. If they want to do DRM, make it hard.
<taylanub>so essentially big corporations are deities, or forces of nature, in the minds of these people. they don't consider questioning the corporations' actions, just suit their own actions to what they do.
<unknown_lamer>what really scares me is that the accelerated video stuff in DRI/DRM could support DRMed video decoding hardware :-\\
<taylanub>^ re. the line about Sony
<unknown_lamer>and I bet it's coming
<taylanub>davexunit: maybe, if you make that clear to them, they will at least admit that they're taking a defeatist stance and view themselves as comparatively powerless :\\
<taylanub>(which is not exactly irrational either to be honest)
<davexunit>taylanub: perhaps, yeah.
***michel_mno is now known as michel_mno_afk
<ArneBab_>davexunit: my answer is that if a service actively forbids copyleft licenses, the provider of that service wants to lock out people who promise not to betray the user.
<davexunit>exactly.
<ArneBab_>it doesn’t mean that the LGPL is bad, but that the service which forbids it openly admits that it wants to betray its users - to the point of fighting anyone who shows that it’s possible to act differently.